View Issue Details

IDProjectCategoryView StatusLast Update
0006022DarkRadiantDesign/Codingpublic06.08.2022 11:21
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.1.0Fixed in Version3.1.0 
Summary0006022: Refactor/Extend Favourite Management
DescriptionIn the first implementation, the favourite manager introduced the decl::Type enumeration, which unfortunately lists both declarations and file resources (prefabs and models). The goal of this issue is to cleanup the decl::Type enumeration and generalise the favourite management code to be able to handle both type of resources.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 2707794b

2022-07-23 08:58:23

greebo

Details Diff
0006022: Rename ModResource.h to igameresource.h Affected Issues
0006022
mod - include/iarchive.h Diff File
mod - include/ideclmanager.h Diff File
mod - include/ieclass.h Diff File
mod - include/isound.h Diff File
mod - include/precompiled_interfaces.h Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File

DarkRadiant: master e106b55e

2022-07-23 12:56:15

greebo

Details Diff
0006022: ModResource is now game::IResource Affected Issues
0006022
mod - include/iarchive.h Diff File
mod - include/ideclmanager.h Diff File
mod - include/igameresource.h Diff File
mod - radiantcore/vfs/DirectoryArchive.h Diff File

DarkRadiant: master 500f8382

2022-07-23 16:30:43

greebo

Details Diff
0006022: Change IFavouritesManager interface - moving away from accepting decl::Type enumerations, the interface now operates on type name strings.
Adjust implementation, adjust and extend unit tests.
Affected Issues
0006022
mod - include/idecltypes.h Diff File
mod - include/ifavourites.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File
mod - radiant/ui/materials/MaterialPopulator.cpp Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/particles/ThreadedParticlesLoader.h Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiantcore/decl/FavouriteSet.h Diff File
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - radiantcore/decl/FavouritesManager.h Diff File
mod - test/Favourites.cpp Diff File
add - test/resources/settings/old_favourites.xml Diff File
rm - test/resources/settings/old_mediabrowser_favourites.xml Diff File

DarkRadiant: master 667e01bc

2022-07-23 16:35:51

greebo

Details Diff
0006022: Cleanup in FavouritesBrowser Affected Issues
0006022
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master 2086a1ca

2022-07-24 04:33:05

greebo

Details Diff
0006022: Remove decl::Type::Model, since it's not a declaration Affected Issues
0006022
mod - include/idecltypes.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/common/SoundChooser.cpp Diff File
mod - radiant/ui/materials/MaterialTreeView.cpp Diff File
mod - radiant/ui/modelselector/ModelTreeView.cpp Diff File
mod - radiant/ui/particles/ParticleSelector.cpp Diff File

DarkRadiant: master 36edf344

2022-07-24 16:16:29

greebo

Details Diff
0006022: Fix unit test file Affected Issues
0006022
mod - test/resources/settings/old_favourites.xml Diff File

Issue History

Date Modified Username Field Change
23.07.2022 06:51 greebo New Issue
23.07.2022 06:51 greebo Assigned To => greebo
23.07.2022 06:51 greebo Status new => assigned
24.07.2022 13:50 greebo Changeset attached => DarkRadiant master 2707794b
24.07.2022 13:50 greebo Changeset attached => DarkRadiant master e106b55e
24.07.2022 13:50 greebo Changeset attached => DarkRadiant master 500f8382
24.07.2022 13:50 greebo Changeset attached => DarkRadiant master 667e01bc
24.07.2022 13:50 greebo Changeset attached => DarkRadiant master 2086a1ca
24.07.2022 16:16 greebo Changeset attached => DarkRadiant master 36edf344
06.08.2022 11:21 greebo Status assigned => resolved
06.08.2022 11:21 greebo Resolution open => fixed
06.08.2022 11:21 greebo Fixed in Version => 3.1.0