View Issue Details

IDProjectCategoryView StatusLast Update
0006040DarkRadiantGUIpublic31.07.2022 16:15
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.1.0Fixed in Version3.1.0 
Summary0006040: Material Editor: preview renders shadows for noshadows materials
DescriptionThe material editor's preview object seems to cast a shadow even if the material source text has the noshadows keyword. Using the Advanced tab's "Global settings" to toggle noshadows does update shadowcasting correctly.

For example: textures/darkmod/metal/detailed/panel_circledesign01_brown_ns
TagsNo tags attached.

Activities

greebo

greebo

31.07.2022 15:51

administrator   ~0015102

This appears to be a problem that is happening earlier, the noshadows checkbox is unchecked, e.g. for the material textures/darkmod/metal/detailed/panel_circledesign01_brown_ns
grafik.png (33,032 bytes)   
grafik.png (33,032 bytes)   

Related Changesets

DarkRadiant: master 25ac8936

2022-07-31 16:13:40

greebo

Details Diff
0006040: Fix noShadows flag being cleared right after the first stage is added - this unintentionally clears the noshadows even in legit cases.
This will likely break something else since the code was put there on purpose, but this has to be solved somewhere else.
Affected Issues
0006040
mod - radiantcore/shaders/ShaderTemplate.cpp Diff File
mod - test/Materials.cpp Diff File
mod - test/resources/tdm/materials/parsertest.mtr Diff File

Issue History

Date Modified Username Field Change
31.07.2022 10:08 Dragofer New Issue
31.07.2022 10:10 Dragofer Description Updated
31.07.2022 10:11 Dragofer Description Updated
31.07.2022 15:05 greebo Status new => acknowledged
31.07.2022 15:51 greebo Note Added: 0015102
31.07.2022 15:51 greebo File Added: grafik.png
31.07.2022 15:51 greebo Status acknowledged => confirmed
31.07.2022 16:12 greebo Target Version => 3.1.0
31.07.2022 16:12 greebo Assigned To => greebo
31.07.2022 16:12 greebo Status confirmed => assigned
31.07.2022 16:15 greebo Changeset attached => DarkRadiant master 25ac8936
31.07.2022 16:15 greebo Status assigned => resolved
31.07.2022 16:15 greebo Resolution open => fixed
31.07.2022 16:15 greebo Fixed in Version => 3.1.0