View Issue Details

IDProjectCategoryView StatusLast Update
0006048DarkRadiantGUIpublic31.07.2022 17:08
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.1.0Fixed in Version3.1.0 
Summary0006048: Material Editor: allow to change preview background
DescriptionAs far as I can see, there's no way to change the background material used in the preview scene. Mappers might like to change this in order to thematically better match what they're working on (would also be suitable for being remembered from the previous session - 0006045).

It's possible mappers might choose the same background as the material they're working on. So maybe the background should be updated, too, whenever a change is made to its material.
TagsNo tags attached.

Relationships

related to 0006045 resolvedgreebo Material Editor: doesn't remember settings from previous session 
related to 0006050 resolvedgreebo Material Editor: suboptimal preview for cubeMap materials 

Activities

greebo

greebo

31.07.2022 15:48

administrator   ~0015101

The only way to change the material used in the preview "room" can be changed by editing the doom3.game or darkmod.game files:

    <materialPreview>
        <defaultRoomMaterial value="textures/darkmod/stone/brick/blocks_brown" />
        <defaultLightDef value="light_torchflame" />
    </materialPreview>

I assume you're hoping for an option to pick the material in the UI itself?
Dragofer

Dragofer

31.07.2022 16:08

developer   ~0015103

Yeah, I think picking the material from the UI would be best since it's a straightforward way to get a better idea of what the material will look like in the intended environment. Maybe the "Light Properties" tab could be renamed to "Preview Scene Properties" and expanded with a background material choice.

Related Changesets

DarkRadiant: master 3c099d32

2022-07-31 16:53:44

greebo

Details Diff
0006048: Fix unhandled decl type exception Affected Issues
0006048
mod - include/idecltypes.h Diff File

DarkRadiant: master d2dd67fb

2022-07-31 16:56:11

greebo

Details Diff
0006048: MaterialPreview allows setting the room material. Start setting up the MaterialEditor controls to support this Affected Issues
0006048
mod - install/ui/materialeditor.fbp Diff File
mod - install/ui/materialeditor.xrc Diff File
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File
mod - radiant/ui/materials/editor/MaterialEditor.h Diff File
mod - radiant/ui/materials/editor/MaterialPreview.cpp Diff File
mod - radiant/ui/materials/editor/MaterialPreview.h Diff File

DarkRadiant: master f7a228dd

2022-07-31 17:06:25

greebo

Details Diff
0006048: Wire up select button to choose the material of the test room Affected Issues
0006048
mod - radiant/ui/materials/editor/MaterialEditor.cpp Diff File

Issue History

Date Modified Username Field Change
31.07.2022 11:21 Dragofer New Issue
31.07.2022 11:21 Dragofer Relationship added related to 0006045
31.07.2022 12:05 Dragofer Relationship added related to 0006050
31.07.2022 15:05 greebo Status new => acknowledged
31.07.2022 15:48 greebo Status acknowledged => feedback
31.07.2022 15:48 greebo Note Added: 0015101
31.07.2022 16:08 Dragofer Note Added: 0015103
31.07.2022 16:08 Dragofer Status feedback => new
31.07.2022 16:08 Dragofer Status new => acknowledged
31.07.2022 16:08 Dragofer Status acknowledged => feedback
31.07.2022 16:27 greebo Status feedback => confirmed
31.07.2022 16:56 greebo Assigned To => greebo
31.07.2022 16:56 greebo Status confirmed => assigned
31.07.2022 16:56 greebo Target Version => 3.1.0
31.07.2022 17:06 greebo Changeset attached => DarkRadiant master 3c099d32
31.07.2022 17:06 greebo Changeset attached => DarkRadiant master d2dd67fb
31.07.2022 17:06 greebo Changeset attached => DarkRadiant master f7a228dd
31.07.2022 17:08 greebo Status assigned => resolved
31.07.2022 17:08 greebo Resolution open => fixed
31.07.2022 17:08 greebo Fixed in Version => 3.1.0