View Issue Details

IDProjectCategoryView StatusLast Update
0006081DarkRadiantRendererpublic04.09.2022 13:03
ReporterFrost_Salamander Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version3.1.0 
Target Version3.3.0Fixed in Version3.3.0 
Summary0006081: Some materials aren't displayed correctly
DescriptionSome materials aren't displayed correctly in DR.

These show up as black when used to texture an object:

- rough_wood_brown/rough_wood_brown_ns
- rough_wood_darkbrown/rough_wood_darkbrown_ns
- rough_wood_sand/rough_wood_sand_ns

This shows up as transparent:

- textures/darkmod/window/lamp_glass_moonlit_opaque

There may be others, but those are the ones I've noticed so far.

Steps To Reproduce1. Add a brush to a map and texture with any of the above materials
2. Observe the texture is black (or transparent in the case of the glass material)
TagsNo tags attached.

Activities

greebo

greebo

03.09.2022 14:51

administrator   ~0015224

I can confirm the rough wood textures are showing as black in fullbright render mode. The glass material doesn't appear as transparent in fullbright mode (it's transparent in lighting mode only).
Frost_Salamander

Frost_Salamander

03.09.2022 15:12

reporter   ~0015225

Odd - the glass does for me. See the below screen shots. Same map, same window, just different versions of DR.
dr3.0.0.PNG (371,937 bytes)
dr3.2.0.PNG (2,100,280 bytes)
greebo

greebo

03.09.2022 17:16

administrator   ~0015226

Last edited: 03.09.2022 17:17

I could fix the first problems with rough_wood. The moonlit opaque material is wrong in all renderer modes in DarkRadiant, it should appear as opaque and have an interaction pass (triggered by the single specular stage).
greebo

greebo

04.09.2022 05:36

administrator   ~0015227

The rgb expressions are now actively suppressed when rendering the editor preview pass.
Materials with just a single specular map (like the moonlit opaque one) are now properly treated as interaction materials.
greebo

greebo

04.09.2022 05:44

administrator   ~0015229

Comparison Screenies
grafik.png (494,965 bytes)
grafik-2.png (499,189 bytes)
grafik-3.png (749,073 bytes)
Frost_Salamander

Frost_Salamander

04.09.2022 09:54

reporter   ~0015231

awesome - thank you!

Related Changesets

DarkRadiant: master 859a4b24

2022-09-03 16:49:50

greebo

Details Diff
0006081: Remove unused RENDER_POINT_COLOUR flag. Affected Issues
0006081
mod - include/irender.h Diff File
mod - include/version.h Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/xyview/XYWnd.cpp Diff File
mod - radiantcore/rendersystem/backend/BuiltInShader.cpp Diff File

DarkRadiant: master b3971b05

2022-09-03 17:06:27

greebo

Details Diff
0006081: The default parm0-parm3 colour shader parms will evaluate to 1.0 if no entity is available Affected Issues
0006081
mod - radiantcore/shaders/ShaderExpression.h Diff File

DarkRadiant: master 41bc1243

2022-09-03 17:09:15

greebo

Details Diff
0006081: The editor preview pass should not be affected by the diffuse stage's colour modulation.
In many materials the editor image is already coloured such that it resembles the look of the diffuse in lighting mode, like in the rough_wood_brown material (where the diffuse is mostly grey but modulated with rgb expressions, its editor image is already coloured to simulate this). The editor preview pass is now actively suppressing all colour information from the associated stages when applying the glColor values.
Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLState.h Diff File

DarkRadiant: master 1626bdf1

2022-09-04 04:11:46

greebo

Details Diff
0006081: Adjust unit test now that parm0 to parm3 evaluate to 1 by default Affected Issues
0006081
mod - test/Materials.cpp Diff File

DarkRadiant: master 3ac88466

2022-09-04 05:03:44

greebo

Details Diff
0006081: Even if a material defines just a single specular, this will still count as interaction pass with a _black diffuse and a _flat bump.
Run the depth fill pass for such materials and make sure it doesn't crash due to the lacking diffuse stage.
Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File

DarkRadiant: master 581003ee

2022-09-04 05:07:21

greebo

Details Diff
0006081: Remove a bunch of leftover code Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: master 9656683d

2022-09-04 05:25:25

greebo

Details Diff
0006081: Move redundant loops finding the diffuse stage into one helper method Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File
mod - radiantcore/rendersystem/backend/OpenGLShader.h Diff File

DarkRadiant: master 263514af

2022-09-04 05:31:23

greebo

Details Diff
0006081: Evaluate the diffuse stage registers once before checking the alpha test value Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File

DarkRadiant: master 4b80af76

2022-09-04 05:34:24

greebo

Details Diff
0006081: Remove the old switch statement, it's no longer of use Affected Issues
0006081
mod - radiantcore/rendersystem/backend/OpenGLShader.cpp Diff File

Issue History

Date Modified Username Field Change
24.08.2022 17:13 Frost_Salamander New Issue
25.08.2022 03:35 greebo Status new => acknowledged
03.09.2022 14:51 greebo Status acknowledged => confirmed
03.09.2022 14:51 greebo Note Added: 0015224
03.09.2022 15:12 Frost_Salamander Note Added: 0015225
03.09.2022 15:12 Frost_Salamander File Added: dr3.0.0.PNG
03.09.2022 15:12 Frost_Salamander File Added: dr3.2.0.PNG
03.09.2022 17:09 greebo Assigned To => greebo
03.09.2022 17:09 greebo Status confirmed => assigned
03.09.2022 17:09 greebo Target Version => 3.3.0
03.09.2022 17:16 greebo Note Added: 0015226
03.09.2022 17:16 greebo Changeset attached => DarkRadiant master 859a4b24
03.09.2022 17:16 greebo Changeset attached => DarkRadiant master b3971b05
03.09.2022 17:16 greebo Changeset attached => DarkRadiant master 41bc1243
03.09.2022 17:17 greebo Note Edited: 0015226
04.09.2022 04:11 greebo Changeset attached => DarkRadiant master 1626bdf1
04.09.2022 05:34 greebo Changeset attached => DarkRadiant master 3ac88466
04.09.2022 05:34 greebo Changeset attached => DarkRadiant master 581003ee
04.09.2022 05:34 greebo Changeset attached => DarkRadiant master 9656683d
04.09.2022 05:34 greebo Changeset attached => DarkRadiant master 263514af
04.09.2022 05:34 greebo Changeset attached => DarkRadiant master 4b80af76
04.09.2022 05:36 greebo Status assigned => resolved
04.09.2022 05:36 greebo Resolution open => fixed
04.09.2022 05:36 greebo Fixed in Version => 3.3.0
04.09.2022 05:36 greebo Note Added: 0015227
04.09.2022 05:43 greebo File Deleted: grafik-3.png
04.09.2022 05:43 greebo File Deleted: grafik-2.png
04.09.2022 05:43 greebo File Deleted: grafik.png
04.09.2022 05:44 greebo Note Added: 0015229
04.09.2022 05:44 greebo File Added: grafik.png
04.09.2022 05:44 greebo File Added: grafik-2.png
04.09.2022 05:44 greebo File Added: grafik-3.png
04.09.2022 09:54 Frost_Salamander Note Added: 0015231
04.09.2022 13:03 greebo Category General => Renderer