View Issue Details

IDProjectCategoryView StatusLast Update
0006095DarkRadiantGUIpublic23.09.2022 09:08
Reporterorbweaver Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.0 
Target Version3.3.0Fixed in Version3.3.0 
Summary0006095: Remove menu options which are not applicable to current game
DescriptionThe Brush menu currently contains two options — Make Detail and Make Structural — which are only useful in games other than The Dark Mod. There should be a system to allow such game-specific menu options to only be shown if the particular game (as defined by the .game file) requires them.
TagsNo tags attached.

Activities

orbweaver

orbweaver

21.09.2022 19:36

developer   ~0015270

Implemented in 2e57c2131c99bfc09702eea34b8fb8d0dd11561b

Related Changesets

DarkRadiant: master db434479

2022-09-07 19:38:35

orbweaver

Details Diff
0006095: Make Detail and Make Structural disabled without selection Affected Issues
0006095
mod - radiantcore/selection/algorithm/General.cpp Diff File

DarkRadiant: master 9b05e8bd

2022-09-13 20:01:29

orbweaver

Details Diff
0006095: add a trivial test for the GameManager

This may not turn out to be all that useful, since the RadiantTest sets
up a fake game by responding on the message bus, and never actually
loads any .game files. Currently it is testing only that the game
manager can return the expected config struct which reflects the fake
game info populated by RadiantTest.
Affected Issues
0006095
mod - libs/string/split.h Diff File
mod - test/CMakeLists.txt Diff File
mod - test/DeclManager.cpp Diff File
mod - test/EntityClass.cpp Diff File
add - test/Game.cpp Diff File
mod - test/Particles.cpp Diff File
mod - test/RadiantTest.h Diff File

DarkRadiant: master e68aff09

2022-09-14 19:24:01

orbweaver

Details Diff
0006095: test sorted list of Game objects

Test that the IGameManager::getSortedGameList() method returns the
vector of games in the expected order (defined by the "index" property
in the XML file). To confirm which game is which, the getName() method
is exposed on the pure virtual interface (it was already present on the
implementing class).
Affected Issues
0006095
mod - include/igame.h Diff File
mod - radiantcore/settings/Game.cpp Diff File
mod - radiantcore/settings/Game.h Diff File
mod - test/Game.cpp Diff File

DarkRadiant: master 0c52b0bb

2022-09-14 19:46:41

orbweaver

Details Diff
0006095: test accessing some values from .game file

It turns out that the tests ARE loading .game files, although these are
not under the test/resources directory so it remains to be seen whether
this test will encounter any problems on other platforms. Possibly it
will only work if the main DR resources (i.e. install/*) are installed
to their expected location before the tests are run.
Affected Issues
0006095
mod - include/igame.h Diff File
mod - test/Game.cpp Diff File

DarkRadiant: master bb8c3bd5

2022-09-14 20:02:30

orbweaver

Details Diff
0006095: passing test for IGame::hasFeature()

Add the "detail_brushes" optional feature only to quake3.game, and
confirm that it appears on the expected IGame object.
Affected Issues
0006095
mod - install/games/quake3.game Diff File
mod - radiantcore/settings/Game.cpp Diff File
mod - test/Game.cpp Diff File

DarkRadiant: master 78620678

2022-09-20 20:00:52

orbweaver

Details Diff
0006095: don't create menu items for unsupported game features

The menu.xml allows a new "gamefeature" attribute to be applied to a
<menuItem> node. If present, this feature will be looked up in the
current game using the hasFeature() method, and the menu item will not
be created if the feature is not present.

This is used to hide the "Make Structural" and "Make Detail" menu items
for games which are not Quake 3.
Affected Issues
0006095
mod - install/games/darkmod.game Diff File
mod - install/menu.xml Diff File
mod - radiant/ui/menu/MenuElement.cpp Diff File
mod - radiant/ui/menu/MenuElement.h Diff File
mod - test/Game.cpp Diff File

DarkRadiant: master 2e57c213

2022-09-21 19:29:32

orbweaver

Details Diff
0006095: hide Game Connection functionality except in Dark Mod

Only the Dark Mod supports hot reload, so this functionality is now
gated by a hot_reload optional feature exposed only by the Dark Mod
.game file. In other games, neither the "Map → Game Connection" menu
item nor the associated camera toolbar buttons will appear.
Affected Issues
0006095
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File

Issue History

Date Modified Username Field Change
07.09.2022 19:04 orbweaver New Issue
07.09.2022 19:04 orbweaver Status new => assigned
07.09.2022 19:04 orbweaver Assigned To => orbweaver
21.09.2022 19:36 orbweaver Status assigned => resolved
21.09.2022 19:36 orbweaver Resolution open => fixed
21.09.2022 19:36 orbweaver Fixed in Version => 3.3.0
21.09.2022 19:36 orbweaver Note Added: 0015270
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master db434479
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master 9b05e8bd
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master e68aff09
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master 0c52b0bb
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master bb8c3bd5
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master 78620678
23.09.2022 09:08 orbweaver Changeset attached => DarkRadiant master 2e57c213