View Issue Details

IDProjectCategoryView StatusLast Update
0006158DarkRadiantGUIpublic22.11.2022 04:28
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.5.0 
Target Version3.6.0Fixed in Version3.6.0 
Summary0006158: ModelDefs are now shown in T-pose
DescriptionUntil now, AI entities were always shown with the model in a standing pose with arms hanging down the sides. Now they're all T-posing as if they had no animations assigned (which also exposes an old workaround where the spines in the base models are twisted 90° and should be rotated into the correct position by the animations defined in the modelDef).
Steps To Reproduce1) Right-click > Entity Chooser
2) View any AI entity, i.e. atdm:ai_guard_archer_01 from the attached image.
TagsNo tags attached.

Activities

Dragofer

Dragofer

11.11.2022 17:48

developer  

image.png (76,897 bytes)   
image.png (76,897 bytes)   

Related Changesets

DarkRadiant: master 75c62efc

12.11.2022 04:35

greebo


Details Diff
0006158: Apply the idle pose to models in the ModelPreview Affected Issues
0006158
mod - libs/entitylib.h Diff File
mod - libs/wxutil/preview/ModelPreview.cpp Diff File
mod - radiantcore/entity/ModelKey.cpp Diff File
mod - radiantcore/entity/ModelKey.h Diff File

DarkRadiant: master c99e3d7b

12.11.2022 05:50

greebo


Details Diff
0006158: Generalise the ModelPreview, split off an EntityPreview base class which might be more suitable for viewing entityDefs Affected Issues
0006158
mod - libs/wxutil/preview/ModelPreview.cpp Diff File
mod - libs/wxutil/preview/ModelPreview.h Diff File
mod - libs/wxutil/preview/RenderPreview.cpp Diff File
mod - plugins/dm.editing/AIHeadChooserDialog.cpp Diff File
mod - plugins/dm.editing/AIHeadChooserDialog.h Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File

DarkRadiant: master 44a15668

12.11.2022 06:01

greebo


Details Diff
0006158: Move EntityPreview to a separate file pair Affected Issues
0006158
mod - libs/wxutil/CMakeLists.txt Diff File
add - libs/wxutil/preview/EntityPreview.cpp Diff File
add - libs/wxutil/preview/EntityPreview.h Diff File
mod - libs/wxutil/preview/ModelPreview.cpp Diff File
mod - libs/wxutil/preview/ModelPreview.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: master 285c685e

12.11.2022 06:50

greebo


Details Diff
0006158: EntityClassPreview is inheriting from EntityPreview Affected Issues
0006158
mod - libs/wxutil/preview/EntityClassPreview.h Diff File
mod - libs/wxutil/preview/EntityPreview.cpp Diff File
mod - libs/wxutil/preview/EntityPreview.h Diff File
mod - libs/wxutil/preview/ModelPreview.cpp Diff File

DarkRadiant: master f2fc5089

12.11.2022 15:00

greebo


Details Diff
0006158: Fix crash due to race condition in EntityPreview Affected Issues
0006158
mod - libs/wxutil/preview/EntityPreview.cpp Diff File

DarkRadiant: master 6e4f5ca7

22.11.2022 04:17

greebo


Details Diff
0006158: Fix the unrotatable model in the preview, the func_static has to consider itself a model, which is determined by the "model" key value Affected Issues
0006158
mod - libs/wxutil/preview/ModelPreview.cpp Diff File

Issue History

Date Modified Username Field Change
11.11.2022 17:48 Dragofer New Issue
11.11.2022 17:48 Dragofer File Added: image.png
11.11.2022 17:49 Dragofer Description Updated
11.11.2022 17:49 Dragofer Steps to Reproduce Updated
12.11.2022 04:34 greebo Status new => confirmed
12.11.2022 04:34 greebo Assigned To => greebo
12.11.2022 04:34 greebo Status confirmed => assigned
12.11.2022 04:34 greebo Target Version => 3.6.0
12.11.2022 04:35 greebo Changeset attached => DarkRadiant master 75c62efc
12.11.2022 07:08 greebo Changeset attached => DarkRadiant master c99e3d7b
12.11.2022 07:08 greebo Changeset attached => DarkRadiant master 44a15668
12.11.2022 07:08 greebo Changeset attached => DarkRadiant master 285c685e
12.11.2022 07:51 greebo Status assigned => resolved
12.11.2022 07:51 greebo Resolution open => fixed
12.11.2022 07:51 greebo Fixed in Version => 3.6.0
12.11.2022 15:00 greebo Changeset attached => DarkRadiant master f2fc5089
22.11.2022 04:28 greebo Changeset attached => DarkRadiant master 6e4f5ca7