View Issue Details

IDProjectCategoryView StatusLast Update
0006243The Dark ModCodingpublic26.11.2023 16:57
ReporterBikerdude Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 (21H2)
Product VersionTDM 2.10 
Fixed in VersionTDM 2.12 
Summary0006243: Light volumes that should be culled bleeding into other vizleafs
DescriptionIn the map Welli and I are working on, there is a large single light in the fireplace on the ground floor.

With the player stood in the basement and after inputting "r_showLightCount 1" we can see way more lights hitting surfaces than there are light in that vizleaf.

So I stood still and look at each of the colours represeting amount of lights hitting surfaces -

red = 0
green = 1
blue = 2
cyan = 3
pink = 4
white = 5+

And the white stood out as I could see it moving like a candle or fireplace. So I then nocliped to the room above and doused that fireplace.

And then when that light off, I got a FPS improvement
Additional Information@nbohr1more comented -

"I wonder if some of this can be done at the dmap level since optimizing the realtime engine is a pretty challenging."
TagsNo tags attached.

Relationships

related to 0005190 assignedstgatilov Frontend optimizations due to connectedness of entities/surfaces 
related to 0005172 feedbackstgatilov Improve interaction culling: case when player-visible object is not visible from light 

Activities

Bikerdude

Bikerdude

25.01.2023 12:39

reporter  

after.jpg (21,746 bytes)   
after.jpg (21,746 bytes)   
before.png (45,935 bytes)   
before.png (45,935 bytes)   
stgatilov

stgatilov

25.01.2023 17:47

administrator   ~0015884

Light cannot be always culled by flowing through visportals.
Read linked 0005172 for explanation why.
stgatilov

stgatilov

04.06.2023 12:00

administrator   ~0016012

Last edited: 04.06.2023 12:00

Finally fixed in svn rev 10394:
  https://bugs.thedarkmod.com/view.php?id=5172#c16011

Lights no longer interact with entities in areas that their rays don't reach through portals.
With an important exception: the world geometry still casts shadows in all areas within light volume (regardless of portals).
Bikerdude

Bikerdude

26.11.2023 16:57

reporter   ~0016191

Thank you.

Issue History

Date Modified Username Field Change
25.01.2023 12:39 Bikerdude New Issue
25.01.2023 12:39 Bikerdude File Added: after.jpg
25.01.2023 12:39 Bikerdude File Added: before.png
25.01.2023 12:39 Bikerdude Relationship added related to 0005190
25.01.2023 12:40 Bikerdude Relationship added related to 0005172
25.01.2023 12:40 Bikerdude Additional Information Updated
25.01.2023 17:47 stgatilov Note Added: 0015884
04.06.2023 12:00 stgatilov Note Added: 0016012
04.06.2023 12:00 stgatilov Note Edited: 0016012
04.06.2023 12:00 stgatilov Assigned To => stgatilov
04.06.2023 12:00 stgatilov Status new => resolved
04.06.2023 12:00 stgatilov Resolution open => fixed
04.06.2023 12:00 stgatilov Fixed in Version => TDM 2.12
26.11.2023 16:57 Bikerdude Note Added: 0016191