View Issue Details

IDProjectCategoryView StatusLast Update
0000647DarkRadiantDesign/Codingpublic13.03.2009 12:32
ReporterJdude Assigned Togreebo  
PrioritylowSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
Product Version0.9.5 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000647: Strange entity production when trying to exit.
DescriptionSometimes after loading the model viewer and trying to place a model nothing happens. Trying again results in nothing once again. One can place brushes and work on clipping them and vertex manipulation but that is about it when this occurs. When one goes to exit, one will be prompt to save or not, save then try exiting. Instead of exiting the program will create the model (or entitie) that you wanted to create. Try again and the program will keep doing the same thing. I'm unsure how this glitch came to be but it has occurred three times on church.map soon after opening the program.
TagsNo tags attached.

Activities

greebo

greebo

21.04.2008 08:41

administrator   ~0001150

Can you give me some more details of how to reproduce that, step-by-step? What do you mean with "...trying to place a model nothing happens"? Which model are you trying to place?
Jdude

Jdude

22.04.2008 11:07

developer   ~0001151

It seems to randomly happen. I've had it occur 3 more times since I posted this.

Essentially I open Dark Radiant and create static models and entities of any kind. Eventually the editor will stop spawning the models or entity. You won't be able to do anything, you will click okay when you try and spawn either and nothing will have happened. Once you try and close the program it will ask you to save, click either yes or no and it won't exit the program but instead create the last item you were trying to make before it stopped. If you delete the item and try again it will just re-create the item. If you leave the item and try to close it will just not close. I've had this occur with even just roughly 10 models and 10 entities.
greebo

greebo

22.04.2008 11:33

administrator   ~0001152

I'll try to reproduce this. It seems to be a rather strange bug.
Jdude

Jdude

23.04.2008 04:58

developer   ~0001153

I found what is causing it today. Open Dark Radiant, create an entity, any entity. Re-open the entity window, highlight the same entity you made, click the [X] on the top right of the entity window, try re-opening the entity window, it won't open. Now try closing the program, it will do as I previously described.
greebo

greebo

18.09.2008 20:58

administrator   ~0001585

Last edited: 18.09.2008 21:00

I think this is fixed - jdude, I'm not entirely sure whether I understood your reproduction, but I believe I got it right. Clicking the X on the "Choose Entity..." dialog no longer yields undefined behaviour.

This fix will be in DarkRadiant 0.9.8pre5 and upwards.

Issue History

Date Modified Username Field Change
19.04.2008 05:35 Jdude New Issue
21.04.2008 08:41 greebo Note Added: 0001150
21.04.2008 08:41 greebo Status new => feedback
22.04.2008 11:07 Jdude Note Added: 0001151
22.04.2008 11:33 greebo Note Added: 0001152
23.04.2008 04:58 Jdude Note Added: 0001153
29.08.2008 11:38 greebo Target Version => 0.9.8
18.09.2008 20:52 greebo Status feedback => assigned
18.09.2008 20:52 greebo Assigned To => greebo
18.09.2008 20:58 greebo Note Added: 0001585
18.09.2008 20:58 greebo Status assigned => resolved
18.09.2008 20:58 greebo Fixed in Version => 0.9.8
18.09.2008 20:58 greebo Resolution open => fixed
18.09.2008 20:58 greebo Projection none => minor fix
18.09.2008 20:58 greebo ETA none => < 1 day
18.09.2008 20:58 greebo Build => 3781
18.09.2008 21:00 greebo Note Edited: 0001585
13.03.2009 12:32 greebo Status resolved => closed