View Issue Details

IDProjectCategoryView StatusLast Update
0000698DarkRadiantMap Editingpublic19.07.2014 07:10
ReporterAluminumHaste Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9.6 
Target Version1.8.0Fixed in Version1.8.0 
Summary0000698: "Floor" option for models and func_statics
DescriptionIn the elder scrolls editors they have an option called "Floor" when dealing with objects and what this does is drop the selected object down on the Z plane, until it encounters something and then it stops.
So putting things like bottles on a table was as easy as placing them over the table all wily nilly, then selecting them all and hitting the "Floor" button, which would cause them to drop down until they hit the table top and voilâ, all done.
TagsNo tags attached.

Activities

AluminumHaste

AluminumHaste

09.04.2009 18:36

updater   ~0002427

Can we get any love for this?
greebo

greebo

10.04.2009 13:49

administrator   ~0002430

Sorry, I don't have time for this right now, as I want to focus on TDM coding for the next month at least. It's a non-trivial feature, on top of that, and I suspect this is a lot of work.
greebo

greebo

01.09.2013 16:52

administrator   ~0006135

Implemented in a96f7ebb6d05bcba9ca2385350c333f7d4d1f609
AluminumHaste

AluminumHaste

01.09.2013 19:01

updater   ~0006136

Last edited: 01.09.2013 19:04

View 4 revisions

Man, thank you for trying this, after 5 years I didn't think this would every get looked at!

Okay I tried it, and it sort of works, items are moved down until the origin meets something (worldspawn or patch or entity).

This will probably need to be changed so that the lowest face from entity origin (in world orientation not entity orientation for obvious reasons) should be used to determine if something collides.

The detection algorithm works amazingly well, even on complicated patches the entity meets up perfectly.

Screenshots.

Before
http://imageshack.us/a/img35/9716/vwvm.png

After
http://imageshack.us/a/img542/1890/sf1x.png

greebo

greebo

01.09.2013 20:15

administrator   ~0006137

Done, as in the build linked here: http://forums.thedarkmod.com/topic/15030-darkradiant-174-pre-release-test/
AluminumHaste

AluminumHaste

02.09.2013 14:36

updater   ~0006140

Brushes drop to the center of their volume (the origin I presume), not the lowest vertex.
AluminumHaste

AluminumHaste

02.09.2013 14:52

updater   ~0006141

Strange crash issue. Steps to reproduce:

1) Create new map
2) Make a brush around origin
3) Create a room with the Make Room button
4) Texture it with wood texture, then deselect everything
5) Create Model in the room (I used furniture->tables->dining_table1.lwo)
6) With the model still selected, press Floor
7) Darkmod crashes.

I compiled a debug version and I get this runtime error:

Debug Assertion Failed!

Program: C:\Windows\system32\MSVCP110D.dll
File: C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\vector
Line: 72

Expression: vector iterator not dereferencable

Unable to attach a debugger for some reason when it crashes.
greebo

greebo

07.09.2013 18:06

administrator   ~0006168

Reproducable, the crash was due to degenerate faces which seem to happen occasionally. Fixed in git.

Issue History

Date Modified Username Field Change
29.05.2008 00:55 AluminumHaste New Issue
29.05.2008 06:24 greebo Status new => acknowledged
09.04.2009 18:36 AluminumHaste Note Added: 0002427
10.04.2009 13:49 greebo Note Added: 0002430
01.09.2013 16:51 greebo Assigned To => greebo
01.09.2013 16:51 greebo Status acknowledged => assigned
01.09.2013 16:51 greebo Fixed in Version => 1.8.0
01.09.2013 16:51 greebo Target Version => 1.8.0
01.09.2013 16:52 greebo Note Added: 0006135
01.09.2013 16:52 greebo Status assigned => resolved
01.09.2013 16:52 greebo Resolution open => fixed
01.09.2013 19:01 AluminumHaste Note Added: 0006136
01.09.2013 19:02 AluminumHaste Note Edited: 0006136 View Revisions
01.09.2013 19:02 AluminumHaste Note Edited: 0006136 View Revisions
01.09.2013 19:04 AluminumHaste Note Edited: 0006136 View Revisions
01.09.2013 20:15 greebo Note Added: 0006137
02.09.2013 14:36 AluminumHaste Note Added: 0006140
02.09.2013 14:52 AluminumHaste Note Added: 0006141
07.09.2013 18:06 greebo Note Added: 0006168
19.07.2014 07:10 greebo Status resolved => closed