View Issue Details

IDProjectCategoryView StatusLast Update
0000905DarkRadiantMap Editingpublic30.06.2008 14:29
Reporterlrice648 Assigned Togreebo  
Status closedResolutionfixed 
Product Version0.9.6 
Fixed in Version0.9.7 
Summary0000905: Crashes when attempting to split brush using clipper and shift+enter
DescriptionWas attempting to split roof brush with clipper and shift+enter (assuming that even works with the same buttons in DR as it does in D3 editor) Probably just my hell map.
TagsNo tags attached.


related to 0000881 closed Crashes when I attempt to create a brush by clicking on any of the grid views and program crashes 




29.06.2008 10:37

administrator   ~0001389

This doesn't seem to happen in my local build. I'll upload a new version from latest SVN and post a link in the public forums.

Could you try it out with that build again?


30.06.2008 00:47

reporter   ~0001396

I actually retried in the current build and it is working OK now, as well as the other problem I had had with not being able to create a brush by dragging in one of the grid views. I ignored it for a while and eventually accidentally tried expecting it to crash and it worked (the brush thing I mean, not the clipper).

I loaded a previous version (I've been saving an absurd number of backups) and it IS still happening in that version, I've tried with the new snapshot build and on many different brushes and it crashes every time. I'm uploading that exact map. If I'm the only one who's had this problem you could probably put it on a back burner, its working OK now in my current version of the map even in the old DR build.

Thanks for all your hard work.


30.06.2008 04:57

administrator   ~0001397

Hm, I tried that map you uploaded and I can drag new brushes in the orthoviews just fine. Weird, but it actually seems to be specific to your system/map/DarkRadiant combination.

Anyway, if the new build works, I think we can safely resolve this issue. :) Please close the issue if you can confirm this status.


30.06.2008 14:29

reporter   ~0001400

Problem seemed to have been specific to map at specific time and not a pervasive DR bug.

Issue History

Date Modified Username Field Change
28.06.2008 01:41 lrice648 New Issue
28.06.2008 01:41 lrice648 File Added:
29.06.2008 09:48 greebo Status new => acknowledged
29.06.2008 10:37 greebo Note Added: 0001389
29.06.2008 10:37 greebo Status acknowledged => feedback
29.06.2008 10:37 greebo File Deleted:
30.06.2008 00:47 lrice648 Note Added: 0001396
30.06.2008 00:49 lrice648 File Added:
30.06.2008 04:57 greebo Note Added: 0001397
30.06.2008 04:57 greebo Status feedback => resolved
30.06.2008 04:57 greebo Fixed in Version => 0.9.7
30.06.2008 04:57 greebo Resolution open => fixed
30.06.2008 04:57 greebo Assigned To => greebo
30.06.2008 04:57 greebo File Deleted:
30.06.2008 14:29 lrice648 Status resolved => closed
30.06.2008 14:29 lrice648 Note Added: 0001400
02.07.2008 14:38 greebo Relationship added related to 0000881