View Issue Details

IDProjectCategoryView StatusLast Update
0000098DarkRadiantMap Editingpublic10.03.2007 07:36
Reportergreebo Assigned Togreebo  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000098: Scale Manipulator is not functional, remove?
DescriptionI think it has been mentioned in the forums once, it should probably be removed, shouldn't it?
TagsNo tags attached.

Activities

orbweaver

orbweaver

11.02.2007 13:03

developer   ~0000083

If it's non-functional, then yes it should go.
greebo

greebo

11.02.2007 13:28

administrator   ~0000084

I'll look into it, perhaps I'll find the reason why the ScaleManipulator does not work and if it is easy to fix.
greebo

greebo

11.02.2007 17:51

administrator   ~0000088

I could fix the Scale manipulator. The FacePlane::transform() method did not normalise the plane normals after the transformation has been applied.
SneaksieDave

SneaksieDave

12.02.2007 22:47

developer   ~0000113

Last edited: 12.02.2007 22:48

Something seems strange here - I used it, and all seemed well in the X and Y directions. When I turned to the side to try Z direction, it only moved up instead of up and down, and then when I dragged down (to shrink) the brush appeared to blow up to maximum size (off the screen) or vanish. I used UNDO, and then went back to XY view, and noticed that it was no longer snapping to the grid.

Edit: Also, I notice that many times the origin axis (or whatever it's called) doesn't appear in the center of the brush, but sometimes off to the side, even up against one of the edges.

No reliable reproduction at this point, but just using it should show some of these results.

greebo

greebo

13.02.2007 21:59

administrator   ~0000128

I don't seem to be able to reproduce this. I switched the views several times, and the scale manipulator always stayed functional.
greebo

greebo

25.02.2007 18:43

administrator   ~0000224

SneaksieDave, your note text seems to be lost after the recent server issue, are there any updates on this?
SneaksieDave

SneaksieDave

26.02.2007 00:35

developer   ~0000232

Shit! :) Yes, I responded in detail, with images (now lost on) imageshack, even. Now I don't have that post anymore, so I'll try to sum up:

1. It's not just Z axis as I originally thought - it happens on any axis. Create a brush, and as soon as you scale it down to zero size (don't let go), the size jumps to something like 131074. Then, if you drag it any further, it jumps back to "normal" expected numbers. Undefined/unhandled values at 0.

2. After doing scaling around, zoom in and have a close look at your brush. It's probably no longer grid aligned. Happened each time I tried.

And finally, in conclusion,
3. It's not a tool I'd ever use, so I'm fine with it going away. It sucked in pretty much every editor I can remember (even being disabled in some - T3Ed, I think?) because it's apparently by-nature problematic, so I don't use it. :)
greebo

greebo

26.02.2007 07:22

administrator   ~0000239

It's only natural that the resulting brush is not aligned to the grid anymore (same with the rotation manipulator).

I wouldn't want to use this tool either, so if everyone agrees, I'll remove it after all.
greebo

greebo

26.02.2007 14:55

administrator   ~0000245

Scale manipulator disabled in latest SVN.

Issue History

Date Modified Username Field Change
11.02.2007 10:37 greebo New Issue
11.02.2007 10:37 greebo Status new => feedback
11.02.2007 13:03 orbweaver Note Added: 0000083
11.02.2007 13:03 orbweaver Status feedback => confirmed
11.02.2007 13:20 greebo Assigned To => greebo
11.02.2007 13:20 greebo Status confirmed => assigned
11.02.2007 13:28 greebo Note Added: 0000084
11.02.2007 17:51 greebo Status assigned => resolved
11.02.2007 17:51 greebo Fixed in Version => latest SVN
11.02.2007 17:51 greebo Resolution open => fixed
11.02.2007 17:51 greebo Note Added: 0000088
12.02.2007 22:47 SneaksieDave Status resolved => feedback
12.02.2007 22:47 SneaksieDave Resolution fixed => reopened
12.02.2007 22:47 SneaksieDave Note Added: 0000113
12.02.2007 22:48 SneaksieDave Note Edited: 0000113
13.02.2007 21:59 greebo Note Added: 0000128
23.02.2007 22:27 greebo Status feedback => assigned
23.02.2007 22:27 greebo Assigned To greebo => SneaksieDave
23.02.2007 22:27 greebo Status assigned => feedback
25.02.2007 18:43 greebo Note Added: 0000224
26.02.2007 00:35 SneaksieDave Note Added: 0000232
26.02.2007 07:22 greebo Note Added: 0000239
26.02.2007 07:22 greebo Status feedback => assigned
26.02.2007 07:22 greebo Assigned To => greebo
26.02.2007 14:55 greebo Status assigned => resolved
26.02.2007 14:55 greebo Resolution reopened => fixed
26.02.2007 14:55 greebo Note Added: 0000245
10.03.2007 07:36 greebo Status resolved => closed