View Issue Details

IDProjectCategoryView StatusLast Update
0000105DarkRadiantGUIpublic23.02.2007 02:22
ReporterSneaksieDave Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.1 
Fixed in Version0.9.0 
Summary0000105: Cannot close Light Properties with J
DescriptionLight Properties is not closed again by toggling J. So far that's the only one I know of that acts that way:

S can be toggled to open/close Surface props
Shift-S can be toggled to open/close Patch props
L toggled for entity list
etc.
TagsNo tags attached.

Activities

orbweaver

orbweaver

11.02.2007 20:51

developer   ~0000093

I don't like this, it is non-standard widget behaviour and a recipe for confusion. The texture list box provides typeahead, so a user might legitimately use the keyboard shortcut when typing a texture name. This would either result in the dialog closing unexpectedly, or produce inconsistent behaviour based on which widget was selected (J in texture view does typeahead, J anywhere else closes dialog).

I'm not in any hurry to remove this functionality from the other dialogs, since it doesn't seem to be doing any harm, but I am not particularly keen to take the time to code it (it would require special event handling in the dialog widget) given the usability gotchas involved.
SneaksieDave

SneaksieDave

11.02.2007 21:48

developer   ~0000098

You mean to remove the toggle behavior from all of them? Eep. If so, it'd become almost essential to have ESC function to close them (0000055). Mousing over and clicking a close button is a major pain when you must do it over and over again while working.

Isn't the framework already there for the other dialogs?
orbweaver

orbweaver

12.02.2007 11:41

developer   ~0000103

The ESC option sounds a lot better to me, since this key is commonly associated with "cancel" and will not confuse users or get in the way of widget typeahead.
SneaksieDave

SneaksieDave

12.02.2007 14:20

developer   ~0000105

Last edited: 12.02.2007 14:22

I was thinking on this further and it didn't occur to me that there is of course also the option to change the shortcuts:

S for surf props because Shift-A for instance
Shift S (patch props) could stay the same, because it's not single letter (so it causes no problem with letter seeking)

Anyway, if you guys go the ESC route, if it's not already in there, I might suggest an 'ESC queue' (with regard to this only) whereby it remembers what is next to be closed/deselected by LIFO order (don't know if that term applies here, but I think so?) So basically a user could still keep the properties window open by hitting ESC only once to deselect their texture, but not twice, which would close the dialog.

This is getting more and more confusing %)

SneaksieDave

SneaksieDave

20.02.2007 04:31

developer   ~0000167

Another reason this is important keeps biting me in the arse, so I thought I'd mention it: I do fullscreen camera frequently. Since J (and ESC) cannot be used to toggle or close the dialog, it keeps falling behind the camera, and then I sit there thinking DR is locked up. It gets me all the time. I end up minimizing the camera and voila, there's the light props dialog hiding in plain sight.
orbweaver

orbweaver

20.02.2007 11:54

developer   ~0000172

ESC now closes the dialog in SVN. However, you may not find this all that useful because if the dialog is cancelled the changes are not applied. This functionality may need to be paired with the "realtime update" whereby the changes would be applied immediately and the dialog would have a single Close button.
SneaksieDave

SneaksieDave

23.02.2007 02:22

developer   ~0000186

A simple thing, and so much better. :)

Issue History

Date Modified Username Field Change
11.02.2007 19:39 SneaksieDave New Issue
11.02.2007 20:51 orbweaver Note Added: 0000093
11.02.2007 20:51 orbweaver Status new => acknowledged
11.02.2007 21:48 SneaksieDave Note Added: 0000098
12.02.2007 11:41 orbweaver Note Added: 0000103
12.02.2007 14:20 SneaksieDave Note Added: 0000105
12.02.2007 14:22 SneaksieDave Note Edited: 0000105
20.02.2007 04:31 SneaksieDave Note Added: 0000167
20.02.2007 11:54 orbweaver Status acknowledged => resolved
20.02.2007 11:54 orbweaver Fixed in Version => latest SVN
20.02.2007 11:54 orbweaver Resolution open => fixed
20.02.2007 11:54 orbweaver Assigned To => orbweaver
20.02.2007 11:54 orbweaver Note Added: 0000172
23.02.2007 02:22 SneaksieDave Status resolved => closed
23.02.2007 02:22 SneaksieDave Note Added: 0000186