View Issue Details

IDProjectCategoryView StatusLast Update
0000115DarkRadiantMap Editingpublic07.04.2007 01:30
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000115: Can't move multi-part func statics selected with entity list?
DescriptionNot sure what's going on here, or why there might be a difference in behavior.

-Enter translate mode (W)
-Create a few patches, and collectively make them into a single func static
-Select all of them one by one, and drag the group around

However,
-Deselect all
-Open the entity list (L)
-Use the list to select the func static
-Try to drag the group around as before

I see two different behaviors here; either they don't move at all, as if they're stuck, or only one moves while the other parts stay stuck.
TagsNo tags attached.

Relationships

parent of 0000117 closedgreebo Func_* brushes don't show origin 

Activities

greebo

greebo

13.02.2007 07:19

administrator   ~0000117

Confirmed. This behaviour is a bit weird.
greebo

greebo

26.02.2007 14:12

administrator   ~0000244

This is partly resolved. Switch to Entity Selection mode to select the func_static entity itself and transform it (it's also possible to select the func_static via the Entity List). The origin is moved along with the entity (although it shows up at the new origin after the operation has finised).

Switch to "normal" brush selection mode to select the single brushes and move them independently of their parent func_static.

Rotation seems to be broken somehow.
SneaksieDave

SneaksieDave

07.04.2007 01:30

developer   ~0000533

There is an anticipated overhaul of selection and multi-ents, but this is at least behaving consistently, so I think it's okay to close it.

Issue History

Date Modified Username Field Change
12.02.2007 23:18 SneaksieDave New Issue
13.02.2007 07:19 greebo Note Added: 0000117
13.02.2007 07:19 greebo Status new => confirmed
26.02.2007 09:46 greebo Relationship added parent of 0000117
26.02.2007 09:46 greebo Status confirmed => assigned
26.02.2007 09:46 greebo Assigned To => greebo
26.02.2007 14:12 greebo Status assigned => resolved
26.02.2007 14:12 greebo Fixed in Version => latest SVN
26.02.2007 14:12 greebo Resolution open => fixed
26.02.2007 14:12 greebo Note Added: 0000244
07.04.2007 01:30 SneaksieDave Status resolved => closed
07.04.2007 01:30 SneaksieDave Note Added: 0000533