View Issue Details

IDProjectCategoryView StatusLast Update
0000117DarkRadiantMap Editingpublic04.03.2007 15:54
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.1 
Fixed in Version0.9.0 
Summary0000117: Func_* brushes don't show origin
DescriptionI haven't tried them all, but I've noticed that func_liquid and func_static don't show their origins visually in the iso views. It's usually essential to be able to see the origin when positioning it manually.
TagsNo tags attached.

Relationships

child of 0000115 closedgreebo Can't move multi-part func statics selected with entity list? 

Activities

orbweaver

orbweaver

13.02.2007 10:42

developer   ~0000124

Last edited: 13.02.2007 10:43

Known issue. In theory it would be good to be able to move the origin as well as just show it.

greebo

greebo

26.02.2007 10:34

administrator   ~0000242

The origin is now showing up correctly (the RenderablePivot implementation was seemingly half-finished). A few bugs are still remaining though and this might take a bit.
greebo

greebo

26.02.2007 14:08

administrator   ~0000243

Rendering of the origin is fixed in SVN.
SneaksieDave

SneaksieDave

27.02.2007 02:43

developer   ~0000250

Do I have to do anything to enable it? So far I don't see it on func_doors, func_statics, etc.

http://img410.imageshack.us/my.php?image=noorigincd6.jpg
greebo

greebo

27.02.2007 08:03

administrator   ~0000254

That's because I haven't uploaded the snapshot yet ;) Uploading now...
SneaksieDave

SneaksieDave

28.02.2007 01:02

developer   ~0000266

It looks like this is working, however a quick question: is there a reason not to show origins for entities like func_emitter or func_damage, etc? DoomEd does, though I can't personally say if it's needed or not. The origin value exists though, so I'd be concerned not to include it.
greebo

greebo

28.02.2007 09:06

administrator   ~0000272

The func_emitter is a small cube in the first place, I don't think it's necessary to render the origin (= center of the cube) as well.

If this is really needed, I can look into it though, but there may exist more pressing issues available.
SneaksieDave

SneaksieDave

28.02.2007 21:14

developer   ~0000288

No problem, I just worried that there might be a reason for it. I don't know what happens if a particle has the origin offset, for instance.
SneaksieDave

SneaksieDave

04.03.2007 15:54

developer   ~0000322

I guess we can close this, hoping that such items never need their origins shown (I don't know of an example where they do), and re-open if ever necessary.

Issue History

Date Modified Username Field Change
13.02.2007 02:58 SneaksieDave New Issue
13.02.2007 10:42 orbweaver Note Added: 0000124
13.02.2007 10:42 orbweaver Status new => confirmed
13.02.2007 10:43 orbweaver Note Edited: 0000124
26.02.2007 07:14 greebo Status confirmed => assigned
26.02.2007 07:14 greebo Assigned To => greebo
26.02.2007 07:14 greebo Category GUI => Map Editing
26.02.2007 09:46 greebo Relationship added child of 0000115
26.02.2007 10:34 greebo Note Added: 0000242
26.02.2007 14:08 greebo Note Added: 0000243
26.02.2007 14:09 greebo Status assigned => resolved
26.02.2007 14:09 greebo Fixed in Version => latest SVN
26.02.2007 14:09 greebo Resolution open => fixed
27.02.2007 02:43 SneaksieDave Note Added: 0000250
27.02.2007 02:44 SneaksieDave Status resolved => feedback
27.02.2007 02:44 SneaksieDave Resolution fixed => reopened
27.02.2007 08:03 greebo Note Added: 0000254
27.02.2007 08:05 greebo Status feedback => resolved
27.02.2007 08:05 greebo Resolution reopened => fixed
28.02.2007 01:02 SneaksieDave Status resolved => feedback
28.02.2007 01:02 SneaksieDave Resolution fixed => reopened
28.02.2007 01:02 SneaksieDave Note Added: 0000266
28.02.2007 09:06 greebo Note Added: 0000272
28.02.2007 21:14 SneaksieDave Note Added: 0000288
03.03.2007 11:28 greebo Status feedback => resolved
03.03.2007 11:28 greebo Resolution reopened => fixed
04.03.2007 15:54 SneaksieDave Status resolved => closed
04.03.2007 15:54 SneaksieDave Note Added: 0000322