View Issue Details

IDProjectCategoryView StatusLast Update
0001709DarkRadiantGUIpublic24.02.2021 19:59
ReporterSneaksieDave Assigned Toorbweaver  
PrioritylowSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.9.12 
Target Version2.12.0Fixed in Version2.12.0 
Summary0001709: Show light_radius on 'other' entities
DescriptionUsing one of our powerful new complex-defined light entities (e.g., /lights/static/atdm:torch_gothic_wall) can be a pain, because we can't see how large the light is. As a workaround, I've been creating a regular light next to it and sizing that, in order to copy/paste the size info to the complex entity. The idea arose: how about scanning for and displaying the "light_radius" property, regardless of the entity? (in this case "set light_radius on flame") That way, even though the entity is not a light, the user has a wysiwyg way of adjusting the size in DR.

Edit: Just wanted to add a quick note: one thing this would help mitigate is the doubled-lights problem we're likely going to see a lot of, where a mapper adds a light combo entity (like the torch-light combo), and then since they can't see or adjust the light, assumes they must then add a standalone light entity. So this (the 'show light_radius' version of the request) holds at least some higher status than showing all def-attached items.
TagsNo tags attached.

Relationships

duplicate of 0000994 resolvedorbweaver Show attached (light) entities 

Activities

orbweaver

orbweaver

24.02.2021 19:59

developer   ~0013728

I think this is now resolved by the implementation of 0000994.

Issue History

Date Modified Username Field Change
23.03.2009 15:12 SneaksieDave New Issue
23.03.2009 16:37 greebo Status new => acknowledged
22.04.2009 13:45 SneaksieDave Description Updated
09.12.2010 21:28 tels Relationship added duplicate of 0000994
08.01.2012 11:58 orbweaver Assigned To => orbweaver
08.01.2012 11:58 orbweaver Status acknowledged => assigned
08.01.2012 11:58 orbweaver Severity minor => normal
24.02.2021 19:59 orbweaver Status assigned => resolved
24.02.2021 19:59 orbweaver Resolution open => fixed
24.02.2021 19:59 orbweaver Fixed in Version => 2.12.0
24.02.2021 19:59 orbweaver Note Added: 0013728
24.02.2021 19:59 orbweaver Target Version => 2.12.0