View Issue Details

IDProjectCategoryView StatusLast Update
0000994DarkRadiantMap Editingpublic05.09.2021 18:21
Reportertels Assigned Toorbweaver  
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionfixed 
Target Version2.12.0Fixed in Version2.12.0 
Summary0000994: Show attached (light) entities
DescriptionWhen an entity has some light or another entity attached, these are not visible in the editor. This makes it hard for mappers to see what exactly the entity represents.

The wish here would be that the attached entity/entities are drawn in dashed or dotted form, and these entities are selected together with the base entity.
Additional InformationAs example see atdm:moveable_candle1
TagsNo tags attached.

Relationships

has duplicate 0001709 closedorbweaver Show light_radius on 'other' entities 

Activities

tels

tels

08.01.2012 10:07

reporter   ~0004229

Apparently, for lights, the combined light entites are also not rendered as lights, and it is not possible to adjust their radius/color easily, the mapper has to use the "set _color on flame" syntax manually.
orbweaver

orbweaver

26.07.2020 20:31

developer   ~0012682

Adjusting severity to Major since while this is a feature request, it is a pretty serious limitation of the renderer and makes the lighting preview mode almost useless since no entity-based lights are actually shown as lights.
Judith

Judith

11.08.2020 16:20

reporter   ~0012722

Last edited: 11.08.2020 16:24

I think this might have something to do with the way with how these entities were made, i.e. as models with lights as attachments. In every other engine I used, lights with physical representation (model / static mesh) were always a child class of the light class itself. It was always like GeneralLightClass -> SpecificLightClass -> SpecificLightWithStaticMeshClass. In one of my TDM WIPs I made lights like that, and IIRC, they were visible in lit mode. Will check that when I have time.
orbweaver

orbweaver

24.11.2020 19:53

developer   ~0013016

@Judith is correct — if object-based lights are children of the "light" class they should function correctly as lights in DR, and should even show the correct model if this is set as the "model" spawnarg (although they wouldn't show any additional attached objects, or particles). The problem is with non-light objects which spawn attached light entities at runtime, which are currently "invisible" to DR since it does not process attachments at all.

But for better or worse, we can't insist that the entire mod asset tree is restructured, and we need to handle this in DR somehow.
orbweaver

orbweaver

11.02.2021 20:24

developer   ~0013675

As of 2e35762cbab4f7cb66a7934ae2423791c758d963 the basic functionality required by this issue is implemented. Attached light sources render as lights in both preview and full-lighting mode. There is a lot more that could be done on this (e.g. showing attached heads on AI, allowing attached lights to be edited or resized), but these are much lower priority and can be tracked as separate issues.
greebo

greebo

12.02.2021 04:34

administrator   ~0013676

Nice!

Related Changesets

DarkRadiant: master d82be950

2021-02-12 04:51:33

greebo

Details Diff
0000994: Adjust VC++ projects Affected Issues
0000994
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

Issue History

Date Modified Username Field Change
22.07.2008 18:54 tels New Issue
09.12.2010 21:28 tels Relationship added has duplicate 0001709
08.01.2012 10:07 tels Note Added: 0004229
08.01.2012 11:58 orbweaver Assigned To => orbweaver
08.01.2012 11:58 orbweaver Status new => assigned
26.07.2020 20:31 orbweaver Severity feature => major
26.07.2020 20:31 orbweaver Note Added: 0012682
11.08.2020 16:20 Judith Note Added: 0012722
11.08.2020 16:24 Judith Note Edited: 0012722
24.11.2020 19:53 orbweaver Note Added: 0013016
11.02.2021 20:24 orbweaver Status assigned => resolved
11.02.2021 20:24 orbweaver Resolution open => fixed
11.02.2021 20:24 orbweaver Fixed in Version => 2.12.0
11.02.2021 20:24 orbweaver Note Added: 0013675
11.02.2021 20:26 orbweaver Target Version => 2.12.0
12.02.2021 04:34 greebo Note Added: 0013676
12.02.2021 06:12 greebo Changeset attached => DarkRadiant master d82be950
05.09.2021 18:21 greebo Status resolved => closed