View Issue Details

IDProjectCategoryView StatusLast Update
0001711DarkRadiantMap Editingpublic20.06.2010 08:03
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.9.12 
Target Version1.1.0Fixed in Version1.1.0 
Summary0001711: Mapped texture doesn't match texture tool display
DescriptionI haven't a guess whether this is a texture tool bug, or a proper consequence of some arrangement of vertexes in a patch. I see this sometimes, and have reproduced it in the attached map for examination. The TT shows a rectangle across two tiles of a texture. The cam view shows something entirely different, as if the vertexes are inverted and the patch split in half and glued back together from the inside out. Original post with images:

http://modetwo.net/darkmod/index.php?s=&showtopic=4581&view=findpost&p=179762

As a side note (instead of a separate issue): what are those diagonal lines shown in the TT? I can't figure out what they correspond to, or if they're a bug.
TagsNo tags attached.

Activities

23.03.2009 18:32

 

temparch1.zip (1,849 bytes)
SneaksieDave

SneaksieDave

03.01.2010 18:52

developer   ~0002834

While the second half of the issue (the diagonal lines) appears to be fixed (they're gone), I still get the same result for the first half. I may not have explained well, or chose a good image to display the problem.

See pic 0000002 in the original post linked. Note that the UV tiling in the Texture Tool show tiling of "Shader Not Found | Shader Not Found"

However, the actual mapping on the patch shows only part of the texture,
"Shader Not | Not Found"
It's as if the center of the tiling is missing.
greebo

greebo

11.01.2010 11:54

administrator   ~0002878

Ah, very subtle. The patch in the above testmap is a 7x3 patch, where the patch rows 3 to 5 are cramped together at the same 3D location, hence the middle part of the tiling (which is assigned to those rows) is not visible in 3D view, but in the UV editor.

Issue History

Date Modified Username Field Change
23.03.2009 18:32 SneaksieDave New Issue
23.03.2009 18:32 SneaksieDave File Added: temparch1.zip
24.03.2009 07:14 greebo Status new => acknowledged
18.11.2009 06:26 greebo Status acknowledged => assigned
18.11.2009 06:26 greebo Assigned To => greebo
18.11.2009 06:26 greebo Status assigned => resolved
18.11.2009 06:26 greebo Fixed in Version => 1.0.3
18.11.2009 06:26 greebo Resolution open => fixed
18.11.2009 06:27 greebo Projection none => minor fix
18.11.2009 06:27 greebo ETA none => half an hour
18.11.2009 06:27 greebo Build => 4928
18.11.2009 06:27 greebo Target Version => 1.0.3
03.01.2010 18:52 SneaksieDave Note Added: 0002834
03.01.2010 18:52 SneaksieDave Status resolved => feedback
11.01.2010 11:54 greebo Note Added: 0002878
11.01.2010 11:54 greebo Status feedback => resolved
20.06.2010 08:03 greebo Status resolved => closed