View Issue Details

IDProjectCategoryView StatusLast Update
0000175DarkRadiantMap Editingpublic25.03.2007 15:13
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.0 
Fixed in Version0.9.0 
Summary0000175: Rotation Modes
DescriptionI thought this was already tracked (I know I mentioned it on the boards) but now I don't see it, so here goes:

Create (for example) three cubes, move them into a triangular distribution, and skew it some so it is not equilateral. Make them all into one func_door. Then, move the origin so it is far enough off from center that it's noticable. Now enter rotation mode and rotate the door around as a whole.

Note that it rotates around the center point of those three objects, not the origin. DoomEd supports three (broken) important rotation modes:

1. rotation around the object center (as in DR)
2. rotation around the object origin (since it can be different from center - seems to be broken)
3. rotation of each component of the complex object, each around its own center (at least, I think that is the intent - very broken)

For comparison, these (broken) modes are toggled in DoomEd with ctrl-R.
TagsNo tags attached.

Relationships

related to 0000023 closedgreebo Configurable centre of rotation for multiple entities 

Activities

greebo

greebo

14.03.2007 22:35

administrator   ~0000413

See discussion thread here: http://modetwo.net/darkmod/index.php?showtopic=5577.

This is partially resolved and can be re-opened if the third rotation mode is really important.
SneaksieDave

SneaksieDave

25.03.2007 15:13

developer   ~0000494

I personally think the third mode is of little importance for any example I can think of. The other two seem to work great, so that's yet another improvement over DoomEd. :)

Issue History

Date Modified Username Field Change
04.03.2007 18:32 SneaksieDave New Issue
04.03.2007 19:15 greebo Status new => acknowledged
09.03.2007 22:44 greebo Relationship added related to 0000023
13.03.2007 07:13 greebo Status acknowledged => assigned
13.03.2007 07:13 greebo Assigned To => greebo
14.03.2007 22:35 greebo Status assigned => resolved
14.03.2007 22:35 greebo Fixed in Version => latest SVN
14.03.2007 22:35 greebo Resolution open => fixed
14.03.2007 22:35 greebo Note Added: 0000413
25.03.2007 15:13 SneaksieDave Status resolved => closed
25.03.2007 15:13 SneaksieDave Note Added: 0000494