View Issue Details

IDProjectCategoryView StatusLast Update
0002253DarkRadiantGeneralpublic20.06.2010 17:43
Reportergrayman Assigned Togreebo  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformWin32OSWindowsOS VersionXP
Product Version1.3.1 
Target Version1.3.2Fixed in Version1.3.2 
Summary0002253: NURB spline data is broken
DescriptionDR is confused about NURB spline control point coordinates. When you create a new spline, the coordinate set begins with (0 0 0 ...), suggesting that the data is stored as offsets from the absolute origin.

When the game moves something along this spline, however, the curve followed will begin at (0,0,0), not at the origin of the spline.

If you reload the map, the spline will have moved from where you placed it to (0,0,0). As if DR is reading the coordinate offsets as absolutes.

Steps To ReproduceCreate a NURB spline. The first control point is shown as (0,0,0), regardless of where the origin is. Select and drag the spline and it will move correctly. Save the map and reopen it. The spline will be shown starting at (0,0,0), instead of where you left it.

DR is misinterpreting the control point data. After looking at politics.map (see below) I can see that this data is supposed to be stored as absolute coordinates.
Additional InformationOpen politics.map, the first of the 3 NHAT missions.

Search the entity list for the spline named "spline_cam1".

Its points are shown as (3483.18994140625 -7426.23193359375 -2072.91015625 ...). These are absolute coordinates. This spline was created with an earlier version of DR.

Drag the spline. It will disappear off the map, because DR is treating the control point coordinates as offsets from the spline origin. When the game runs, TDM treats the coordinates (correctly) as absolute.

Mortem Desino reports that DR didn't behave this way prior to 1.3.0.
TagsNo tags attached.

Relationships

related to 0002020 closedgreebo NURBS curves are not displayed correctly 
related to 0002148 closedgreebo Nurbs do not set focus when switching views 

Activities

grayman

grayman

20.06.2010 17:43

administrator   ~0003079

Verified.

Thanks! (Now I can make my cutscene.)

Issue History

Date Modified Username Field Change
10.06.2010 00:26 grayman New Issue
10.06.2010 16:03 greebo Status new => acknowledged
10.06.2010 16:04 greebo Priority high => normal
20.06.2010 09:50 greebo Relationship added related to 0002020
20.06.2010 09:50 greebo Relationship added related to 0002148
20.06.2010 09:51 greebo Status acknowledged => assigned
20.06.2010 09:51 greebo Assigned To => greebo
20.06.2010 09:51 greebo Target Version => 1.3.2
20.06.2010 09:52 greebo Status assigned => resolved
20.06.2010 09:52 greebo Fixed in Version => 1.3.2
20.06.2010 09:52 greebo Resolution open => fixed
20.06.2010 17:43 grayman Note Added: 0003079
20.06.2010 17:43 grayman Status resolved => closed