View Issue Details

IDProjectCategoryView StatusLast Update
0002561The Dark ModCodingpublic13.03.2012 06:47
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Fixed in VersionTDM 1.08 
Summary0002561: AI responding to alerts from far across map
DescriptionI have a medium-sized city map, and I'm noticing that AI are being alerted at ridiculous distances. I lured one guard to a far corner of the map, killed him, and then shot a noise arrow. About two minutes later (the time it takes the AI to run from one end of the map to the other) 4 AI from the opposite side of the map show up with their weapons drawn!

I've checked the visportals, and they're all working. there are at least seven or eight different areas between the two spots, so there's no way sound should be traveling that far. Something odd is definitely going on.


I've never heard this come up before, but two other mappers have commented on it in the last two weeks, so I'm assuming this is a new problem.


http://modetwo.net/darkmod/index.php?/topic/12182-ai-being-alerted-clear-across-the-map/page__pid__245251__st__0&#entry245251
TagsNo tags attached.

Relationships

related to 0002211 closedSpringheel Noisemaker arrows disobey sound dropoff, occlusion 

Activities

Springheel

Springheel

30.01.2011 21:55

administrator   ~0003518

Last edited: 30.01.2011 22:03

View 2 revisions

This has been reported as wrecking The Alchemist map, which lends evidence to it being a new problem.


I'm going to see if I can reproduce this in a testmap.

nbohr1more

nbohr1more

31.01.2011 21:57

developer   ~0003520

Any relation to issue 0002334?

That was targeted for v1.03?
Springheel

Springheel

01.02.2011 12:04

administrator   ~0003528

Ok, test/city.map is up.
nbohr1more

nbohr1more

16.02.2011 05:06

developer   ~0003589

Looks like a duplicate of 2211
nbohr1more

nbohr1more

17.11.2011 00:58

developer   ~0004151

Last edited: 17.11.2011 01:00

View 2 revisions

Does 2903 fix this as well?

Springheel

Springheel

20.11.2011 23:31

administrator   ~0004172

I haven't noticed this recently.
Springheel

Springheel

12.03.2012 23:59

administrator   ~0004404

Marking resolved until someone notices this again.

Issue History

Date Modified Username Field Change
22.01.2011 12:57 Springheel New Issue
30.01.2011 21:55 Springheel Note Added: 0003518
30.01.2011 21:55 Springheel Assigned To => Springheel
30.01.2011 21:55 Springheel Status new => assigned
30.01.2011 22:03 Springheel Note Edited: 0003518 View Revisions
31.01.2011 21:57 nbohr1more Note Added: 0003520
01.02.2011 12:04 Springheel Note Added: 0003528
01.02.2011 12:05 Springheel Assigned To Springheel =>
04.02.2011 20:46 Springheel Assigned To => Springheel
04.02.2011 20:46 Springheel Status assigned => new
16.02.2011 05:06 nbohr1more Note Added: 0003589
19.02.2011 03:28 Springheel Assigned To Springheel =>
17.11.2011 00:58 nbohr1more Note Added: 0004151
17.11.2011 01:00 nbohr1more Note Edited: 0004151 View Revisions
20.11.2011 23:31 Springheel Note Added: 0004172
12.03.2012 20:19 tels Relationship added related to 0002211
12.03.2012 23:59 Springheel Note Added: 0004404
12.03.2012 23:59 Springheel Status new => resolved
12.03.2012 23:59 Springheel Resolution open => fixed
12.03.2012 23:59 Springheel Assigned To => Springheel
13.03.2012 06:47 tels Resolution fixed => unable to reproduce
13.03.2012 06:47 tels Fixed in Version => TDM 1.08