View Issue Details

IDProjectCategoryView StatusLast Update
0002677The Dark ModCodingpublic06.07.2012 15:46
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityrandom
Status resolvedResolutionfixed 
Product VersionTDM 1.03 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0002677: Weapon behaviour interrupted
DescriptionAt least three times over two nights of play, I clicked the mouse to swing the blackjack, and instead of swinging, the arm raised and then froze in place. A subsequent click swung it normally. It triggered a memory I had of a while ago, having similar behaviour with the bow...
Yes, I've had this. Click mouse, bow is readied. Release mouse, nothing. Another click, arrow is shot. This occured when I was trying to fire the bow very fast.

http://modetwo.net/darkmod/index.php?/topic/12419-weapon-issue-in-104/
TagsNo tags attached.

Relationships

has duplicate 0003164 resolvedgrayman Player arm freezes when attack button pressed 

Activities

grayman

grayman

07.03.2011 01:24

administrator   ~0003709

Last edited: 07.03.2011 01:27

View 2 revisions

With a simple map with me and two guards, I couldn't reproduce the problem. I knocked one guard out from behind, then fought like heck with the other, beating the crap out of him with the bj before he killed me.

I tested both 1.04 and SVN.

At no time did the arm freeze on the upswing.

There must be other conditions that apply.

What map?

Was the freeze after a cutscene? Cutscenes were mentioned in the thread.

Was the freeze after a quicksave/quickload?

After a regular game save/load?

I tried both forms of save/load and didn't have a problem.

Edit: Ditto with shooting arrows. No problem.

grayman

grayman

07.03.2011 01:29

administrator   ~0003710

I see you filed this against 1.03.

Does the problem exist in 1.04? The weapon-switching changes are in 1.04.
Springheel

Springheel

07.03.2011 01:53

administrator   ~0003711

It's only happened to me a handful of times so I'm not sure how to reproduce it. I can't be sure it's 1.03...I have a recollection of it happening a month or two ago with the bow, but I can't be sure which version.
grayman

grayman

27.01.2012 13:38

administrator   ~0004280

I've seen this twice with the bow in the past month while working with 1.08. Not very reproducible.
Springheel

Springheel

04.07.2012 02:47

administrator   ~0004685

Siyah has nailed it. The issue happens after looking at a map and then putting it away. That's why we never noticed it in testmaps.
grayman

grayman

06.07.2012 15:46

administrator   ~0004695

Duplicate of 0003164, which has been fixed in 1.08.

Issue History

Date Modified Username Field Change
06.03.2011 18:30 Springheel New Issue
07.03.2011 00:50 Springheel Assigned To => grayman
07.03.2011 00:50 Springheel Status new => assigned
07.03.2011 01:24 grayman Note Added: 0003709
07.03.2011 01:24 grayman Status assigned => feedback
07.03.2011 01:27 grayman Note Edited: 0003709 View Revisions
07.03.2011 01:29 grayman Note Added: 0003710
07.03.2011 01:53 Springheel Note Added: 0003711
07.03.2011 01:53 Springheel Status feedback => assigned
27.01.2012 13:38 grayman Note Added: 0004280
04.07.2012 02:45 Springheel Relationship added has duplicate 0003164
04.07.2012 02:47 Springheel Note Added: 0004685
06.07.2012 15:46 grayman Note Added: 0004695
06.07.2012 15:46 grayman Status assigned => resolved
06.07.2012 15:46 grayman Resolution open => fixed
06.07.2012 15:46 grayman Fixed in Version => TDM 1.08
06.07.2012 15:46 grayman Target Version => TDM 1.08