View Issue Details

IDProjectCategoryView StatusLast Update
0003164The Dark ModCodingpublic06.07.2012 15:45
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityrandom
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003164: Player arm freezes when attack button pressed
DescriptionHitting the attack with the BJ causes the player's arm to raise up and freeze there. You must hit the attack button again to swing.

Can also happen with bows.

TagsNo tags attached.

Relationships

duplicate of 0002677 resolvedgrayman Weapon behaviour interrupted 

Activities

SiyahParsomen

SiyahParsomen

03.07.2012 06:33

reporter   ~0004683

Problem: Weapon rises but doesn't strike after viewing map. Sequence: View and close map by using button or attack button. Then hitting attack button while weapon is drawn(bj,sword,bow) cause weapon to set but not strike. It needs using attack button again to do. Strangely no problem while using map button to close map or with any other readables from inventory.

Probably same issue: http://bugs.angua.at/view.php?id=2677
grayman

grayman

06.07.2012 15:45

administrator   ~0004694

When putting a map away, the inventory map script didn’t tell the SDK to clear the “current displayed map”. The subsequent ATTACK key release wasn’t allowed to fire a raised weapon because it thought the ATTACK key belonged to the action of putting the map away.

Clearing the “current displayed map” allowed the subsequent ATTACK key release to fire the weapon.

rev. 5489:

Player.cpp
Player.h

rev. 13023:

tdm_events.script
tdm_inventory_map.script

Issue History

Date Modified Username Field Change
01.07.2012 01:10 Springheel New Issue
03.07.2012 06:33 SiyahParsomen Note Added: 0004683
04.07.2012 02:45 Springheel Relationship added duplicate of 0002677
06.07.2012 15:45 grayman Note Added: 0004694
06.07.2012 15:45 grayman Assigned To => grayman
06.07.2012 15:45 grayman Status new => resolved
06.07.2012 15:45 grayman Resolution open => fixed
06.07.2012 15:45 grayman Product Version TDM 1.08 => TDM 1.07
06.07.2012 15:45 grayman Fixed in Version => TDM 1.08
06.07.2012 15:45 grayman Target Version => TDM 1.08