View Issue Details

IDProjectCategoryView StatusLast Update
0002754DarkRadiantMap Editingpublic11.10.2012 19:04
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.6.1 
Target Version1.7.0Fixed in Version1.7.0 
Summary0002754: Clipped brush parts always go into default layer
DescriptionEven if the default layer is hidden, clipped brush fragments are assigned to the default layer at all times.

The solution should make them go into the same layer as the brush they've been clipped off from.
TagsNo tags attached.

Relationships

child of 0002494 closedFidcal New entities not going into expected layer 

Activities

grayman

grayman

31.07.2011 15:53

administrator   ~0003965

Thank you. This one's been plaguing me a lot.
grayman

grayman

24.08.2011 18:22

administrator   ~0004001

I just wanted to note that clipped brushes don't always go into the default layer. They'll go into the first visible layer, regardless of whether it's "default" or not.

If the fix is to make clipped brushes stay in the same layer, that solves the above problem.
greebo

greebo

24.08.2011 19:09

administrator   ~0004002

Yes, that's the fix:

// Put the fragment in the same layer as the brush it was clipped from
scene::assignNodeToLayers(fragmentNode, node->getLayers());

Issue History

Date Modified Username Field Change
11.05.2011 17:02 greebo New Issue
11.05.2011 17:02 greebo Status new => assigned
11.05.2011 17:02 greebo Assigned To => greebo
11.05.2011 17:02 greebo Relationship added child of 0002494
11.05.2011 17:11 greebo Status assigned => resolved
11.05.2011 17:11 greebo Fixed in Version => 1.6.2
11.05.2011 17:11 greebo Resolution open => fixed
31.07.2011 05:24 greebo Target Version 1.6.2 => 1.7.0
31.07.2011 05:25 greebo Fixed in Version 1.6.2 => 1.7.0
31.07.2011 15:53 grayman Note Added: 0003965
24.08.2011 18:22 grayman Note Added: 0004001
24.08.2011 19:09 greebo Note Added: 0004002
11.10.2012 19:04 greebo Status resolved => closed