View Issue Details

IDProjectCategoryView StatusLast Update
0002758The Dark ModGUIpublic15.05.2020 14:05
Reporterjacobalbano Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status assignedResolutionreopened 
PlatformLinuxOSUbuntuOS Version10.04
Product VersionTDM 1.05 
Target VersionTDM 2.09 
Summary0002758: Arms detach from body on pause
DescriptionWhen pausing the game while an arrow is drawn, the player's arms detach from the camera for as long as the attack key is held down.
Steps To ReproduceSelect any arrow
Begin attack
Without releasing the attack key, open the pause menu
Still holding the attack key, press the pause button again to close the menu
Move the player around.
TagsNo tags attached.

Relationships

related to 0002509 new blackjack idle 
related to 0005001 resolvedstgatilov Glitch with sword renders weapons unusable 

Activities

nbohr1more

nbohr1more

15.12.2018 19:57

developer   ~0010938

Unable to reproduce:

1) There is no pause menu button other than escape (ESC) to menu
2) Escaping to menu with the weapon held at attack does not produce this issue when returning
3) The closest function we have to pause it g_stopTime and it does not cause the arm to become detached.

The only thing even close to this issue in current builds is issue 2509
jacobalbano

jacobalbano

15.12.2018 20:17

reporter   ~0010939

Last edited: 15.12.2018 20:38

View 2 revisions

With all due respect, unless this has been fixed in a version that has yet to be released, it's *not* "fixed". See below for a video that I just recorded minutes ago, on the most recent version of TDM.

https://www.youtube.com/watch?v=xHLMmA5J3l0

jacobalbano

jacobalbano

15.12.2018 20:29

reporter   ~0010940

This also happens with melee weapons:

https://www.youtube.com/watch?v=bbuM81VASCI

The only difference here is that your weapon is permanently locked a backswing and you can't even switch to another item.

> There is no pause menu button other than escape (ESC) to menu

This is the button I was referring to, yes.

Was there any attempt made to reproduce this or was it simply deemed unlikely to be valid?
grayman

grayman

15.12.2018 20:58

administrator   ~0010941

Haha! That's pretty funny.

greebo apparently was able to reproduce it originally, but he never fixed it.

Since then, it got covered over by the sands of time.

I reproduced it in the SVN version.

I don't know if I can fix it in 2.07, but if not, I'll put it on the 2.08 TODO list.
nbohr1more

nbohr1more

16.12.2018 02:25

developer   ~0010942

Thanks for the video.
It took a little fiddling but I can now reproduce this issue as well.
nbohr1more

nbohr1more

13.05.2020 04:53

developer   ~0012501

This still happens in 2.08 but I cannot reproduce the "locked" melee issue.

I can release the un-tethered sword-arm and everything returns to normal.

Can anyone reproduce the "lock" issue?
nbohr1more

nbohr1more

14.05.2020 19:40

developer   ~0012515

Shall I move this to 2.09?
grayman

grayman

15.05.2020 09:09

administrator   ~0012518

I have no time to look at this, so please move to 2.09.

Issue History

Date Modified Username Field Change
15.05.2011 13:27 jacobalbano New Issue
16.05.2011 04:49 greebo Status new => acknowledged
15.12.2018 19:54 nbohr1more Relationship added related to 0002509
15.12.2018 19:57 nbohr1more Note Added: 0010938
15.12.2018 19:59 nbohr1more Assigned To => grayman
15.12.2018 19:59 nbohr1more Status acknowledged => closed
15.12.2018 19:59 nbohr1more Resolution open => unable to reproduce
15.12.2018 19:59 nbohr1more Fixed in Version => TDM 2.07
15.12.2018 19:59 nbohr1more Target Version => TDM 2.07
15.12.2018 20:17 jacobalbano Note Added: 0010939
15.12.2018 20:17 jacobalbano Status closed => feedback
15.12.2018 20:17 jacobalbano Resolution unable to reproduce => reopened
15.12.2018 20:29 jacobalbano Note Added: 0010940
15.12.2018 20:29 jacobalbano Status feedback => assigned
15.12.2018 20:38 jacobalbano Note Edited: 0010939 View Revisions
15.12.2018 20:58 grayman Note Added: 0010941
15.12.2018 20:59 grayman Fixed in Version TDM 2.07 =>
16.12.2018 02:25 nbohr1more Note Added: 0010942
18.12.2018 05:26 grayman Assigned To grayman =>
18.12.2018 05:26 grayman Status assigned => acknowledged
30.12.2018 10:23 STiFU Target Version TDM 2.07 => TDM 2.08
04.01.2020 04:56 stgatilov Relationship added related to 0005001
13.05.2020 04:53 nbohr1more Note Added: 0012501
14.05.2020 19:39 nbohr1more Assigned To => grayman
14.05.2020 19:39 nbohr1more Status acknowledged => assigned
14.05.2020 19:40 nbohr1more Note Added: 0012515
15.05.2020 09:09 grayman Note Added: 0012518
15.05.2020 14:05 nbohr1more Target Version TDM 2.08 => TDM 2.09