View Issue Details

IDProjectCategoryView StatusLast Update
0005001The Dark ModDesign/Codingpublic09.03.2020 11:19
Reporterteh_saccade Assigned Tostgatilov  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformpcOSwin10OS Version1803
Product VersionTDM 2.06 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0005001: Glitch with sword renders weapons unusable
DescriptionAll weapons will do this, but when applied to the sword - the result is that the player cannot change weapons. All other interactions are unaffected.

The sword will fire on return from menu, but (unlike all other weapons) the sword will remain chambered.

This persists through saves, if made, requiring a restart to fix.
Steps To ReproduceHold fire with any weapon, press esc. twice, move - release fire/switch weapon to reset.
Additional Informationhttps://youtu.be/nqrJskJgrkQ
TagsNo tags attached.

Relationships

related to 0002758 assigned Arms detach from body on pause 
related to 0002509 new blackjack idle 

Activities

teh_saccade

teh_saccade

02.03.2019 12:47

reporter   ~0011663

shouldering a body - weapon is restored as chambered still.
stgatilov

stgatilov

03.01.2020 09:56

administrator   ~0012037

You can also walk away, turn back and see your hand with a sword in air =)
stgatilov

stgatilov

03.01.2020 10:56

administrator   ~0012038

Fixed in svn rev 15768.

In my testing, only sword attack get stuck completely. The reason is: script code waits until attack animation becomes "done" without any other conditions. In this case going to main menu and back makes animation "paused", so this script code gets stuck waiting for animation forever. I have added a workaround in this wait loop: it continually checks if animation is paused, and unpauses it in such case. I hope it won't case much trouble.

Another issue is that while you are still holding attack button when returning from main menu, you can walk around and see your hand midair =) This affects all weapons: blackjack, bows, etc. I hope it is rare enough to ignore it =)
stgatilov

stgatilov

04.01.2020 04:57

administrator   ~0012054

Found related issue 0002758 about the last thing --- seeing your arm+weapon in air =)
stgatilov

stgatilov

04.01.2020 05:00

administrator   ~0012056

And another one is about blackjack: 0002509

Issue History

Date Modified Username Field Change
02.03.2019 12:38 teh_saccade New Issue
02.03.2019 12:47 teh_saccade Note Added: 0011663
03.01.2020 09:56 stgatilov Note Added: 0012037
03.01.2020 10:56 stgatilov Note Added: 0012038
03.01.2020 10:57 stgatilov Assigned To => stgatilov
03.01.2020 10:57 stgatilov Status new => resolved
03.01.2020 10:57 stgatilov Resolution open => fixed
03.01.2020 10:57 stgatilov Fixed in Version => TDM 2.08
04.01.2020 04:56 stgatilov Relationship added related to 0002758
04.01.2020 04:57 stgatilov Note Added: 0012054
04.01.2020 04:59 stgatilov Relationship added related to 0002509
04.01.2020 05:00 stgatilov Note Added: 0012056
09.03.2020 11:19 stgatilov Target Version => TDM 2.08