View Issue Details

IDProjectCategoryView StatusLast Update
0002841The Dark ModAIpublic21.12.2018 21:42
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionTDM 1.06 
Target VersionTDM 2.04Fixed in VersionTDM 2.04 
Summary0002841: AI have problems with double doors marked "shouldBeClosed"
DescriptionThis is actually two problems:

1. When a double door has both doors marked "shouldBeClosed", and one is opened, a stim alerts a nearby AI. He'll then search around the doors, closing and opening them in a (seemingly) random sequence. When done, he might leave one or both doors open when he walks away.

2. The amount of light needed for the AI to notice the open door seems low. I have an AI patrolling w/in 100 units of an open sBC door, in a low-light area, and he doesn't see it until I turn my lantern on and stand near the door to light it up. If there's enough light for him to walk around and see where he's going, he ought to be able to notice that a door next to him is open.
TagsNo tags attached.

Relationships

related to 0004240 closedgrayman AI will not close "shouldbeclosed 1" atdm:mover_door_sliding 
related to 0002959 resolvedgrayman Let AI investigate a low-lighting shouldBeClosed door if they handle it 
related to 0004077 resolvedgrayman Two AI in St. Lucia hung up using adjacent doors 
related to 0003745 resolvedgrayman AI gets confused when a double door's movement is interrupted 

Activities

grayman

grayman

01.09.2011 05:01

administrator   ~0004012

A thread discussion of 0000002 decided that if there isn't enough light for the AI to notice the door, and it seems odd that he's not, the mapper should add a light nearby so the AI can see the door.
nbohr1more

nbohr1more

21.12.2018 21:41

developer   ~0011011

No recent reports.

Door handling fixes between 1.08 and 2.04 have addressed this.

Issue History

Date Modified Username Field Change
19.08.2011 20:57 grayman New Issue
19.08.2011 20:57 grayman Status new => assigned
19.08.2011 20:57 grayman Assigned To => grayman
01.09.2011 05:01 grayman Note Added: 0004012
24.11.2017 16:39 grayman Assigned To grayman =>
24.11.2017 16:39 grayman Status assigned => new
06.06.2018 14:44 nbohr1more Relationship added related to 0004823
06.06.2018 15:10 nbohr1more Relationship deleted related to 0004823
21.12.2018 21:25 nbohr1more Relationship added related to 0004240
21.12.2018 21:35 nbohr1more Relationship added related to 0002959
21.12.2018 21:40 nbohr1more Relationship added related to 0004077
21.12.2018 21:40 nbohr1more Relationship added related to 0003745
21.12.2018 21:41 nbohr1more Note Added: 0011011
21.12.2018 21:42 nbohr1more Assigned To => grayman
21.12.2018 21:42 nbohr1more Status new => resolved
21.12.2018 21:42 nbohr1more Resolution open => unable to reproduce
21.12.2018 21:42 nbohr1more Fixed in Version => TDM 2.04
21.12.2018 21:42 nbohr1more Target Version => TDM 2.04