View Issue Details

IDProjectCategoryView StatusLast Update
0003137DarkRadiantDesign/Codingpublic27.08.2013 14:32
Reportersalamanderrake Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
PlatformAmd64OSGentooOS Version10.1
Product Version1.7.0 
Target Version1.8.0Fixed in Version1.8.0 
Summary0003137: Darkradiant Segmentation Fault == > MenuManager: Could not find insertPath: (etc.)
DescriptionLatest git build of darkradiant seg faults when run.
** latest stable 1.7.1 build fails in the same way.
Steps To ReproduceBuild Darkradiant:
./autogen.sh
./configure --prefix=/opt/darkradiant
make -j5
sudo make install

then run Darkradiant (the loading screen does show up):
cd /opt/darkradiant/bin
./darkradiant
Segmentation fault

Additional InformationThe pertaining part of the log starts here:
...
ScriptModule: Found 6 commands.
MenuManager: Could not find insertPath: main/help
MenuManager: Could not find insertPath: main/file/refreshShaders
SelectionSetManager::initialiseModule called.
SoundManager: initialising sound playback
WaveFrontModule::initialiseModule called
MenuManager: Could not find insertPath: main/file/createCM
MenuManager: Could not find insertPath: main/file/exit

ldd output:

ldd /opt/darkradiant/bin/darkradiant
        linux-vdso.so.1 => (0x00007fffcffbc000)
        libboost_filesystem-mt-1_47.so.1.47.0 => /usr/lib64/libboost_filesystem-mt-1_47.so.1.47.0 (0x00007f50596f4000)
        libboost_system-mt-1_47.so.1.47.0 => /usr/lib64/libboost_system-mt-1_47.so.1.47.0 (0x00007f50594f0000)
        libboost_regex-mt-1_47.so.1.47.0 => /usr/lib64/libboost_regex-mt-1_47.so.1.47.0 (0x00007f5059204000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f5059000000)
        libscenegraph-1.7.1.so => /opt/darkradiant/lib/darkradiant/libscenegraph-1.7.1.so (0x00007f5058de2000)
        libgtkutil-1.7.1.so => /opt/darkradiant/lib/darkradiant/libgtkutil-1.7.1.so (0x00007f5058a98000)
        libgtkglextmm-x11-1.2.so.0 => /usr/lib64/libgtkglextmm-x11-1.2.so.0 (0x00007f505888f000)
        libgdkglextmm-x11-1.2.so.0 => /usr/lib64/libgdkglextmm-x11-1.2.so.0 (0x00007f5058679000)
        libgtkglext-x11-1.0.so.0 => /usr/lib64/libgtkglext-x11-1.0.so.0 (0x00007f5058475000)
        libgdkglext-x11-1.0.so.0 => /usr/lib64/libgdkglext-x11-1.0.so.0 (0x00007f505820e000)
        libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00007f5057fa0000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f5057c88000)
        libXmu.so.6 => /usr/lib64/libXmu.so.6 (0x00007f5057a6e000)
        libXt.so.6 => /usr/lib64/libXt.so.6 (0x00007f5057806000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007f50575fd000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007f50573e0000)
        libpangox-1.0.so.0 => /usr/lib64/libpangox-1.0.so.0 (0x00007f50571d2000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f5056e90000)
        libGLEW.so.1.6 => /usr/lib64/libGLEW.so.1.6 (0x00007f5056c24000)
        libgtksourceviewmm-2.0.so.2 => /usr/lib64/libgtksourceviewmm-2.0.so.2 (0x00007f50569cc000)
        libgtkmm-2.4.so.1 => /usr/lib64/libgtkmm-2.4.so.1 (0x00007f5056344000)
        libgtksourceview-2.0.so.0 => /usr/lib64/libgtksourceview-2.0.so.0 (0x00007f50560d5000)
        libatkmm-1.6.so.1 => /usr/lib64/libatkmm-1.6.so.1 (0x00007f5055e87000)
        libgdkmm-2.4.so.1 => /usr/lib64/libgdkmm-2.4.so.1 (0x00007f5055c35000)
        libgiomm-2.4.so.1 => /usr/lib64/libgiomm-2.4.so.1 (0x00007f5055926000)
        libpangomm-1.4.so.1 => /usr/lib64/libpangomm-1.4.so.1 (0x00007f50556f7000)
        libglibmm-2.4.so.1 => /usr/lib64/libglibmm-2.4.so.1 (0x00007f5055488000)
        libcairomm-1.0.so.1 => /usr/lib64/libcairomm-1.0.so.1 (0x00007f5055261000)
        libsigc-2.0.so.0 => /usr/lib64/libsigc-2.0.so.0 (0x00007f505505b000)
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f5054a1e000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f5054769000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f5054546000)
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f50541f7000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f5053fc9000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f5053dbc000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f5053b9b000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f505388c000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f505363f000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f5053408000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f5053168000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f5052f52000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f5052d42000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f5052b17000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f50528c7000)
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f50526c3000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f50524ba000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f5052197000)
        libftgl.so.2 => /usr/lib64/libftgl.so.2 (0x00007f5051f69000)
        libxmlutil-1.7.1.so => /opt/darkradiant/lib/darkradiant/libxmlutil-1.7.1.so (0x00007f5051d64000)
        libmath-1.7.1.so => /opt/darkradiant/lib/darkradiant/libmath-1.7.1.so (0x00007f5051b59000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f5051802000)
        libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6 (0x00007f50514f9000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f5051277000)
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libgcc_s.so.1 (0x00007f5051061000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f5050e44000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f5050ab6000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f5059917000)
        libnvidia-tls.so.295.49 => /usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.295.49 (0x00007f50508b3000)
        libnvidia-glcore.so.295.49 => /usr/lib64/libnvidia-glcore.so.295.49 (0x00007f504e579000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f504e365000)
        libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f504e160000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f504df41000)
        libpng15.so.15 => /usr/lib64/libpng15.so.15 (0x00007f504dd13000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f504db08000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f504d901000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f504d6fe000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f504d4ee000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f504d2e5000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f504d0da000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f504ced7000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f504ccd4000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f504cabd000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f504c834000)
        libEGL.so.1 => /usr/lib64/libEGL.so.1 (0x00007f504c61a000)
        libffi.so.5 => /usr/lib64/libffi.so.5 (0x00007f504c411000)
        libicuuc.so.49 => /usr/lib64/libicuuc.so.49 (0x00007f504c098000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f504be94000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f504bc8e000)
        libX11-xcb.so.1 => /usr/lib64/libX11-xcb.so.1 (0x00007f504ba8c000)
        libxcb-dri2.so.0 => /usr/lib64/libxcb-dri2.so.0 (0x00007f504b888000)
        libxcb-xfixes.so.0 => /usr/lib64/libxcb-xfixes.so.0 (0x00007f504b681000)
        libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f504b475000)
        libicudata.so.49 => /usr/lib64/libicudata.so.49 (0x00007f504a155000)
TagsNo tags attached.

Relationships

duplicate of 0003190 closedgreebo DarkRadiant segfaults on start 
has duplicate 0003204 closedgreebo Segmentation Fault - libgtkmm 

Activities

salamanderrake

salamanderrake

23.05.2012 06:46

reporter  

darkradiant.log (15,343 bytes)   
Started logging to /home/salamanderrake/.darkradiant/darkradiant.log
Today is: Wed May 23 02:45:16 2012
This is DarkRadiant 1.7.1 x64 
gtkmm Version: 2.24.2
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/fonts.so'
Module registered: FontManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/grid.so'
Module registered: Grid
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/vfspk3.so'
Module registered: VirtualFileSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/filetypes.so'
Module registered: FileTypes
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/scenegraph.so'
Module registered: SceneGraph
Module registered: SceneGraphFactory
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/filters.so'
Module registered: FilterSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/uimanager.so'
Module registered: UIManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/mapdoom3.so'
Module registered: Doom3MapLoader
Module registered: Quake4MapLoader
Module registered: Doom3PrefabLoader
Module registered: MapCompiler
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/commandsystem.so'
Module registered: CommandSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/skins.so'
Module registered: ModelSkinCache
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/eventmgr.so'
Module registered: EventManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/eclassmgr.so'
Module registered: EntityClassManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/model.so'
Module registered: ModelLoaderMD3
Module registered: ModelLoader3DS
Module registered: ModelLoaderASE
Module registered: ModelLoaderMS3D
Module registered: ModelLoaderMDC
Module registered: ModelLoaderMD2
Module registered: ModelLoaderFM
Module registered: ModelLoaderLWO
Module registered: ModelLoaderPICOTERRAIN
Module registered: ModelLoaderOBJ
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/md5model.so'
Module registered: ModelLoaderMD5MESH
Module registered: MD5AnimationCache
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/image.so'
Module registered: ImageLoaderTGA
Module registered: ImageLoaderJPG
Module registered: ImageLoaderPNG
Module registered: ImageLoaderPCX
Module registered: ImageLoaderBMP
Module registered: ImageLoaderDDS
Module registered: ImageLoaderGDK
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/particles.so'
Module registered: ParticlesManager
Module registered: ParticlesEditor
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/entitylist.so'
Module registered: EntityList
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/archivezip.so'
Module registered: ArchivePK4
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/shaders.so'
Module registered: MaterialManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/entity.so'
Module registered: Doom3EntityCreator
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/undo.so'
Module registered: UndoSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/xmlregistry.so'
Module registered: XMLRegistry
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/sound.so'
Module registered: SoundManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/script.so'
Module registered: ScriptingSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/plugins/eclasstree.so'
Module registered: EClassTree
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/plugins/wavefront.so'
Module registered: WaveFrontExporter
ArchivePK4::initialiseModule called
XMLRegistry::initialiseModule called
XMLRegistry: looking for XML files under /opt/darkradiant/share/darkradiant/
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/user.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/colours.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/input.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/menu.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/commandsystem.xml
XMLRegistry: Importing XML file: /home/salamanderrake/.darkradiant/user.xml
XMLRegistry: Importing XML file: /home/salamanderrake/.darkradiant/input.xml
XMLRegistry: Importing XML file: /home/salamanderrake/.darkradiant/filters.xml
CommandSystem::initialiseModule called.
EventManager::initialiseModule called.
EventManager: Critical: No modifiers definitions found!
MouseEventManager: Critical: No button definitions found!
MouseEventManager: Critical: No XYView event definitions found!
MouseEventManager: Critical: No observer event definitions found!
MouseEventManager: Critical: No camera event definitions found!
MouseEventManager: Critical: No camera strafe definitions found!
EventManager successfully initialised.
UIManager::initialiseModule called
MenuManager: Could not find menu root in registry.ToolbarManager: Warning: No toolbars found.
ColourSchemeManager: Loading colour schemes...
ColourSchemeManager: No schemes found...
MainFrameLayoutManager::initialiseModule called.
OrthoviewManager::initialiseModule called.
MainFrame::initialiseModule called.
Clipper::initialiseModule called
GridManager::initialiseModule called.
SceneGraph::initialiseModule called
RadiantSelectionSystem::initialiseModule called.
RadiantModule::initialiseModule called.
EventManager: Event ToggleClipper is not a Toggle.
EventManager: Event MouseTranslate is not a Toggle.
EventManager: Event MouseRotate is not a Toggle.
EventManager: Event MouseDrag is not a Toggle.
PreferenceSystem::initialiseModule called
FileTypes::initialiseModule called.
GameManager: Scanning for game description files: /opt/darkradiant/share/darkradiant/games/
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/doom3-demo.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/quake4.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/stau.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/xreal.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/doom3.game
GameManager: Found game definitions: 
  Doom 3
  Doom 3 Demo
  Quake 4
  Stau
  XreaL

GameManager: Selected game type: Doom 3
GameManager: Querying Windows Registry for game path: HKEY_LOCAL_MACHINE\SOFTWARE\id\Doom 3\InstallPath
GameManager: Windows Registry returned result: 
GameManager: Map path set to /home/salamanderrake/.doom3/base/maps/
GameManager: Prefab path set to /home/salamanderrake/.doom3/base/prefabs/
VFS Search Path priority is: 
- /home/salamanderrake/.doom3/base/
- /usr/local/games/doom3/base/
VFS::initialiseModule called
filesystem initialised
[vfs] searched directory: /home/salamanderrake/.doom3/base/
[vfs] searched directory: /usr/local/games/doom3/base/
[vfs] pak file: /usr/local/games/doom3/base/pak005.pk4
[vfs] pak file: /usr/local/games/doom3/base/game01.pk4
[vfs] pak file: /usr/local/games/doom3/base/game00.pk4
MaterialManager::initialiseModule called
1212 shaders found.
OpenGL::initialiseModule called.
ShaderCache::initialiseModule called.
ColourScheme: Colour selected_brush_camera doesn't exist!
ColourScheme: Colour selected_brush doesn't exist!
Camera::initialiseModule called.
UndoSystem::initialiseModule called
BrushModuleClass::initialiseModule called.
Map::initialiseModule called.
Doom3EntityCreator::initialiseModule called.
EntityClassDoom3::initialiseModule called.
searching vfs directory 'def' for *.def
model model_mp_marine inherits unknown model model_sp_marine
[eclassmgr] Entity class damage_bfg_mp specifies unknown parent class damage_bf
ColourScheme: Colour default_entity doesn't exist!g[eclassmgr] Entity class damage_bfgsplash_mp specifies unknown parent class damage_bfgSplash[eclassmgr] Entity class damage_bullet_chaingun_mp specifies unknown parent class damage_bullet_chaingun[eclassmgr] Entity class damage_bullet_machinegun_mp specifies unknown parent class damage_bullet_machinegun[eclassmgr] Entity class damage_bullet_pistol_mp specifies unknown parent class damage_bullet_pistol[eclassmgr] Entity class damage_chainsaw_mp specifies unknown parent class damage_chainsaw[eclassmgr] Entity class damage_explodingbarrel_mp specifies unknown parent class damage_explodingbarrel[eclassmgr] Entity class damage_fatalfall_mp specifies unknown parent class damage_fatalfall[eclassmgr] Entity class damage_grenadedirect_mp specifies unknown parent class damage_grenadeDirect[eclassmgr] Entity class damage_grenadesplash_inhand_mp specifies unknown parent class damage_grenadeSplash_mp[eclassmgr] Entity class damage_grenadesplash_mp specifies unknown parent class damage_grenadeSplash[eclassmgr] Entity class damage_hardfall_mp specifies unknown parent class damage_hardfall[eclassmgr] Entity class damage_plasmablast_mp specifies unknown parent class damage_plasmablast[eclassmgr] Entity class damage_rocketdirect_mp specifies unknown parent class damage_rocketDirect[eclassmgr] Entity class damage_rocketsplash_mp specifies unknown parent class damage_rocketSplash[eclassmgr] Entity class damage_shotgun_mp specifies unknown parent class damage_shotgun[eclassmgr] Entity class damage_softfall_mp specifies unknown parent class damage_softfall[eclassmgr] Entity class damage_soulblast_mp specifies unknown parent class damage_soulblast[eclassmgr] Entity class damage_soulsplash_mp specifies unknown parent class damage_soulSplash[eclassmgr] Entity class moveable_item_bfg_mp specifies unknown parent class moveable_item_bfg[eclassmgr] Entity class moveable_item_chaingun_mp specifies unknown parent class moveable_item_chaingun[eclassmgr] Entity class moveable_item_chainsaw_mp specifies unknown parent class moveable_item_chainsaw[eclassmgr] Entity class moveable_item_grenades_mp specifies unknown parent class moveable_item_grenades[eclassmgr] Entity class moveable_item_lantern_world specifies unknown parent class moveable_item_default[eclassmgr] Entity class moveable_item_machinegun_mp specifies unknown parent class moveable_item_machinegun[eclassmgr] Entity class moveable_item_pistol_mp specifies unknown parent class moveable_item_pistol[eclassmgr] Entity class moveable_item_plasmagun_mp specifies unknown parent class moveable_item_plasmagun[eclassmgr] Entity class moveable_item_rocketlauncher_mp specifies unknown parent class moveable_item_rocketlauncher[eclassmgr] Entity class moveable_item_shotgun_mp specifies unknown parent class moveable_item_shotgun[eclassmgr] Entity class player_doommarine_mp specifies unknown parent class player_base[eclassmgr] Entity class projectile_bfg_mp specifies unknown parent class projectile_bfg[eclassmgr] Entity class projectile_bullet_machinegun_mp specifies unknown parent class projectile_bullet_machinegun[eclassmgr] Entity class projectile_bullet_pistol_mp specifies unknown parent class projectile_bullet_pistol[eclassmgr] Entity class projectile_bullet_shotgun_mp specifies unknown parent class projectile_bullet_shotgun[eclassmgr] Entity class projectile_chaingunbullet_mp specifies unknown parent class projectile_chaingunbullet[eclassmgr] Entity class projectile_grenade_mp specifies unknown parent class projectile_grenade[eclassmgr] Entity class projectile_plasmablast_mp specifies unknown parent class projectile_plasmablast[eclassmgr] Entity class projectile_rocket_mp specifies unknown parent class projectile_rocket[eclassmgr] Entity class weapon_bfg_mp specifies unknown parent class weapon_bfg[eclassmgr] Entity class weapon_chaingun_mp specifies unknown parent class weapon_chaingun[eclassmgr] Entity class weapon_chainsaw_mp specifies unknown parent class weapon_chainsaw[eclassmgr] Entity class weapon_handgrenade_mp specifies unknown parent class weapon_handgrenade[eclassmgr] Entity class weapon_machinegun_mp specifies unknown parent class weapon_machinegun[eclassmgr] Entity class weapon_pistol_mp specifies unknown parent class weapon_pistol[eclassmgr] Entity class weapon_plasmagun_mp specifies unknown parent class weapon_plasmagun[eclassmgr] Entity class weapon_rocketlauncher_mp specifies unknown parent class weapon_rocketlauncher[eclassmgr] Entity class weapon_shotgun_mp specifies unknown parent class weapon_shotgu
ColourScheme: Colour default_brush doesn't exist!
ColourScheme: Colour light_volumes doesn't exist!
LayerSystem::initialiseModule called.
MapFormatManager::initialiseModule called.
PatchModuleDef2::initialiseModule called.
PatchModuleDef3::initialiseModule called.
Doom3MapLoader: initialiseModule called.
Doom3PrefabLoader: initialiseModule called.
EClassTree::initialiseModule called.
EntityListModule::initialiseModule called
[filters] Loaded 15 filters from registry.
FontManager::initialiseModule called
0 fonts registered.
ImageLoaderBMP::initialiseModule called.
ImageLoaderDDS::initialiseModule called.
ImageLoaderGDK::initialiseModule called.
ImageLoaderJPG::initialiseModule called.
ImageLoaderPCX::initialiseModule called.
ImageLoaderPNG::initialiseModule called.
ImageLoaderTGA::initialiseModule called.
MD5AnimationCache::initialiseModule called.
MapCompiler: initialiseModule called.
MapResourceManager::initialiseModule called.
PicoModelLoader: ModelLoaderASE initialised.
PicoModelLoader: ModelLoaderLWO initialised.
MD5Model::initialiseModule called.
ModelCache::initialiseModule called.
PicoModelLoader: ModelLoader3DS initialised.
PicoModelLoader: ModelLoaderFM initialised.
PicoModelLoader: ModelLoaderMD2 initialised.
PicoModelLoader: ModelLoaderMD3 initialised.
PicoModelLoader: ModelLoaderMDC initialised.
PicoModelLoader: ModelLoaderMS3D initialised.
PicoModelLoader: ModelLoaderOBJ initialised.
PicoModelLoader: ModelLoaderPICOTERRAIN initialised.
Doom3SkinCache::initialiseModule called
[skins] Loading skins.
NamespaceFactory::initialiseModule called.
ParticlesEditor::initialiseModule called.
ParticlesManager::initialiseModule called
Quake4MapLoader: initialiseModule called.
RenderSystemFactory::initialiseModule called.
SceneGraphFactory::initialiseModule called.
ScriptingSystem::initialiseModule called.
ScriptingSystem: Python interpreter initialised.
Registered script file commands/ase_export.py as aseExport
Registered script file commands/shift_textures_randomly.py as ShiftTexturesRandomly
Registered script file commands/select_all_models_of_type.py as SelectAllModelsOfType
Registered script file commands/convert_to_ase_and_replace.py as aseConvertAndReplace
Registered script file commands/example.py as Example
Registered script file commands/shift_textures_upwards_randomly.py as ShiftTexturesUpwardsRandomly
ScriptModule: Found 6 commands.
MenuManager: Could not find insertPath: main/help
MenuManager: Could not find insertPath: main/file/refreshShaders
SelectionSetManager::initialiseModule called.
SoundManager: initialising sound playback
WaveFrontModule::initialiseModule called
MenuManager: Could not find insertPath: main/file/createCM
MenuManager: Could not find insertPath: main/file/exit
darkradiant.log (15,343 bytes)   
salamanderrake

salamanderrake

13.06.2012 16:11

reporter  

darkradiant-1.7.1.log (15,091 bytes)   
Started logging to /home/salamanderrake/.darkradiant/darkradiant.log
Today is: Wed Jun 13 12:01:14 2012
This is DarkRadiant 1.7.1 x64 
gtkmm Version: 2.24.2
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/fonts.so'
Module registered: FontManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/grid.so'
Module registered: Grid
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/vfspk3.so'
Module registered: VirtualFileSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/filetypes.so'
Module registered: FileTypes
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/scenegraph.so'
Module registered: SceneGraph
Module registered: SceneGraphFactory
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/filters.so'
Module registered: FilterSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/uimanager.so'
Module registered: UIManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/mapdoom3.so'
Module registered: Doom3MapLoader
Module registered: Quake4MapLoader
Module registered: Doom3PrefabLoader
Module registered: MapCompiler
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/commandsystem.so'
Module registered: CommandSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/skins.so'
Module registered: ModelSkinCache
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/eventmgr.so'
Module registered: EventManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/eclassmgr.so'
Module registered: EntityClassManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/model.so'
Module registered: ModelLoaderMD3
Module registered: ModelLoader3DS
Module registered: ModelLoaderASE
Module registered: ModelLoaderMS3D
Module registered: ModelLoaderMDC
Module registered: ModelLoaderMD2
Module registered: ModelLoaderFM
Module registered: ModelLoaderLWO
Module registered: ModelLoaderPICOTERRAIN
Module registered: ModelLoaderOBJ
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/md5model.so'
Module registered: ModelLoaderMD5MESH
Module registered: MD5AnimationCache
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/image.so'
Module registered: ImageLoaderTGA
Module registered: ImageLoaderJPG
Module registered: ImageLoaderPNG
Module registered: ImageLoaderPCX
Module registered: ImageLoaderBMP
Module registered: ImageLoaderDDS
Module registered: ImageLoaderGDK
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/particles.so'
Module registered: ParticlesManager
Module registered: ParticlesEditor
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/entitylist.so'
Module registered: EntityList
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/archivezip.so'
Module registered: ArchivePK4
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/shaders.so'
Module registered: MaterialManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/entity.so'
Module registered: Doom3EntityCreator
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/undo.so'
Module registered: UndoSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/xmlregistry.so'
Module registered: XMLRegistry
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/sound.so'
Module registered: SoundManager
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/modules/script.so'
Module registered: ScriptingSystem
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/plugins/eclasstree.so'
Module registered: EClassTree
ModuleLoader: Loading module '/opt/darkradiant/lib/darkradiant/plugins/wavefront.so'
Module registered: WaveFrontExporter
ArchivePK4::initialiseModule called
XMLRegistry::initialiseModule called
XMLRegistry: looking for XML files under /opt/darkradiant/share/darkradiant/
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/user.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/colours.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/input.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/menu.xml
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/commandsystem.xml
XMLRegistry: no user.xml in /home/salamanderrake/.darkradiant/user.xml
CommandSystem::initialiseModule called.
EventManager::initialiseModule called.
EventManager: Critical: No modifiers definitions found!
MouseEventManager: Critical: No button definitions found!
MouseEventManager: Critical: No XYView event definitions found!
MouseEventManager: Critical: No observer event definitions found!
MouseEventManager: Critical: No camera event definitions found!
MouseEventManager: Critical: No camera strafe definitions found!
EventManager successfully initialised.
UIManager::initialiseModule called
MenuManager: Could not find menu root in registry.ToolbarManager: Warning: No toolbars found.
ColourSchemeManager: Loading colour schemes...
ColourSchemeManager: No schemes found...
MainFrameLayoutManager::initialiseModule called.
OrthoviewManager::initialiseModule called.
MainFrame::initialiseModule called.
Clipper::initialiseModule called
GridManager::initialiseModule called.
SceneGraph::initialiseModule called
RadiantSelectionSystem::initialiseModule called.
RadiantModule::initialiseModule called.
EventManager: Event ToggleClipper is not a Toggle.
EventManager: Event MouseTranslate is not a Toggle.
EventManager: Event MouseRotate is not a Toggle.
EventManager: Event MouseDrag is not a Toggle.
PreferenceSystem::initialiseModule called
FileTypes::initialiseModule called.
GameManager: Scanning for game description files: /opt/darkradiant/share/darkradiant/games/
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/doom3-demo.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/quake4.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/xreal.game
XMLRegistry: Importing XML file: /opt/darkradiant/share/darkradiant/games/doom3.game
GameManager: Found game definitions: 
  Doom 3
  Doom 3 Demo
  Quake 4
  XreaL

GameManager: Selected game type: Doom 3
GameManager: Querying Windows Registry for game path: HKEY_LOCAL_MACHINE\SOFTWARE\id\Doom 3\InstallPath
GameManager: Windows Registry returned result: 
GameManager: Map path set to /home/salamanderrake/.doom3/base/maps/
GameManager: Prefab path set to /home/salamanderrake/.doom3/base/prefabs/
VFS Search Path priority is: 
- /home/salamanderrake/.doom3/base/
- /usr/local/games/doom3/base/
VFS::initialiseModule called
filesystem initialised
[vfs] searched directory: /home/salamanderrake/.doom3/base/
[vfs] searched directory: /usr/local/games/doom3/base/
[vfs] pak file: /usr/local/games/doom3/base/pak005.pk4
[vfs] pak file: /usr/local/games/doom3/base/game01.pk4
[vfs] pak file: /usr/local/games/doom3/base/game00.pk4
MaterialManager::initialiseModule called
1212 shaders found.
OpenGL::initialiseModule called.
ShaderCache::initialiseModule called.
ColourScheme: Colour selected_brush_camera doesn't exist!
ColourScheme: Colour selected_brush doesn't exist!
Camera::initialiseModule called.
UndoSystem::initialiseModule called
BrushModuleClass::initialiseModule called.
Map::initialiseModule called.
Doom3EntityCreator::initialiseModule called.
EntityClassDoom3::initialiseModule called.
searching vfs directory 'def' for *.def
model model_mp_marine inherits unknown model model_sp_marine
[eclassmgr] Entity class damage_bfg_mp specifies unknown parent class damage_bf
ColourScheme: Colour default_entity doesn't exist!g[eclassmgr] Entity class damage_bfgsplash_mp specifies unknown parent class damage_bfgSplash[eclassmgr] Entity class damage_bullet_chaingun_mp specifies unknown parent class damage_bullet_chaingun[eclassmgr] Entity class damage_bullet_machinegun_mp specifies unknown parent class damage_bullet_machinegun[eclassmgr] Entity class damage_bullet_pistol_mp specifies unknown parent class damage_bullet_pistol[eclassmgr] Entity class damage_chainsaw_mp specifies unknown parent class damage_chainsaw[eclassmgr] Entity class damage_explodingbarrel_mp specifies unknown parent class damage_explodingbarrel[eclassmgr] Entity class damage_fatalfall_mp specifies unknown parent class damage_fatalfall[eclassmgr] Entity class damage_grenadedirect_mp specifies unknown parent class damage_grenadeDirect[eclassmgr] Entity class damage_grenadesplash_inhand_mp specifies unknown parent class damage_grenadeSplash_mp[eclassmgr] Entity class damage_grenadesplash_mp specifies unknown parent class damage_grenadeSplash[eclassmgr] Entity class damage_hardfall_mp specifies unknown parent class damage_hardfall[eclassmgr] Entity class damage_plasmablast_mp specifies unknown parent class damage_plasmablast[eclassmgr] Entity class damage_rocketdirect_mp specifies unknown parent class damage_rocketDirect[eclassmgr] Entity class damage_rocketsplash_mp specifies unknown parent class damage_rocketSplash[eclassmgr] Entity class damage_shotgun_mp specifies unknown parent class damage_shotgun[eclassmgr] Entity class damage_softfall_mp specifies unknown parent class damage_softfall[eclassmgr] Entity class damage_soulblast_mp specifies unknown parent class damage_soulblast[eclassmgr] Entity class damage_soulsplash_mp specifies unknown parent class damage_soulSplash[eclassmgr] Entity class moveable_item_bfg_mp specifies unknown parent class moveable_item_bfg[eclassmgr] Entity class moveable_item_chaingun_mp specifies unknown parent class moveable_item_chaingun[eclassmgr] Entity class moveable_item_chainsaw_mp specifies unknown parent class moveable_item_chainsaw[eclassmgr] Entity class moveable_item_grenades_mp specifies unknown parent class moveable_item_grenades[eclassmgr] Entity class moveable_item_lantern_world specifies unknown parent class moveable_item_default[eclassmgr] Entity class moveable_item_machinegun_mp specifies unknown parent class moveable_item_machinegun[eclassmgr] Entity class moveable_item_pistol_mp specifies unknown parent class moveable_item_pistol[eclassmgr] Entity class moveable_item_plasmagun_mp specifies unknown parent class moveable_item_plasmagun[eclassmgr] Entity class moveable_item_rocketlauncher_mp specifies unknown parent class moveable_item_rocketlauncher[eclassmgr] Entity class moveable_item_shotgun_mp specifies unknown parent class moveable_item_shotgun[eclassmgr] Entity class player_doommarine_mp specifies unknown parent class player_base[eclassmgr] Entity class projectile_bfg_mp specifies unknown parent class projectile_bfg[eclassmgr] Entity class projectile_bullet_machinegun_mp specifies unknown parent class projectile_bullet_machinegun[eclassmgr] Entity class projectile_bullet_pistol_mp specifies unknown parent class projectile_bullet_pistol[eclassmgr] Entity class projectile_bullet_shotgun_mp specifies unknown parent class projectile_bullet_shotgun[eclassmgr] Entity class projectile_chaingunbullet_mp specifies unknown parent class projectile_chaingunbullet[eclassmgr] Entity class projectile_grenade_mp specifies unknown parent class projectile_grenade[eclassmgr] Entity class projectile_plasmablast_mp specifies unknown parent class projectile_plasmablast[eclassmgr] Entity class projectile_rocket_mp specifies unknown parent class projectile_rocket[eclassmgr] Entity class weapon_bfg_mp specifies unknown parent class weapon_bfg[eclassmgr] Entity class weapon_chaingun_mp specifies unknown parent class weapon_chaingun[eclassmgr] Entity class weapon_chainsaw_mp specifies unknown parent class weapon_chainsaw[eclassmgr] Entity class weapon_handgrenade_mp specifies unknown parent class weapon_handgrenade[eclassmgr] Entity class weapon_machinegun_mp specifies unknown parent class weapon_machinegun[eclassmgr] Entity class weapon_pistol_mp specifies unknown parent class weapon_pistol[eclassmgr] Entity class weapon_plasmagun_mp specifies unknown parent class weapon_plasmagun[eclassmgr] Entity class weapon_rocketlauncher_mp specifies unknown parent class weapon_rocketlauncher[eclassmgr] Entity class weapon_shotgun_mp specifies unknown parent class weapon_shotgu
ColourScheme: Colour default_brush doesn't exist!
ColourScheme: Colour light_volumes doesn't exist!
LayerSystem::initialiseModule called.
MapFormatManager::initialiseModule called.
PatchModuleDef2::initialiseModule called.
PatchModuleDef3::initialiseModule called.
Doom3MapLoader: initialiseModule called.
Doom3PrefabLoader: initialiseModule called.
EClassTree::initialiseModule called.
EntityListModule::initialiseModule called
[filters] Loaded 15 filters from registry.
FontManager::initialiseModule called
0 fonts registered.
ImageLoaderBMP::initialiseModule called.
ImageLoaderDDS::initialiseModule called.
ImageLoaderGDK::initialiseModule called.
ImageLoaderJPG::initialiseModule called.
ImageLoaderPCX::initialiseModule called.
ImageLoaderPNG::initialiseModule called.
ImageLoaderTGA::initialiseModule called.
MD5AnimationCache::initialiseModule called.
MapCompiler: initialiseModule called.
MapResourceManager::initialiseModule called.
PicoModelLoader: ModelLoaderASE initialised.
PicoModelLoader: ModelLoaderLWO initialised.
MD5Model::initialiseModule called.
ModelCache::initialiseModule called.
PicoModelLoader: ModelLoader3DS initialised.
PicoModelLoader: ModelLoaderFM initialised.
PicoModelLoader: ModelLoaderMD2 initialised.
PicoModelLoader: ModelLoaderMD3 initialised.
PicoModelLoader: ModelLoaderMDC initialised.
PicoModelLoader: ModelLoaderMS3D initialised.
PicoModelLoader: ModelLoaderOBJ initialised.
PicoModelLoader: ModelLoaderPICOTERRAIN initialised.
Doom3SkinCache::initialiseModule called
[skins] Loading skins.
NamespaceFactory::initialiseModule called.
ParticlesEditor::initialiseModule called.
ParticlesManager::initialiseModule called
Quake4MapLoader: initialiseModule called.
RenderSystemFactory::initialiseModule called.
SceneGraphFactory::initialiseModule called.
ScriptingSystem::initialiseModule called.
ScriptingSystem: Python interpreter initialised.
Registered script file commands/ase_export.py as aseExport
Registered script file commands/shift_textures_randomly.py as ShiftTexturesRandomly
Registered script file commands/select_all_models_of_type.py as SelectAllModelsOfType
Registered script file commands/convert_to_ase_and_replace.py as aseConvertAndReplace
Registered script file commands/example.py as Example
Registered script file commands/shift_textures_upwards_randomly.py as ShiftTexturesUpwardsRandomly
ScriptModule: Found 6 commands.
MenuManager: Could not find insertPath: main/help
MenuManager: Could not find insertPath: main/file/refreshShaders
SelectionSetManager::initialiseModule called.
SoundManager: initialising sound playback
WaveFrontModule::initialiseModule called
MenuManager: Could not find insertPath: main/file/createCM
MenuManager: Could not find insertPath: main/file/exit
darkradiant-1.7.1.log (15,091 bytes)   
greebo

greebo

28.09.2012 20:08

administrator   ~0004854

Fixed in git commit bf02954789.

Issue History

Date Modified Username Field Change
23.05.2012 06:46 salamanderrake New Issue
23.05.2012 06:46 salamanderrake File Added: darkradiant.log
13.06.2012 16:09 salamanderrake Summary Darkradiant Segmentation Fault => Darkradiant Segmentation Fault MenuManager: Could not find insertPath:
13.06.2012 16:09 salamanderrake Description Updated View Revisions
13.06.2012 16:09 salamanderrake Additional Information Updated View Revisions
13.06.2012 16:11 salamanderrake File Added: darkradiant-1.7.1.log
13.06.2012 16:14 salamanderrake Summary Darkradiant Segmentation Fault MenuManager: Could not find insertPath: => Darkradiant Segmentation Fault == > MenuManager: Could not find insertPath: (etc.)
28.09.2012 20:04 greebo Relationship added duplicate of 0003190
28.09.2012 20:04 greebo Assigned To => greebo
28.09.2012 20:04 greebo Status new => assigned
28.09.2012 20:08 greebo Note Added: 0004854
28.09.2012 20:08 greebo Status assigned => resolved
28.09.2012 20:08 greebo Fixed in Version => 1.8.0
28.09.2012 20:08 greebo Resolution open => fixed
28.09.2012 20:08 greebo Target Version => 1.8.0
28.09.2012 20:09 greebo Relationship added has duplicate 0003204
27.08.2013 14:32 greebo Status resolved => closed