View Issue Details

IDProjectCategoryView StatusLast Update
0003204DarkRadiantDesign/Codingpublic27.08.2013 14:32
Reporterbofh80 Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Platform64bitOSDebain TestingOS Version3.2.0-3-amd64
Fixed in Version1.8.0 
Summary0003204: Segmentation Fault - libgtkmm
DescriptionThe Game Chooser screen comes up . i choose xreal, but choosing d3 and not fix (cos i don't have it.) does the same.
As soon as u press next/finish.

gdb:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff592f6f0 in Gtk::Widget::hide() () from /usr/lib/libgtkmm-2.4.so.1


#0 0x00007ffff592f6f0 in Gtk::Widget::hide() ()
   from /usr/lib/libgtkmm-2.4.so.1
0000001 0x0000000000630b5c in ui::MRU::constructMenu (this=0xb11560)
    at ui/mru/MRU.cpp:195
0000002 0x00000000007c49e0 in Radiant_Initialise () at mainframe_old.cpp:136
0000003 0x000000000054b861 in main (argc=1, argv=0x7fffffffe8d8) at main.cpp:143

Steps To Reproducecompile and run.
Additional InformationSeems to be related to http://bugs.angua.at/view.php?id=3137
duplicate of http://bugs.angua.at/view.php?id=3190
sorry
TagsNo tags attached.

Relationships

duplicate of 0003137 closedgreebo Darkradiant Segmentation Fault == > MenuManager: Could not find insertPath: (etc.) 

Activities

bofh80

bofh80

19.08.2012 01:07

reporter  

darkradiant.log (11,491 bytes)   
Started logging to /home/bofh80/.darkradiant/darkradiant.log
Today is: Sun Aug 19 01:53:15 2012
This is DarkRadiant 1.7.2 x64 
gtkmm Version: 2.24.2
Unable to locate theme engine in module_path: "equinox",
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/archivezip.so'
Module registered: ArchivePK4
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/model.so'
Module registered: ModelLoaderMD3
Module registered: ModelLoader3DS
Module registered: ModelLoaderASE
Module registered: ModelLoaderMS3D
Module registered: ModelLoaderMDC
Module registered: ModelLoaderMD2
Module registered: ModelLoaderFM
Module registered: ModelLoaderLWO
Module registered: ModelLoaderPICOTERRAIN
Module registered: ModelLoaderOBJ
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/image.so'
Module registered: ImageLoaderTGA
Module registered: ImageLoaderJPG
Module registered: ImageLoaderPNG
Module registered: ImageLoaderPCX
Module registered: ImageLoaderBMP
Module registered: ImageLoaderDDS
Module registered: ImageLoaderGDK
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/eclassmgr.so'
Module registered: EntityClassManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/md5model.so'
Module registered: ModelLoaderMD5MESH
Module registered: MD5AnimationCache
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/uimanager.so'
Module registered: UIManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/entitylist.so'
Module registered: EntityList
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/scenegraph.so'
Module registered: SceneGraph
Module registered: SceneGraphFactory
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/grid.so'
Module registered: Grid
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/fonts.so'
Module registered: FontManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/sound.so'
Module registered: SoundManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/undo.so'
Module registered: UndoSystem
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/entity.so'
Module registered: Doom3EntityCreator
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/commandsystem.so'
Module registered: CommandSystem
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/xmlregistry.so'
Module registered: XMLRegistry
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/particles.so'
Module registered: ParticlesManager
Module registered: ParticlesEditor
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/vfspk3.so'
Module registered: VirtualFileSystem
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/skins.so'
Module registered: ModelSkinCache
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/mapdoom3.so'
Module registered: Doom3MapLoader
Module registered: Quake4MapLoader
Module registered: Doom3PrefabLoader
Module registered: MapCompiler
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/script.so'
Module registered: ScriptingSystem
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/filters.so'
Module registered: FilterSystem
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/filetypes.so'
Module registered: FileTypes
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/shaders.so'
Module registered: MaterialManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/modules/eventmgr.so'
Module registered: EventManager
ModuleLoader: Loading module '/usr/local/lib/darkradiant/plugins/wavefront.so'
Module registered: WaveFrontExporter
ModuleLoader: Loading module '/usr/local/lib/darkradiant/plugins/eclasstree.so'
Module registered: EClassTree
ArchivePK4::initialiseModule called
XMLRegistry::initialiseModule called
XMLRegistry: looking for XML files under /usr/local/share/darkradiant/
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/user.xml
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/colours.xml
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/input.xml
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/menu.xml
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/commandsystem.xml
XMLRegistry: no user.xml in /home/bofh80/.darkradiant/user.xml
CommandSystem::initialiseModule called.
EventManager::initialiseModule called.
EventManager: Critical: No modifiers definitions found!
MouseEventManager: Critical: No button definitions found!
MouseEventManager: Critical: No XYView event definitions found!
MouseEventManager: Critical: No observer event definitions found!
MouseEventManager: Critical: No camera event definitions found!
MouseEventManager: Critical: No camera strafe definitions found!
EventManager successfully initialised.
UIManager::initialiseModule called
MenuManager: Could not find menu root in registry.ToolbarManager: Warning: No toolbars found.
ColourSchemeManager: Loading colour schemes...
ColourSchemeManager: No schemes found...
MainFrameLayoutManager::initialiseModule called.
OrthoviewManager::initialiseModule called.
MainFrame::initialiseModule called.
Clipper::initialiseModule called
GridManager::initialiseModule called.
SceneGraph::initialiseModule called
RadiantSelectionSystem::initialiseModule called.
RadiantModule::initialiseModule called.
EventManager: Event ToggleClipper is not a Toggle.
EventManager: Event MouseTranslate is not a Toggle.
EventManager: Event MouseRotate is not a Toggle.
EventManager: Event MouseDrag is not a Toggle.
PreferenceSystem::initialiseModule called
FileTypes::initialiseModule called.
GameManager: Scanning for game description files: /usr/local/share/darkradiant/games/
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/games/xreal.game
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/games/doom3-demo.game
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/games/quake4.game
XMLRegistry: Importing XML file: /usr/local/share/darkradiant/games/doom3.game
GameManager: Found game definitions: 
  Doom 3
  Doom 3 Demo
  Quake 4
  XreaL

GameManager: Selected game type: Doom 3
GameManager: Querying Windows Registry for game path: HKEY_LOCAL_MACHINE\SOFTWARE\id\Doom 3\InstallPath
GameManager: Windows Registry returned result: 
GameManager: Map path set to /home/bofh80/tmp/xreal/xreal/base/maps/
GameManager: Prefab path set to /home/bofh80/tmp/xreal/xreal/base/prefabs/
VFS Search Path priority is: 
- /home/bofh80/tmp/xreal/xreal/base/
- /home/bofh80/tmp/xreal/xreal/base/
- /home/bofh80/tmp/xreal/xreal/base/
VFS::initialiseModule called
filesystem initialised
[vfs] searched directory: /home/bofh80/tmp/xreal/xreal/base/
[vfs] searched directory: /home/bofh80/tmp/xreal/xreal/base/
[vfs] searched directory: /home/bofh80/tmp/xreal/xreal/base/
MaterialManager::initialiseModule called

[shaders] materials/trak6.mtr: shader textures/trak/trak6/base1a already defined.
[shaders] materials/trak6.mtr: shader textures/trak/trak6/wall6 already defined.
[shaders] materials/tables.mtr: table ptfullfade already defined.
[shaders] materials/tables.mtr: table lightning already defined.
[shaders] materials/tables.mtr: table lightning2 already defined.
[shaders] materials/tables.mtr: table ember1 already defined.
[shaders] materials/tables.mtr: table stripAnim16table already defined.
[shaders] materials/tables.mtr: table builduplight already defined.
[shaders] materials/tables.mtr: table builduppulse already defined.
[shaders] materials/tables.mtr: table builduppulse2 already defined.
[shaders] materials/tables.mtr: table xFlickerLight already defined.
[shaders] materials/player_shina.mtr: shader models/players/shina/skin_red already defined.
[shaders] materials/gfx.mtr: shader nailTrail already defined.
[shaders] materials/gfx.mtr: shader powerups/redflag already defined.
[shaders] materials/gfx.mtr: shader powerups/blueflag already defined.
[shaders] materials/lights.mtr: table spark_neontable1 already defined.
1176 shaders found.
OpenGL::initialiseModule called.
ShaderCache::initialiseModule called.
ColourScheme: Colour selected_brush_camera doesn't exist!
ColourScheme: Colour selected_brush doesn't exist!
Camera::initialiseModule called.
UndoSystem::initialiseModule called
BrushModuleClass::initialiseModule called.
Map::initialiseModule called.
Doom3EntityCreator::initialiseModule called.
EntityClassDoom3::initialiseModule called.
searching vfs directory 'def' for *.def[eclassmgr] attribute spawnclass already set on entityclass item_regen
[eclassmgr] attribute dmg already set on entityclass trigger_hurt
[eclassmgr] attribute wait already set on entityclass trigger_multiple

ColourScheme: Colour default_brush doesn't exist!
ColourScheme: Colour light_volumes doesn't exist!
LayerSystem::initialiseModule called.
MapFormatManager::initialiseModule called.
PatchModuleDef2::initialiseModule called.
PatchModuleDef3::initialiseModule called.
Doom3MapLoader: initialiseModule called.
Doom3PrefabLoader: initialiseModule called.
EClassTree::initialiseModule called.
EntityListModule::initialiseModule called
[filters] Loaded 15 filters from registry.
FontManager::initialiseModule called
0 fonts registered.
ImageLoaderBMP::initialiseModule called.
ImageLoaderDDS::initialiseModule called.
ImageLoaderGDK::initialiseModule called.
ImageLoaderJPG::initialiseModule called.
ImageLoaderPCX::initialiseModule called.
ImageLoaderPNG::initialiseModule called.
ImageLoaderTGA::initialiseModule called.
MD5AnimationCache::initialiseModule called.
MapCompiler: initialiseModule called.
MapResourceManager::initialiseModule called.
PicoModelLoader: ModelLoaderASE initialised.
PicoModelLoader: ModelLoaderLWO initialised.
MD5Model::initialiseModule called.
ModelCache::initialiseModule called.
PicoModelLoader: ModelLoader3DS initialised.
PicoModelLoader: ModelLoaderFM initialised.
PicoModelLoader: ModelLoaderMD2 initialised.
PicoModelLoader: ModelLoaderMD3 initialised.
PicoModelLoader: ModelLoaderMDC initialised.
PicoModelLoader: ModelLoaderMS3D initialised.
PicoModelLoader: ModelLoaderOBJ initialised.
PicoModelLoader: ModelLoaderPICOTERRAIN initialised.
Doom3SkinCache::initialiseModule called
[skins] Loading skins.
NamespaceFactory::initialiseModule called.
ParticlesEditor::initialiseModule called.
ParticlesManager::initialiseModule called
Quake4MapLoader: initialiseModule called.
RenderSystemFactory::initialiseModule called.
SceneGraphFactory::initialiseModule called.
ScriptingSystem::initialiseModule called.
ScriptingSystem: Python interpreter initialised.
Registered script file commands/shift_textures_randomly.py as ShiftTexturesRandomly
Registered script file commands/convert_to_ase_and_replace.py as aseConvertAndReplace
Registered script file commands/shift_textures_upwards_randomly.py as ShiftTexturesUpwardsRandomly
Registered script file commands/ase_export.py as aseExport
Registered script file commands/select_all_models_of_type.py as SelectAllModelsOfType
Registered script file commands/example.py as Example
ScriptModule: Found 6 commands.
MenuManager: Could not find insertPath: main/help
MenuManager: Could not find insertPath: main/file/refreshShaders
SelectionSetManager::initialiseModule called.
SoundManager: initialising sound playback
WaveFrontModule::initialiseModule called
MenuManager: Could not find insertPath: main/file/createCM
MenuManager: Could not find insertPath: main/file/exit
darkradiant.log (11,491 bytes)   

Issue History

Date Modified Username Field Change
19.08.2012 01:07 bofh80 New Issue
19.08.2012 01:07 bofh80 File Added: darkradiant.log
19.08.2012 01:11 bofh80 Resolution open => duplicate
19.08.2012 01:13 bofh80 Additional Information Updated View Revisions
28.09.2012 20:09 greebo Relationship added duplicate of 0003137
28.09.2012 20:09 greebo Status new => resolved
28.09.2012 20:09 greebo Fixed in Version => 1.8.0
28.09.2012 20:09 greebo Assigned To => greebo
27.08.2013 14:32 greebo Status resolved => closed