View Issue Details

IDProjectCategoryView StatusLast Update
0003150DarkRadiantDesign/Codingpublic07.01.2016 13:04
Reportergrayman Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.7.0 
Target Version2.0.3Fixed in Version2.0.3 
Summary0003150: "angle" spawnarg disappears when it's set to zero and the entity is moved
DescriptionThe "angle" spawnarg on an entity disappears from the properties list when it's set to 0 and the entity is moved.

This is irritating when you move something and have to change "angle" from 0 to something else and it's no longer displayed.
TagsNo tags attached.

Relationships

related to 0000384 closedgreebo Dragged entity loses angle field 

Activities

grayman

grayman

07.07.2012 18:57

administrator   ~0004700

And what's double irritating is when a TDM entity like path_sit assumes no angle if the "angle" spawnarg has been deleted.

So you have a guard approaching a chair, and the path_sit has an "angle/0" spawnarg, the guard turns to angle 0 before sitting down correctly on the chair.

Now move the path_sit. DR deletes the "angle/0" spawnarg, and now when the guard approaches the chair to sit down, he doesn't turn to angle 0 as before. He just arrives at the chair and sits. So he ends up facing the angle he arrived at the chair with, and may not be sitting on the chair at all.

Issue History

Date Modified Username Field Change
30.05.2012 19:04 grayman New Issue
07.07.2012 18:57 grayman Note Added: 0004700
20.02.2015 17:39 greebo Relationship added duplicate of 0000384
20.02.2015 17:39 greebo Relationship deleted 0000384
20.02.2015 17:40 greebo Relationship added related to 0000384
22.02.2015 12:59 greebo Status new => confirmed
22.02.2015 13:13 greebo Target Version => 2.0.3
22.02.2015 13:13 greebo Assigned To => greebo
22.02.2015 13:13 greebo Status confirmed => assigned
22.02.2015 13:13 greebo Status assigned => resolved
22.02.2015 13:13 greebo Fixed in Version => 2.0.3
22.02.2015 13:13 greebo Resolution open => fixed
07.01.2016 13:04 greebo Status resolved => closed