View Issue Details

IDProjectCategoryView StatusLast Update
0000384DarkRadiantMap Editingpublic07.01.2016 13:04
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.2 
Target Version2.0.3Fixed in Version2.0.3 
Summary0000384: Dragged entity loses angle field
DescriptionThis may extend to other keypairs (though I imagine it is probably due to the nature of angle, rotation, coords); I haven't gone beyond this one at this time.

Create an AI.
Give it an "angle" "180" (or whatever) keypair.
Drag the AI to a new position.

The angle key disappears.

TagsNo tags attached.

Relationships

related to 0003150 closedgreebo "angle" spawnarg disappears when it's set to zero and the entity is moved 

Activities

greebo

greebo

21.10.2007 19:45

administrator   ~0000798

Last edited: 21.10.2007 19:46

I assume you entered the angle keypair manually? After a transformation (this can be a translation or a rotation or both) the rotation matrix is calculated and stored into the spawnargs. Only the "rotation" spawnarg is used to store the actual rotation, the "angle" spawnarg is overwritten (which fixed the weird rotation jumps we had at the beginning if that occurred to you).

I don't know if the code is able to detect translation-only transforms, but given it could, DarkRadiant should check for an existing angle keypair and incorporate it into the resulting rotation matrix. I'll have to check that.

SneaksieDave

SneaksieDave

29.05.2009 00:12

developer   ~0002491

Just a (probably obvious) note: it's not limited to AI
greebo

greebo

22.02.2015 13:27

administrator   ~0007437

Looking at this again, it appears the problem is happening in rotation.h:230, where the "angle" key is set to "0" before writing the rotation matrix to the entity. Setting the "angle" to "0" will fire the key observers, resetting the rotation matrix to identity just before it's written to the entity's key value pairs.

Issue History

Date Modified Username Field Change
21.10.2007 16:13 SneaksieDave New Issue
21.10.2007 18:31 greebo Status new => acknowledged
21.10.2007 19:45 greebo Note Added: 0000798
21.10.2007 19:45 greebo Status acknowledged => confirmed
21.10.2007 19:46 greebo Note Edited: 0000798
29.05.2009 00:12 SneaksieDave Note Added: 0002491
29.05.2009 00:15 SneaksieDave Summary Dragged AI lose angle field => Dragged entity loses angle field
20.02.2015 17:39 greebo Relationship added has duplicate 0003150
20.02.2015 17:39 greebo Relationship deleted has duplicate 0003150
20.02.2015 17:40 greebo Relationship added related to 0003150
22.02.2015 13:27 greebo Note Added: 0007437
22.02.2015 13:28 greebo Assigned To => greebo
22.02.2015 13:28 greebo Status confirmed => assigned
22.02.2015 13:28 greebo Target Version => 2.0.3
22.02.2015 15:55 greebo Status assigned => resolved
22.02.2015 15:55 greebo Fixed in Version => 2.0.3
22.02.2015 15:55 greebo Resolution open => fixed
07.01.2016 13:04 greebo Status resolved => closed