View Issue Details

IDProjectCategoryView StatusLast Update
0003193The Dark ModGUIpublic08.08.2012 19:09
ReporterknymedAssigned Totels 
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003193: numofpages accepts integers only and not alphanumeric strings
DescriptionWhile translating an FM, some books need more pages. The solution would be adding more pages, but this may be a problem because on some languages the FM will shows empty pages.

The solution is to define the argument of "numofpages" in the file .lang but the numofpages only accept integers and not alphanumeric strings like "#str_XXXX"
TagsNo tags attached.

Relationships

child of 0002779 confirmed Translate the menu and HUD into different languages 

Activities

tels

tels

07.08.2012 21:29

developer   ~0004739

Sounds like an easy fix, and should go into v1.08, because otherwise translations are quite hampered for a long time (shortening readables might not be an option, because a lot of languages produce notable longer text than English, even when one tries to be terse).

Just compare "strangulieren" with "strangle" and "fuchsloch" with "foxhole" - French and Italian are even worse.
tels

tels

08.08.2012 19:08

developer   ~0004741

Fixed with change #13088 (main) and #5514 (src).

The fix was more complicated, because readables are handled in the scripts, which lacked an event to translate text. This has now been added. In addition, the SDK now properly relays the "onLanguageChanged" to readables, so they can re-init themselves, including a new count of pages (and reset themselves to page 1).

Issue History

Date Modified Username Field Change
07.08.2012 16:39 knymed New Issue
07.08.2012 21:27 tels Assigned To => tels
07.08.2012 21:27 tels Status new => assigned
07.08.2012 21:29 tels Note Added: 0004739
07.08.2012 21:29 tels Target Version => TDM 1.08
08.08.2012 19:08 tels Note Added: 0004741
08.08.2012 19:08 tels Status assigned => resolved
08.08.2012 19:08 tels Fixed in Version => TDM 1.08
08.08.2012 19:08 tels Resolution open => fixed
08.08.2012 19:09 tels Relationship added child of 0002779