View Issue Details

IDProjectCategoryView StatusLast Update
0000331DarkRadiantGeneralpublic19.01.2008 23:33
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.2 
Target Version0.9.5Fixed in Version0.9.5 
Summary0000331: Cannot set keypair name after one is selected
DescriptionStart up DR anew, create a brush, convert to func_static. Now, put some nonsense keypairs onto it, entered by hand.
"blah" "whatever"
"blah2" "whatever-else"

No problem. Now, reselect your brush and highlight, e.g., the model keypair. This of course populates the typed fields (good). However, select the 'model' edit box, and type "blah3" (adding a new keypair by hand). Now, hit tab to go to the pair field and change that value. The first field changes back to 'model' again. I assume this is happening because of an implicit assignment of this edit box by the listbox selection.

There is a workaround: change the value field first, and then set the key field, and press enter. The new keypair succeeds and is added.
TagsNo tags attached.

Relationships

related to 0000458 closedgreebo ESC to clear selection has lost context 

Activities

orbweaver

orbweaver

18.08.2007 08:11

developer   ~0000734

Confirmed. Tabbing to the value textbox should not result in the key textbox being changed.
greebo

greebo

26.08.2007 15:33

administrator   ~0000741

Resolved. This was caused by the GroupCycle class, which "cycled" the selection even when only 1 item was available for cycling.
SneaksieDave

SneaksieDave

11.10.2007 19:24

developer   ~0000765

Last edited: 11.10.2007 19:27

Hm, I'm still getting this, but I know what's up, something I forgot to mention in the original report (sorry) - keybind conflict. I have GroupCycleForward (you do mention GroupCycle) bound to Tab. I've always had it that way, seems natural to me, to tab through the func_static components. Needless to say this doesn't work.

Is there a way to capture the Tab when the textboxes have focus and suppress it for groupcycling in that case? If so, great, but it's not terribly important - if not, I guess I'll need to think of a new hotkey. ;)

greebo

greebo

11.10.2007 19:34

administrator   ~0000766

I can confirm this issue, it is indeed related to the TAB being caught by both the EntityInspector as well as the EventManager which routes the event to the GroupCycleForward command. I don't know yet how to resolve this, because GTK is already setup to not forward the key events to the EventManager when it can be used in the foremost window (i.e. EntityInspector).
greebo

greebo

03.12.2007 13:32

administrator   ~0000902

I disabled the keystroke propagation for the GroupDialog now, which should the EntityInspector work as expected. Note that this also affects the TextureBrowser, MediaBrowser and Console - when any of these GroupDialog windows are focussed, keystrokes are not propagated to the main window anymore.
SneaksieDave

SneaksieDave

11.12.2007 16:42

developer   ~0000921

Okay, this currently works fine, however: considering the change back in 458, I will have to wait to check this. The hope is that changing 458 back doesn't bring this problem back.

If it does, and there is no other way around it, I'd side with the lesser of two evils, that is leaving it so ESC and TAB DO still propagate around, and if the user doesn't like the way it operates, they should change their group cycle key (as I have, to shift-Tab). And in that case, perhaps the default should change as well.

ESC to clear selection is important. Normal Tab functionality among textboxes is important. These things are fundamental to standard UIs even if they conflict in this case with some DR-specific function.

Issue History

Date Modified Username Field Change
09.07.2007 16:47 SneaksieDave New Issue
13.08.2007 13:38 orbweaver Status new => acknowledged
18.08.2007 08:11 orbweaver Note Added: 0000734
18.08.2007 08:11 orbweaver Status acknowledged => confirmed
26.08.2007 12:47 greebo Status confirmed => assigned
26.08.2007 12:47 greebo Assigned To => greebo
26.08.2007 15:33 greebo Status assigned => resolved
26.08.2007 15:33 greebo Fixed in Version => latest SVN
26.08.2007 15:33 greebo Resolution open => fixed
26.08.2007 15:33 greebo Note Added: 0000741
11.10.2007 19:24 SneaksieDave Status resolved => feedback
11.10.2007 19:24 SneaksieDave Resolution fixed => reopened
11.10.2007 19:24 SneaksieDave Note Added: 0000765
11.10.2007 19:27 SneaksieDave Note Edited: 0000765
11.10.2007 19:34 greebo Note Added: 0000766
03.12.2007 13:32 greebo Note Added: 0000902
03.12.2007 13:32 greebo Status feedback => resolved
03.12.2007 13:32 greebo Fixed in Version 0.9.2 => 0.9.5
03.12.2007 13:32 greebo Resolution reopened => fixed
03.12.2007 13:32 greebo Build => 2633
03.12.2007 13:32 greebo Target Version => 0.9.5
11.12.2007 16:42 SneaksieDave Note Added: 0000921
11.12.2007 16:42 SneaksieDave Relationship added related to 0000458
19.01.2008 23:33 SneaksieDave Status resolved => closed