View Issue Details

IDProjectCategoryView StatusLast Update
0003353The Dark ModSaving/Loadingpublic01.05.2013 23:40
ReporterHis Satanic Majesty Assigned Tograyman  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS VersionXP SP3
Product VersionTDM 1.07 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003353: Crashing Upon Approaching Mine(s) With Lockpicks Drawn To Disarm
DescriptionI'm filing this under "Saving/Loading" because grayman, from his initial tests with the attached quicksave, believes it to be a problem with the quicksave.

"SVN TDM does exhibit the problem. It must have something to do with the savegame not saving properly. If I quicksave, then approach the mine, I can disarm it. If I reload the game and approach the mine again, it crashes."

The manifest problem is as in the Summary: a consistent crashing when approaching the mines to disarm the one real and live one.
Steps To Reproduce1. Load up the quicksave (attached here).
2. Approach them there mines.
3. Git yer lockpicks out to disarm the dangurned thing(s) (only one is really really real it turns out)
4. Crash.
Additional InformationWell the .rar file is apparently just slightly too big for this here bugtracker ... so I'll put this link instead:

https://docs.google.com/file/d/0BwKBIHZZL_nNZGtGbC1DVWhuVXc/edit?usp=sharing
TagsNo tags attached.

Relationships

has duplicate 0003352 closed Crashing Upon Approaching Mine(s) With Lockpicks Drawn To Disarm 

Activities

grayman

grayman

01.05.2013 23:40

administrator   ~0005350

When working on issue 0002478, I applied the save/restore of the mine’s lock to idGuidedProjectile instead of idProjectile. The lock wasn’t getting saved/restored properly, causing the crash.

Moved save/restore code to the correct locations.

Rev. 5747:

Projectile.cpp
FrobLock.cpp

Issue History

Date Modified Username Field Change
23.03.2013 04:37 His Satanic Majesty New Issue
23.03.2013 13:44 grayman Relationship added has duplicate 0003352
25.03.2013 15:24 grayman Assigned To => grayman
25.03.2013 15:24 grayman Status new => assigned
21.04.2013 21:20 grayman Severity normal => crash
01.05.2013 23:40 grayman Note Added: 0005350
01.05.2013 23:40 grayman Status assigned => resolved
01.05.2013 23:40 grayman Resolution open => fixed
01.05.2013 23:40 grayman Fixed in Version => TDM 2.00
01.05.2013 23:40 grayman Target Version => TDM 2.00