View Issue Details

IDProjectCategoryView StatusLast Update
0003370The Dark ModPhysicspublic27.04.2013 17:05
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003370: Moveables can hurt the player and AI
DescriptionMoveables aren't supposed to hurt actors unless there's a lot of mass and velocity involved.

However, it looks like simply walking over moveables can cause damage, and can lead to death.

TagsNo tags attached.

Activities

Springheel

Springheel

23.04.2013 13:44

administrator   ~0005313

I had another incident happen in that same testmap, right in that vicinity of that same candlestick. Is there somethign unusual about that entity, I wonder?
grayman

grayman

23.04.2013 17:38

administrator   ~0005314

The fix for issue 0000578 introduced relative velocity when determining damage when the player or an AI (actors) landed on something.

For some reason, moveables can attain very high velocities for very short durations. If an actor lands on one of these, the damage code can decide that a lot of damage should be applied.

Since the fix for 0000578 was for landing on moving elevators (movers), if we ignore landing on moveables, this solves 0003370’s problem. (And I’m pointedly not going to worry about landing on a moveable crate sitting on a high-velocity elevator.)

Also noticed that the damage code was allowed to execute when a moveable an AI put in motion hit him. Though no damage was being applied, there’s no point in letting the damage code run in this situation.

Rev. 5741:

Actor.cpp
Moveable.cpp

Tested with bug3370.map.
AluminumHaste

AluminumHaste

27.04.2013 17:03

developer   ~0005319

I had this issue too with 1.09. In St.Lucia the board in the beginning of the map in the street. I walked over it and it killed me. Console showed like 300+ dmg.
grayman

grayman

27.04.2013 17:05

administrator   ~0005320

Hopefully it's fixed now.

Issue History

Date Modified Username Field Change
11.04.2013 11:27 grayman New Issue
23.04.2013 13:44 Springheel Note Added: 0005313
23.04.2013 17:38 grayman Note Added: 0005314
23.04.2013 17:38 grayman Assigned To => grayman
23.04.2013 17:38 grayman Status new => resolved
23.04.2013 17:38 grayman Resolution open => fixed
23.04.2013 17:38 grayman Fixed in Version => TDM 2.00
27.04.2013 17:03 AluminumHaste Note Added: 0005319
27.04.2013 17:05 grayman Note Added: 0005320