View Issue Details

IDProjectCategoryView StatusLast Update
0003598DarkRadiantGeneralpublic24.05.2016 13:47
Reportergrayman Assigned To 
PrioritynormalSeveritynormalReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version1.8.1 
Summary0003598: Empty func_statics
DescriptionIf you create a func_static brush, switch to "Select Group Parts" mode, and delete the brush, the func_static object remains behind, even though it has no parts.

If the func_static happens to be in the void (perhaps you were creating something before moving it into the map), dmap claims there's a leak. Since there are no parts to this func_static, you can't see it on the map.

If the func_static happens to be inside the map (not in the void), it becomes a non-contributing object. Dmap doesn't care about it because it's not in the void, so you may never know it's there.
TagsNo tags attached.

Relationships

related to 0004325 closedgreebo Empty func_static entity after switching classname and hitting undo 

Activities

greebo

greebo

23.12.2013 18:38

administrator   ~0006317

>> If you create a func_static brush, switch to "Select Group Parts" mode, and delete the brush, the func_static object remains behind, even though it has no parts.

I can't reproduce this. These are my steps with DR 1.8.0/1.8.1:

- Start DR
- Drag-create a brush
- RMB > Convert to func_static
- ESC to deselect
- Switch to "Select Group Parts" mode
- Select the brush
- Hit Delete
- The func_static is gone too (see also Entity List dialog)
grayman

grayman

23.12.2013 19:08

administrator   ~0006318

I couldn't reproduce it with a new map either.

So there must be some other condition that I didn't notice when I wrote the report.

This isn't the first time I noticed this; I've had to track down and delete several empty func_statics over the past few months. This was just the first time I decided to report it.

Leave this open and when it happens again, I'll attach the offending map.

Thanks.
Spooks

Spooks

23.05.2016 21:02

reporter   ~0008169

I've found a surefire way to reproduce an empty func_static. Tested on both 2.0.3 and 2.0.4 pre8.

- Create a func_static from a brush
- Rename the "classname" argument from "func_static" to "worldspawn" in the entity pane
- Delete the brush
- Undo once, worldspawn brush reappears
- Undo a second time, instead of the brush turning back into a func_static it will turn into an empty FS without any primitives.

The entity list is the only way you can select the FS then.
greebo

greebo

24.05.2016 03:27

administrator   ~0008170

Last edited: 24.05.2016 03:30

View 2 revisions

Wow, a bit complicated but if it's reproducible... since the repro steps are so different to the case described in the original report, I'll open a new issue from your description: 0004325

grayman

grayman

24.05.2016 13:47

administrator   ~0008171

I agree that the example I gave in the OP no longer fails. I'm using pre8.

Issue History

Date Modified Username Field Change
06.11.2013 01:35 grayman New Issue
23.12.2013 18:38 greebo Note Added: 0006317
23.12.2013 18:38 greebo Status new => feedback
23.12.2013 19:08 grayman Note Added: 0006318
23.12.2013 19:08 grayman Status feedback => new
23.05.2016 21:02 Spooks Note Added: 0008169
24.05.2016 03:27 greebo Note Added: 0008170
24.05.2016 03:30 greebo Relationship added related to 0004325
24.05.2016 03:30 greebo Note Edited: 0008170 View Revisions
24.05.2016 03:31 greebo Status new => acknowledged
24.05.2016 08:40 greebo Status acknowledged => closed
24.05.2016 08:40 greebo Resolution open => unable to reproduce
24.05.2016 13:47 grayman Note Added: 0008171