View Issue Details

IDProjectCategoryView StatusLast Update
0003602The Dark ModAIpublic04.10.2017 13:33
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003602: AI continue searching after killing an enemy
DescriptionIt looks odd when one AI kills another, and then continues to look around, telling the intruder to "come out".

Unless there's another enemy in the neighborhood, the victor should immediately drop down out of the searching states, then ramp down normally from there.

This isn't a problem when the player is killed, because the mission ends soon after, and we don't get to see the odd behavior.
TagsNo tags attached.

Relationships

related to 0002917 closedgrayman AI alerted by objects they drop 

Activities

grayman

grayman

18.04.2014 20:33

administrator   ~0006537

The sound of the loser’s falling weapon was triggering an agitated search. Needed to tell the victor that the weapon belonged to the AI he killed so he wouldn’t become alerted.

If more than one AI was battling the loser, the two victors could still stay in Agitated Searching. Two or more AI tend to feed off each other. We’ll let that be.

Rev. 5959:

AI.cpp

Issue History

Date Modified Username Field Change
11.11.2013 03:56 grayman New Issue
18.04.2014 20:33 grayman Note Added: 0006537
18.04.2014 20:33 grayman Assigned To => grayman
18.04.2014 20:33 grayman Status new => resolved
18.04.2014 20:33 grayman Resolution open => fixed
18.04.2014 20:33 grayman Fixed in Version => TDM 2.02
18.04.2014 20:33 grayman Target Version => TDM 2.02
04.10.2017 13:33 nbohr1more Relationship added related to 0002917