View Issue Details

IDProjectCategoryView StatusLast Update
0002917The Dark ModCodingpublic21.12.2018 16:28
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product VersionTDM 1.07 
Target VersionTDM 2.04Fixed in VersionTDM 2.04 
Summary0002917: AI alerted by objects they drop
DescriptionWhen using the drop/detach code in a frame command, AI get alerted by the sound of the thing they are dropping. They need to know that they (or a friend) were responsible, similar (probably) to the code for bumping into objects.
TagsNo tags attached.

Relationships

related to 0003602 resolvedgrayman AI continue searching after killing an enemy 
related to 0003992 resolvedgrayman Dropped weapons should not be ignored by AI 
related to 0003424 resolvedgrayman A group of guards can search for too long 
related to 0002124 new Arrows bouncing off AI armor bypass no_alerts spawnarg 
related to 0003158 resolvedgrayman AI alerted by movable objects they set in motion 

Activities

grayman

grayman

14.11.2011 01:41

administrator   ~0004144

Might be appropriate to use the same fix that was applied to dropping torches when they're doused.
tels

tels

14.11.2011 21:40

developer   ~0004147

As I have no idea what fix was applied to dropping torches, I am probably not qualified working on this :)
nbohr1more

nbohr1more

04.10.2017 13:37

developer   ~0009382

Changes between 2.0 and 2.04 cover most scenarios where this might be possible.

Issue History

Date Modified Username Field Change
13.11.2011 16:37 Springheel New Issue
13.11.2011 16:37 Springheel Status new => assigned
13.11.2011 16:37 Springheel Assigned To => tels
14.11.2011 01:41 grayman Note Added: 0004144
14.11.2011 21:40 tels Note Added: 0004147
14.11.2011 21:40 tels Assigned To tels =>
14.11.2011 21:41 tels Status assigned => new
04.09.2013 13:38 grayman Assigned To => grayman
04.09.2013 13:38 grayman Status new => assigned
04.10.2017 13:33 nbohr1more Relationship added related to 0003602
04.10.2017 13:33 nbohr1more Relationship added related to 0003992
04.10.2017 13:35 nbohr1more Relationship added related to 0003424
04.10.2017 13:36 nbohr1more Status assigned => closed
04.10.2017 13:36 nbohr1more Resolution open => unable to reproduce
04.10.2017 13:36 nbohr1more Fixed in Version => TDM 2.04
04.10.2017 13:36 nbohr1more Target Version => TDM 2.04
04.10.2017 13:37 nbohr1more Note Added: 0009382
04.10.2017 14:37 nbohr1more Relationship added related to 0002124
21.12.2018 16:28 nbohr1more Relationship added related to 0003158