View Issue Details

IDProjectCategoryView StatusLast Update
0004160The Dark ModGraphicspublic29.12.2017 20:32
Reporteruser81Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionduplicate 
PlatformWin32OSWindows Xp/7/8OS Version7 sp1
Product VersionTDM 2.03 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004160: Gamma controls effecting desktop, rather than engine.
DescriptionGot a PM over on MODDB -

quote from
verterpernerbors

"TDM is changing the gamma exponent of the display, instead of changing the gamma exponent of the Direct3D device it uses to render the game?"
Steps To ReproduceJust move the gamma slider.
TagsNo tags attached.

Relationships

related to 0003684 new Investigate GPL Renderer Improvements 
related to 0004705 resolvedstgatilov Soft gamma 
related to 0004545 resolvedstgatilov Gamma and brightness controls have no effect on external monitor 

Activities

nbohr1more

nbohr1more

15.09.2017 04:37

developer   ~0009249

https://www.khronos.org/registry/OpenGL/extensions/I3D/WGL_I3D_gamma.txt ?

Can't find any implementations online...

user81

29.12.2017 19:17

  ~0009927

Isnt this being looked at by Duzenko or stgatilov.
nbohr1more

nbohr1more

29.12.2017 20:14

developer   ~0009929

Duplicate of 4705

See discussion:

http://forums.thedarkmod.com/topic/19239-soft-r-gamma/
duzenko

duzenko

29.12.2017 20:17

developer   ~0009930

Last edited: 29.12.2017 20:32

View 2 revisions

Not exactly a duplicate, though.
I'm not sure about the difference between a display and a Direct3D device, however I suspect that direct3d is irrelevant in TDM since it uses OpenGL

Issue History

Date Modified Username Field Change
01.06.2015 12:00 user81 New Issue
15.09.2017 04:13 nbohr1more Relationship added related to 0004545
15.09.2017 04:37 nbohr1more Note Added: 0009249
24.09.2017 15:26 nbohr1more Relationship added related to 0003684
29.12.2017 19:17 user81 Note Added: 0009927
29.12.2017 20:11 nbohr1more Relationship added related to 0004705
29.12.2017 20:14 nbohr1more Note Added: 0009929
29.12.2017 20:14 nbohr1more Assigned To => duzenko
29.12.2017 20:14 nbohr1more Status new => closed
29.12.2017 20:14 nbohr1more Resolution open => duplicate
29.12.2017 20:14 nbohr1more Fixed in Version => TDM 2.07
29.12.2017 20:14 nbohr1more Target Version => TDM 2.07
29.12.2017 20:17 duzenko Note Added: 0009930
29.12.2017 20:32 duzenko Note Edited: 0009930 View Revisions