View Issue Details

IDProjectCategoryView StatusLast Update
0004545The Dark ModGraphicspublic01.09.2020 16:49
Reportergerv Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Platformx86-64OSLinuxOS VersionUbuntu 16.04
Product VersionTDM 2.05 
Fixed in VersionTDM 2.08 
Summary0004545: Gamma and brightness controls have no effect on external monitor
DescriptionI have a Thinkpad Carbon X1 Gen 4 running Ubuntu 16.04 64-bit. It has a native resolution of 2560x1440. It's connected via a Thinkpad OneLink+ dock to an external monitor, resolution 1920x1200.

When I am using the external monitor, with the internal LCD disabled, the gamma and brightness controls have no effect. They only work when I am using the built-in LCD panel. Restarting TDM also has no effect. The default settings for the external monitor are far too light. I can make things a bit better by setting r_lightScale to 1 or some other value < 2, but that's not supposed to be the way this works, is it?

There seems to be someone else here with a similar problem (comment 0000009):
http://forums.thedarkmod.com/topic/18533-gamma-or-brightness-settings-have-no-effect-on-brightness-on-debian-sid-with-an-sapphire-rx-480/?hl=gamma
Steps To ReproduceAdjust Gamma and Brightness settings while external monitor enabled
TagsNo tags attached.

Relationships

related to 0004160 closedduzenko Gamma controls effecting desktop, rather than engine. 
related to 0004705 resolvedstgatilov Soft gamma 

Activities

duzenko

duzenko

13.06.2017 09:29

developer   ~0008905

Are any Doom-family games able to control gamma/brightness for you?
gerv

gerv

13.06.2017 09:56

reporter   ~0008906

I've not played any other similar games on this machine. Can you tell me where I can easily download and try one out?
duzenko

duzenko

13.06.2017 09:57

developer   ~0008907

Last edited: 13.06.2017 09:58

View 2 revisions

Maybe steam/gog?
Don't know any free games like that except TDM.

gerv

gerv

13.06.2017 10:22

reporter   ~0008908

Ah :-| I try and run only open source software on my machine. Are there no other Doom-engine-based open source games?
nbohr1more

nbohr1more

20.12.2018 16:55

developer   ~0010998

Soft gamma in 2.07 should work on external monitors.

I guess we'd also need a "soft brightness" mode?
duzenko

duzenko

21.12.2018 09:50

developer   ~0011002

Would it make sense to add it where r_lightscale is being used now?
stgatilov

stgatilov

28.02.2020 03:35

administrator   ~0012247

Due to the changes in 0004705, gamma and brightness are now always applied as part of postprocessing shader.
It is highly unlikely that this issue will be present in 2.08.

Issue History

Date Modified Username Field Change
13.06.2017 08:02 gerv New Issue
13.06.2017 09:29 duzenko Note Added: 0008905
13.06.2017 09:56 gerv Note Added: 0008906
13.06.2017 09:57 duzenko Note Added: 0008907
13.06.2017 09:58 duzenko Note Edited: 0008907 View Revisions
13.06.2017 10:22 gerv Note Added: 0008908
15.09.2017 04:13 nbohr1more Relationship added related to 0004160
20.12.2018 16:54 nbohr1more Relationship added related to 0004705
20.12.2018 16:55 nbohr1more Note Added: 0010998
20.12.2018 17:52 nbohr1more Status new => acknowledged
21.12.2018 09:50 duzenko Note Added: 0011002
28.02.2020 03:35 stgatilov Note Added: 0012247
28.02.2020 03:35 stgatilov Assigned To => stgatilov
28.02.2020 03:35 stgatilov Status acknowledged => feedback
01.09.2020 16:49 stgatilov Status feedback => resolved
01.09.2020 16:49 stgatilov Resolution open => fixed
01.09.2020 16:49 stgatilov Fixed in Version => TDM 2.08