View Issue Details

IDProjectCategoryView StatusLast Update
0004230The Dark ModPhysicspublic23.02.2020 17:12
ReporterVanishedOne Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 2.03 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004230: Flinders spawning with no velocity
DescriptionWhen an entity is damaged and flinders are spawned to replace it, they often spawn with no velocity instead of reacting to the force that damaged the entity. In the attached screenshot, I've just fired a fire arrow into the middle of the group of bottles. Some of the ones nearer the edge of the group have flown off believably, but in many cases you just see a broken bottle top sitting on a broken bottle bottom.
Additional InformationA bit of playing with breakables suggests that a single flinder spawns on the ground, 2+ flinders created with flinder_count (as opposed to two separate def_flinders, which can be given unique offsets as seen on the bottles) hover where they spawn. That might be a bug in its own right, or it might be a problem only because they stay put instead of flying off.

http://wiki.thedarkmod.com/index.php?title=Breakable_objects#def_flinder.2C_flinder_offset.2C_flinder_probability_and_flinder_count
TagsNo tags attached.

Relationships

related to 0000677 closedtels Broken Arrow flinders spawn with no inertia/velocity 
related to 0005161 new Would like code support for a better destructable crate. 

Activities

VanishedOne

VanishedOne

09.10.2015 18:02

developer  

flinders.jpg (428,676 bytes)
VanishedOne

VanishedOne

09.10.2015 18:02

developer  

flinders.map (23,616 bytes)
grayman

grayman

23.02.2020 17:12

administrator   ~0012238

Made changes so flinders wouldn’t be stuck together after breakage, allowing them to fly.

Fixed in rev. 8606:

Entity.cpp
Entity.h
Physics_RigidBody.cpp

Issue History

Date Modified Username Field Change
09.10.2015 18:02 VanishedOne New Issue
09.10.2015 18:02 VanishedOne File Added: flinders.jpg
09.10.2015 18:02 VanishedOne File Added: flinders.map
09.10.2015 18:03 VanishedOne Relationship added related to 0000677
09.10.2015 18:05 VanishedOne Additional Information Updated View Revisions
22.02.2020 17:21 VanishedOne Relationship added related to 0005161
23.02.2020 16:23 grayman Assigned To => grayman
23.02.2020 16:23 grayman Status new => assigned
23.02.2020 16:23 grayman Target Version => TDM 2.08
23.02.2020 17:12 grayman Status assigned => resolved
23.02.2020 17:12 grayman Resolution open => fixed
23.02.2020 17:12 grayman Fixed in Version => TDM 2.08
23.02.2020 17:12 grayman Note Added: 0012238