View Issue Details

IDProjectCategoryView StatusLast Update
0004268The Dark ModPhysicspublic05.01.2016 00:53
Reportergrayman Assigned ToSteveL  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product VersionSVN 
Target VersionTDM 2.04 
Summary0004268: Can walk through a door in SVN
DescriptionI was playing Behind Closed Doors using SVN and suddenly noticed that when I entered the Old Mill, the doors weren't highlighting unless I had the handle in the middle of the screen.

I didn't think much of it until I unlocked a door and it opened, passing right through me.

I checked the *.map file, and there's nothing obviously wrong with the door in question (atdm:door_96x48_2hinge).

But this door is solid in 2.03.

Other instances of this door used in the Old Mill exhibit the same problem.
TagsNo tags attached.

Relationships

related to 0004232 resolvedSteveL skins do not change collision data 
related to 0004269 resolvedSteveL Problem walking through furniture 

Activities

grayman

grayman

03.01.2016 01:28

administrator   ~0007940

I deleted the *.cm file and rebuilt it with DMAP using SVN.

The problem went away.

At least temporarily. I'll have to replay the map from the beginning and see if the problem returns.
SteveL

SteveL

04.01.2016 19:36

developer   ~0007977

Duplicate of 0004268, will be fixed with 0004232 (which caused the problem)
AluminumHaste

AluminumHaste

05.01.2016 00:35

developer  

AluminumHaste

AluminumHaste

05.01.2016 00:53

developer   ~0007979

I also have run into this problem while testing Crucible, I found I could walk through more than just doors. Desks, boxes, crates etc. I reported it in the beta testing thread but next revisions fixed the issue.

I'm now running into this problem while playing NHAT campaign. Maybe it's the handle that's used that's causing it? All I know this all works fine under 2.03.

This is what happened while play NHAT just now:

http://www.youtube.com/watch?v=x5QbABO0e54

Using SVN At revision: 14434

Issue History

Date Modified Username Field Change
02.01.2016 22:17 grayman New Issue
02.01.2016 22:31 grayman Relationship added related to 0004269
03.01.2016 01:28 grayman Note Added: 0007940
04.01.2016 18:47 SteveL Assigned To => SteveL
04.01.2016 18:47 SteveL Status new => assigned
04.01.2016 19:08 SteveL Relationship added related to 0004232
04.01.2016 19:36 SteveL Note Added: 0007977
04.01.2016 19:36 SteveL Status assigned => closed
04.01.2016 19:36 SteveL Resolution open => duplicate
05.01.2016 00:35 AluminumHaste File Added: bcd_0_25_5_2015-11-21_19.12.05.jpg
05.01.2016 00:53 AluminumHaste Note Added: 0007979