View Issue Details

IDProjectCategoryView StatusLast Update
0004320DarkRadiantDesign/Codingpublic01.01.2017 18:09
ReporterhNID Assigned Togreebo  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSLinuxOS VersionManjaro 16.06
Product Version2.0.4 
Target Version2.0.4Fixed in Version2.0.4 
Summary0004320: Error compiling in Linux after latest commit to git.
DescriptionI am unable to compile in Linux after commit b3269603e3d8d3aa0edec6eb80b0c3ab787d29b7
""Address 0004316: Patches + Incorrect Shader Paste operations breaks the 3D viewport"

I keep receiving a compile error which stop compilation.

An abridged gcc output leading up to the error is:

make[2]: Entering directory '/home/harry/Builds/darkmod-build/darkradiant2-git/src/DarkRadiant-build/radiant'
  CXX darkradiant-main.o
  CXX darkradiant-RadiantModule.o
  CXX darkradiant-RadiantThreadManager.o
  CXX brush/darkradiant-BrushModule.o
  CXX brush/darkradiant-FixedWinding.o
In file included from ./brush/TextureProjection.h:8:0,
                 from ./brush/Face.h:10,
                 from ./brush/Brush.h:6,
                 from ./brush/BrushNode.h:8,
                 from brush/BrushModule.cpp:11:
./selection/algorithm/Shader.h: In constructor ‘selection::algorithm::InvalidOperationException::InvalidOperationException(const string&)’:
./selection/algorithm/Shader.h:32:39: error: no matching function for call to ‘std::exception::exception(const char*)’
             std::exception(msg.c_str())
                                       ^
In file included from /usr/include/c++/6.1.1/new:40:0,
                 from /usr/include/c++/6.1.1/ext/new_allocator.h:33,
                 from /usr/include/c++/6.1.1/x86_64-pc-linux-gnu/bits/c++allocator.h:33,
                 from /usr/include/c++/6.1.1/bits/allocator.h:46,
                 from /usr/include/c++/6.1.1/memory:63,
                 from ../include/imodule.h:3,
                 from ../include/iregistry.h:3,
                 from brush/BrushModule.h:3,
                 from brush/BrushModule.cpp:1:
/usr/include/c++/6.1.1/exception:63:5: note: candidate: std::exception::exception()
     exception() _GLIBCXX_USE_NOEXCEPT { }
     ^~~~~~~~~
/usr/include/c++/6.1.1/exception:63:5: note: candidate expects 0 arguments, 1 provided
/usr/include/c++/6.1.1/exception:60:9: note: candidate: constexpr std::exception::exception(const std::exception&)
   class exception
         ^~~~~~~~~
/usr/include/c++/6.1.1/exception:60:9: note: no known conversion for argument 1 from ‘const char*’ to ‘const std::exception&’
In file included from brush/TextureProjection.h:8:0,
                 from brush/Face.h:10,
                 from brush/Brush.h:6,
                 from brush/FixedWinding.cpp:3:
./selection/algorithm/Shader.h: In constructor ‘selection::algorithm::InvalidOperationException::InvalidOperationException(const string&)’:
./selection/algorithm/Shader.h:32:39: error: no matching function for call to ‘std::exception::exception(const char*)’
             std::exception(msg.c_str())
                                       ^
In file included from /usr/include/c++/6.1.1/ios:39:0,
                 from /usr/include/c++/6.1.1/istream:38,
                 from ../libs/math/Vector3.h:17,
                 from brush/FixedWinding.h:3,
                 from brush/FixedWinding.cpp:1:
/usr/include/c++/6.1.1/exception:63:5: note: candidate: std::exception::exception()
     exception() _GLIBCXX_USE_NOEXCEPT { }
     ^~~~~~~~~
/usr/include/c++/6.1.1/exception:63:5: note: candidate expects 0 arguments, 1 provided
/usr/include/c++/6.1.1/exception:60:9: note: candidate: constexpr std::exception::exception(const std::exception&)
   class exception
         ^~~~~~~~~
/usr/include/c++/6.1.1/exception:60:9: note: no known conversion for argument 1 from ‘const char*’ to ‘const std::exception&’
Makefile:2450: recipe for target 'brush/darkradiant-FixedWinding.o' failed
make[2]: *** [brush/darkradiant-FixedWinding.o] Error 1
make[2]: *** Waiting for unfinished jobs....
Makefile:2436: recipe for target 'brush/darkradiant-BrushModule.o' failed
make[2]: *** [brush/darkradiant-BrushModule.o] Error 1
make[2]: Leaving directory '/home/harry/Builds/darkmod-build/darkradiant2-git/src/DarkRadiant-build/radiant'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/harry/Builds/darkmod-build/darkradiant2-git/src/DarkRadiant-build'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

Steps To ReproduceTry to compile Dark Radiant git in Linux. Fails with error.
Additional InformationI've attached my config.log if that helps.
Thanks
TagsNo tags attached.

Activities

hNID

hNID

18.05.2016 20:02

reporter  

config.log (513,430 bytes)
greebo

greebo

19.05.2016 16:35

administrator   ~0008150

Last edited: 19.05.2016 16:35

View 2 revisions

Can you check whether editing radiant/selection/algorithm/Shader.h and replacing the std::exception inheritance to std::logic_error solves the problem? The class looks like this after the change:

    class InvalidOperationException : public std::logic_error
    {
    public:
        InvalidOperationException(const std::string& msg) :
            std::logic_error(msg)
        {}
    };

hNID

hNID

19.05.2016 19:30

reporter   ~0008151

Last edited: 19.05.2016 19:31

View 2 revisions

That did the trick! I was able to compile again.

Sorry for not responding sooner I just got your message.

Thanks greebo!

P.S. Still having the python issue as mentioned here:

http://forums.thedarkmod.com/topic/18067-dark-radiant-recent-compile-failure-in-manjaro-linux-partially-solved/

Should I start a new bugtracker over this issue as it doesn't stop compilation as long as I use the sed statement. It would be nice to be able to compile without having to alter your code. It's up to you as I know you have way more important things to work on.

Again thanks!

greebo

greebo

21.05.2016 08:21

administrator   ~0008152

Ok, I've committed the change to git, it should work again now.

The python stuff seems to be a different issue. Don't get your hopes up to high on this one though, as I can't possibly support all these distributions. We usually aim for successful compilation in the Ubuntu mainstream.
greebo

greebo

21.05.2016 08:24

administrator   ~0008153

Resolved in c0dcff74ec8c893021ec9782ef9b6d3d7935ce07

Issue History

Date Modified Username Field Change
18.05.2016 20:02 hNID New Issue
18.05.2016 20:02 hNID File Added: config.log
19.05.2016 16:35 greebo Note Added: 0008150
19.05.2016 16:35 greebo Status new => feedback
19.05.2016 16:35 greebo Note Edited: 0008150 View Revisions
19.05.2016 19:30 hNID Note Added: 0008151
19.05.2016 19:30 hNID Status feedback => new
19.05.2016 19:31 hNID Note Edited: 0008151 View Revisions
21.05.2016 08:21 greebo Note Added: 0008152
21.05.2016 08:24 greebo Note Added: 0008153
21.05.2016 08:24 greebo Status new => resolved
21.05.2016 08:24 greebo Resolution open => fixed
21.05.2016 08:24 greebo Assigned To => greebo
21.05.2016 08:24 greebo Product Version 2.0.3 => 2.0.4
21.05.2016 08:24 greebo Fixed in Version => 2.0.4
21.05.2016 08:24 greebo Target Version => 2.0.4
01.01.2017 18:09 greebo Status resolved => closed