View Issue Details

IDProjectCategoryView StatusLast Update
0004341The Dark ModSoundpublic01.09.2020 16:44
Reportergrayman Assigned Tostgatilov  
PriorityhighSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.04 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0004341: Conversation sound will abort during a save
DescriptionThis popped up during 2.04 beta test.

Spooks said: "Also, any time you quick save while a sound is playing, e.g. a conversation is going on, the sound will cut out. Noticed it ever since I stared testing and iirc I tested it on 2.03 and it happens there too, so I thought to leave it, but I'll mention it, no harm in doing it."
TagsNo tags attached.

Relationships

related to 0004967 closed Quicksave causes disruptions to HUD 

Activities

Spooks

Spooks

08.06.2016 12:12

reporter   ~0008203

I believe any sort of speaker initiated sound will cut out after a quicksave. The wind sound that plays when the doors of the monastery in Exhumed open, for instance, will stop playing when you save.

Loading will actually resume playing the sound from where it left off, even if it cut out at savetime to begin with, so only saving is affected.
nbohr1more

nbohr1more

09.01.2019 20:20

developer   ~0011275

ConversationSystem.cpp has savegame attributes... I wonder why these are failing?
nbohr1more

nbohr1more

22.01.2019 23:24

developer   ~0011478

Last edited: 22.01.2019 23:34

View 2 revisions

A hunch of sorts...

The savegame process calls a sound pause operation but it may be that this is tied to other pause requests.

Related to the topic of "Pause"...

The "pause" system key used to call the pause "event" but is now throwing an unrecognized command. Find out when "Pause" was broken...

stgatilov

stgatilov

01.09.2020 16:44

administrator   ~0012773

Fixed in svn rev 8962.

The status of OpenAL source was checked to see if sound was complete.
This is wrong, because when game is unpaused, all OpenAL sources are usually long finished, since nobody pushed new data to them during pause.

Issue History

Date Modified Username Field Change
07.06.2016 18:58 grayman New Issue
08.06.2016 12:12 Spooks Note Added: 0008203
09.01.2019 20:20 nbohr1more Note Added: 0011275
19.01.2019 16:12 STiFU Relationship added related to 0004967
22.01.2019 23:24 nbohr1more Note Added: 0011478
22.01.2019 23:34 nbohr1more Note Edited: 0011478 View Revisions
04.07.2020 11:04 stgatilov Target Version => TDM 2.09
05.07.2020 03:45 stgatilov Priority normal => high
01.09.2020 16:44 stgatilov Note Added: 0012773
01.09.2020 16:44 stgatilov Assigned To => stgatilov
01.09.2020 16:44 stgatilov Status new => resolved
01.09.2020 16:44 stgatilov Resolution open => fixed
01.09.2020 16:44 stgatilov Fixed in Version => TDM 2.09