View Issue Details

IDProjectCategoryView StatusLast Update
0004402The Dark ModGUIpublic03.01.2018 18:20
Reporterduzenko Assigned Toduzenko  
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004402: Dpi Awareness
DescriptionI have a dpi-scaled win10 system and since the TDM exe does not report the support for dpi scaling it is being scaled automatically resulting in awful blurriness and possible resolution mismatch.
It applies to trunk as well but with X64 for some reasone I cannot workaround it using the compatibility settings for the EXE.
TagsNo tags attached.

Relationships

related to 0004430 assignedduzenko Allow TDM to run on non-primary monitors 
related to 0004724 resolvedstgatilov Investigate "borderless windowed" screen mode 

Activities

duzenko

duzenko

28.10.2016 09:57

developer   ~0008398

Applied to trunk as well - tired of manual compatibility adjustments
duzenko

duzenko

28.10.2016 11:26

developer   ~0008399

Silly me! I did the previous change to the debug configuration. Applied to Release as well now.
duzenko

duzenko

13.11.2016 11:28

developer   ~0008470

They broke dpi scaling again in the last update
TDM compiled on vs2010 won't go fullscreen any more w/o the compatibility flag
nbohr1more

nbohr1more

15.11.2016 14:52

developer   ~0008483

I presume the latest builds have resolved this. Any reason to leave this open?
duzenko

duzenko

21.11.2016 09:40

developer   ~0008517

Last edited: 21.11.2016 09:42

View 2 revisions

Umm...
I have two computers with Win10.
One is ok, but another can't enter full-screen with non-desktop resolution unless I compile with the "Per monitor" dpi flag.
I wonder if it's only a system glitch or we should apply this for everyone.
...
JIC
The lucky pc is 125% scaling, nvidia gtx750ti.
The unlucky one is 150% scaling, intel 5500 (i5 5200U).

nbohr1more

nbohr1more

22.11.2016 17:47

developer   ~0008531

Retargeted to 2.06. Current code is better than we had previously but we should still encourage disabling DPI scaling until this is fully vetted.
duzenko

duzenko

01.12.2016 12:49

developer   ~0008578

Switched to "Per monitor" because of 0004430

Issue History

Date Modified Username Field Change
26.10.2016 14:25 duzenko New Issue
26.10.2016 14:29 duzenko Assigned To => duzenko
26.10.2016 14:29 duzenko Status new => assigned
28.10.2016 09:57 duzenko Note Added: 0008398
28.10.2016 11:26 duzenko Note Added: 0008399
13.11.2016 11:28 duzenko Note Added: 0008470
15.11.2016 14:49 nbohr1more Status assigned => feedback
15.11.2016 14:49 nbohr1more Product Version => SVN
15.11.2016 14:49 nbohr1more Target Version => TDM 2.05
15.11.2016 14:52 nbohr1more Note Added: 0008483
21.11.2016 09:40 duzenko Note Added: 0008517
21.11.2016 09:40 duzenko Status feedback => assigned
21.11.2016 09:42 duzenko Note Edited: 0008517 View Revisions
22.11.2016 17:46 nbohr1more Target Version TDM 2.05 => TDM 2.06
22.11.2016 17:47 nbohr1more Note Added: 0008531
01.12.2016 12:48 duzenko Summary [x64] Dpi Awareness => Dpi Awareness
01.12.2016 12:49 duzenko Note Added: 0008578
01.12.2016 12:49 duzenko Relationship added related to 0004430
01.04.2017 07:02 duzenko Status assigned => resolved
01.04.2017 07:02 duzenko Fixed in Version => TDM 2.06
01.04.2017 07:02 duzenko Resolution open => fixed
03.01.2018 18:20 nbohr1more Relationship added related to 0004724