View Issue Details

IDProjectCategoryView StatusLast Update
0004484The Dark ModGraphicspublic17.11.2017 16:35
Reporternbohr1more Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformALL 
Product VersionTDM 2.05 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004484: Lightgem is visible in mirrors and some subviews
DescriptionIn previous TDM versions, the Lightgem render was below the viewport on the lower left corner of the screen. Some change appears to have moved it into the standard viewport in subviews


Discussion:

http://forums.thedarkmod.com/topic/18438-tdm-205/page-17#entry401427
Steps To Reproduce1) Install "A House of Locked Secrets"
2) Open the console and invoke "map manor"
3) Noclip to the Necklace portal room and activate the portal event
4) Note that the Lightgem now renders in the lower left corner of the screen
Additional InformationI haven't dug into this but my suspicions are:

The "High-DPI scaling fix" moved the screen viewport and the Lightgem render
was moved too...

or the new PortalSky render method is leaving this image in the framebuffer

???
TagsNo tags attached.

Relationships

related to 0004420 closedduzenko Reflective "subview" materials flicker when in close range 
related to 0004485 closedduzenko Script assert fails in House of Locked Secrets 

Activities

duzenko

duzenko

14.02.2017 20:56

developer   ~0008747

That is a rather dark place - I can't see any mirrors here.
Can you point me please.
nbohr1more

nbohr1more

20.02.2017 05:51

developer   ~0008751

Please navigate close to a glowing crystal on the ground with noclip. You will see the lightgem rendered in the lower left corner.
duzenko

duzenko

21.02.2017 20:12

developer   ~0008752

Last edited: 21.02.2017 20:13

View 2 revisions

When I try to noclip below that area it crashes with out of memory for me :(
But players should not normally noclip anywhere?
I am confused because originally it was supposed to be about mirrors, not noclipping to void?
...
Also I am confused about " 3) ...activate the portal event" because I haven't played this map yet.

nbohr1more

nbohr1more

22.02.2017 04:14

developer  

hols_screens.rar (2,155,402 bytes)
nbohr1more

nbohr1more

22.02.2017 04:15

developer  

hols_save.rar (4,369,009 bytes)
nbohr1more

nbohr1more

22.02.2017 04:18

developer   ~0008754

hols_screens attachment has the replication sequence
hols_save is a savegame archive (replicated with the SVN build)

The issue is less pronounced in the SVN build. The lightgem only shows
if you are looking in the direction of the illuminated falling rock and the
portalsky view is black and unobstructed.

To more easily see it, I set tdm_lg_split 0 and tdm_lg_interleave 1
duzenko

duzenko

05.03.2017 07:05

developer   ~0008757

Last edited: 05.03.2017 07:06

View 3 revisions

Many thanks, your save helped a ton.
I expected this was caused by g_enableportalsky 2 but g_enableportalsky 1 changed nothing.
r_showstris 1 produces this: https://s24.postimg.org/5eumbpsxh/Untitled.png. Please note that lightgem render is partially overwritten by map geometry here.
So I think the problem here is player is spawned in a place not fully surrounded by invisible black geometry.
I think we have two workarounds here:
1 - glClear after lightgems pixels are read to mem - quick and easy
2 - add geometry to this particular place in the map - harder but I like it more because (1) will invoke an extra OpenGL call in all other places in all maps. It's a small thing obviosly but we still need to fix the script for that map and I also noticed an "invalid token }" error in the loading log so we have to touch the map anyway.

nbohr1more

nbohr1more

22.05.2017 01:21

developer   ~0008873

Duzenko fixed this in revision 6907

Issue History

Date Modified Username Field Change
13.02.2017 15:02 nbohr1more New Issue
13.02.2017 15:02 nbohr1more Status new => assigned
13.02.2017 15:02 nbohr1more Assigned To => duzenko
13.02.2017 15:17 nbohr1more Additional Information Updated View Revisions
13.02.2017 17:54 nbohr1more Relationship added related to 0004420
14.02.2017 20:56 duzenko Note Added: 0008747
20.02.2017 05:51 nbohr1more Note Added: 0008751
21.02.2017 20:12 duzenko Note Added: 0008752
21.02.2017 20:13 duzenko Note Edited: 0008752 View Revisions
22.02.2017 04:14 nbohr1more File Added: hols_screens.rar
22.02.2017 04:15 nbohr1more File Added: hols_save.rar
22.02.2017 04:18 nbohr1more Note Added: 0008754
05.03.2017 07:04 duzenko Relationship added related to 0004485
05.03.2017 07:05 duzenko Note Added: 0008757
05.03.2017 07:05 duzenko Note Edited: 0008757 View Revisions
05.03.2017 07:06 duzenko Note Edited: 0008757 View Revisions
22.05.2017 01:21 nbohr1more Note Added: 0008873
22.05.2017 01:22 nbohr1more Status assigned => resolved
22.05.2017 01:22 nbohr1more Resolution open => fixed
22.05.2017 01:22 nbohr1more Fixed in Version => TDM 2.06