View Issue Details

IDProjectCategoryView StatusLast Update
0004485The Dark ModScript/Defpublic14.12.2018 05:44
Reporterduzenko Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionwon't fix 
Product VersionTDM 2.05 
Summary0004485: Script assert fails in House of Locked Secrets
DescriptionWhen loading the map House of Locked Secrets in debug mode I can every timer see an assert failing.
This is Script_Interpreter.cpp, line 1049
assert( st->c->value.argSize == func->parmTotal );
TagsNo tags attached.

Relationships

related to 0004484 resolvedduzenko Lightgem is visible in mirrors and some subviews 

Activities

duzenko

duzenko

14.02.2017 20:54

developer   ~0008746

Failing func name is tdm_haunting::LevitateObject
st->c->value.argSize = 0 while func->parmTotal = 4
grayman

grayman

14.02.2017 21:10

administrator   ~0008748

Isn't this a problem in the mission's script function? (i.e. not a TDM problem.)
duzenko

duzenko

14.02.2017 21:40

developer   ~0008749

I don't know. Should we contact the mission author about this?
duzenko

duzenko

05.03.2017 07:04

developer   ~0008756

There is another problem with this map: 0004484
grayman

grayman

24.03.2017 16:02

administrator   ~0008776

@duzenko,

Pls try something.

In the mission, edit the file script/tdm_haunting.script.

Move the function tdm_haunting::LevitateObject() ABOVE the function tdm_haunting::init().

See if you can start the mission using a Debug dll.

There's a mismatch of expected arguments going on with the LO() function (0 != 4), even though LO() is correctly predefined in the 'object tdm_haunting' block. After I moved the function, the argument counts match (4 = 4).

This is the only thing I can find. When I do this, the assert passes.
duzenko

duzenko

24.03.2017 19:51

developer   ~0008778

Last edited: 24.03.2017 19:52

View 2 revisions

@grayman

That fixed it.
Should we now upload the fixed pk4 to TDM servers?

grayman

grayman

24.03.2017 21:56

administrator   ~0008780

No.

I'll contact the mission author. It's up to him whether he wants to make the change.

The crash only occurs when using a debug dll, so only devs will be affected, if they're debugging the mission for some other reason.
duzenko

duzenko

02.04.2017 08:37

developer   ~0008786

Last edited: 02.04.2017 08:47

View 2 revisions

Same problem with:
tdm_frobchild::HighlightGrabber
tdm_fireball::MakeFireball

grayman

grayman

02.04.2017 22:36

administrator   ~0008788

Thanks for finding these.

I checked all the *.script files and found several other instances of threads being called before they're defined.
duzenko

duzenko

01.05.2017 18:29

developer   ~0008820

Same issue with Accountant2
"convbelt::updateLoop" in "script/convbelt.script"
grayman

grayman

16.09.2017 18:41

administrator   ~0009264

Since the TDM code and scripts aren't going to be changed to correct this problem, which is in the mission scripts, I'm taking this out of 2.06.
nbohr1more

nbohr1more

14.12.2018 05:43

developer   ~0010916

Mapper issue. Closing as will not fix.

Issue History

Date Modified Username Field Change
14.02.2017 20:53 duzenko New Issue
14.02.2017 20:54 duzenko Note Added: 0008746
14.02.2017 21:10 grayman Note Added: 0008748
14.02.2017 21:40 duzenko Note Added: 0008749
05.03.2017 07:04 duzenko Note Added: 0008756
05.03.2017 07:04 duzenko Relationship added related to 0004484
24.03.2017 16:02 grayman Note Added: 0008776
24.03.2017 16:02 grayman Assigned To => grayman
24.03.2017 16:02 grayman Status new => assigned
24.03.2017 19:51 duzenko Note Added: 0008778
24.03.2017 19:52 duzenko Note Edited: 0008778 View Revisions
24.03.2017 21:56 grayman Note Added: 0008780
02.04.2017 08:37 duzenko Note Added: 0008786
02.04.2017 08:47 duzenko Note Edited: 0008786 View Revisions
02.04.2017 22:36 grayman Note Added: 0008788
01.05.2017 18:29 duzenko Note Added: 0008820
16.09.2017 18:41 grayman Note Added: 0009264
16.09.2017 18:42 grayman Assigned To grayman =>
16.09.2017 18:42 grayman Status assigned => new
16.09.2017 18:42 grayman Target Version TDM 2.06 =>
14.12.2018 05:43 nbohr1more Note Added: 0010916
14.12.2018 05:44 nbohr1more Assigned To => duzenko
14.12.2018 05:44 nbohr1more Status new => closed
14.12.2018 05:44 nbohr1more Resolution open => won't fix