View Issue Details

IDProjectCategoryView StatusLast Update
0004511The Dark ModModelspublic23.04.2017 15:15
Reportergrayman Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004511: Bad display of certain foliage
DescriptionIn 2.05, this model:

models/darkmod/nature/bush_small03.lwo

using this skin:

nature/long_grass_lightyellow_dense

displays correctly.

In 2.06, the same model with the same skin displays the alpha channel as a black texture.
Steps To ReproduceStart "In Remembrance of Him", go to the first door, and the bush is on the right.
Additional InformationReference the attached pictures.



TagsNo tags attached.

Relationships

related to 0004431 resolvedduzenko Get rid of deprecated OpenGL functions 
related to 0004512 resolvednbohr1more Vegetation LOD needs testing 

Activities

grayman

grayman

21.04.2017 03:27

administrator  

bush_205.jpg (525,025 bytes)
grayman

grayman

21.04.2017 03:28

administrator  

bush_SVN.jpg (520,830 bytes)
duzenko

duzenko

23.04.2017 10:44

developer   ~0008803

Last edited: 23.04.2017 15:15

View 3 revisions

Old alpha test function was GREATER.
New arb shader function is greater or equal (fixed because KIL discard pixels with tex minus const param less than 0).
The bushes that render properly are the ones w/o support for LOD.
In this mission LOD-enabled bushes have 0 as alpha cut-off param that does not agree with the new shader >= func.
Workaround: add 0.5/255 to cutoff param in RB_T_FillDepthBuffer to simulate the > function.

NEEDS TESTING: Vegetation LOD

grayman

grayman

23.04.2017 14:26

administrator   ~0008804

I'm closing this.

Could you file a separate issue for the LOD testing? No one's going to test if this issue is resolved or closed.

Issue History

Date Modified Username Field Change
21.04.2017 03:27 grayman New Issue
21.04.2017 03:27 grayman File Added: bush_205.jpg
21.04.2017 03:28 grayman File Added: bush_SVN.jpg
21.04.2017 03:28 grayman Additional Information Updated View Revisions
23.04.2017 08:09 duzenko Relationship added related to 0004431
23.04.2017 08:09 duzenko Assigned To => duzenko
23.04.2017 08:09 duzenko Status new => assigned
23.04.2017 10:44 duzenko Note Added: 0008803
23.04.2017 10:49 duzenko Note Edited: 0008803 View Revisions
23.04.2017 10:50 duzenko Status assigned => resolved
23.04.2017 10:50 duzenko Fixed in Version => TDM 2.06
23.04.2017 10:50 duzenko Resolution open => fixed
23.04.2017 14:26 grayman Note Added: 0008804
23.04.2017 14:27 grayman Status resolved => closed
23.04.2017 15:14 duzenko Relationship added related to 0004512
23.04.2017 15:15 duzenko Note Edited: 0008803 View Revisions