View Issue Details

IDProjectCategoryView StatusLast Update
0004573The Dark ModCodingpublic15.09.2017 04:58
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.05 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004573: Can't frob purse in The Creeps
DescriptionA purse inside a cabinet is unfrobable in The Creeps.

I checked 2.01 and the purse was okay.

Somewhere between 2.02 and 2.05, we broke the purse's frobability.
TagsNo tags attached.

Relationships

related to 0004494 resolvedgrayman 2.05 prevents frobbing of spilled purse in Accountant 2 
related to 0004150 resolvedSteveL Add a frob box for purses, and regularise key frob distance 
related to 0000642 closed Frob distance is set too high on many objects 

Activities

nbohr1more

nbohr1more

16.07.2017 15:49

developer   ~0009005

Possibly related:

4494

4150
grayman

grayman

16.07.2017 16:06

administrator   ~0009006

Thanks.

Works in 2.04, so Steve's fix (4150) or my fix (4494) caused the problem.
grayman

grayman

16.07.2017 16:19

administrator   ~0009007

Tried SVN.

I can't frob the bottles OR the purse, even when leaning in. This is worse than 2.05.

If I noclip up to the items, I'm able to frob all of them.
grayman

grayman

17.07.2017 15:22

administrator   ~0009009

Purses in 2.04 didn't have a frobbox_size. The Creeps purse is frobable.

The 2.05 fix to 0004150 gave them a frobbox_size of 10. The purse is NOT frobable.

Changing the frobbox_size from 10 to 1 in 2.05 makes the purse frobable again. Any higher frobbox_size makes the purse not frobable.

However, even with this change, neither the purse nor the bottles are frobable in SVN.

Since the only place this can be fixed is in SVN, I have to focus on that.
grayman

grayman

17.07.2017 15:50

administrator   ~0009010

The frob blocker "bureau_frob_blocker11", which the purse and bottles sit on, is meant to keep the player from frobbing items in the upper left drawer.

Since the drawer has a frob controller in it, the frob blocker is unnecessary. Unfortunately, all the prefab desks are built this way.

blocker11, unlike the other frob blockers sitting on the desk surface, has a frobbox_size of 12. In SVN, it looks like this is what's keeping the purse and bottles from being frobable in SVN. When I remove the frobbox_size spawnarg, the items are all frobable.

So the trick will be to figure out why SVN cares more about the frobbox_size setting on the blocker than it has before.
grayman

grayman

19.07.2017 14:36

administrator   ~0009013

Last edited: 19.07.2017 14:39

View 2 revisions

Summary:

2.04 works.
2.05 fails (can frob bottles but not the purse).
SVN fails (can't frob bottles or purse).

2.05 is fixed by reverting the general "frobbox_size 10" change made on purses.

SVN still fails after reverting the 2.05 change. It appears that changes made to idClip::Translation() are causing the problem.

grayman

grayman

20.07.2017 19:04

administrator   ~0009016

Last edited: 20.07.2017 19:05

View 2 revisions

I had to revert code I had committed to fix 0004494.

The true fix for 0004494 was to revert the frobbox_size changes made for 0004150.
I wasn't aware of 0004150 when I worked on 0004494.

By reverting both 0004150 and 0004494 fixes, the problems in The Creeps and Accountant 2 go away.

rev 7042:

Target.cpp

rev 14849:

tdm_loot.def
tdm_moveable_loot.def

Issue History

Date Modified Username Field Change
16.07.2017 15:37 grayman New Issue
16.07.2017 15:37 grayman Status new => assigned
16.07.2017 15:37 grayman Assigned To => grayman
16.07.2017 15:49 nbohr1more Note Added: 0009005
16.07.2017 16:06 grayman Note Added: 0009006
16.07.2017 16:19 grayman Note Added: 0009007
17.07.2017 15:22 grayman Note Added: 0009009
17.07.2017 15:50 grayman Note Added: 0009010
19.07.2017 14:36 grayman Note Added: 0009013
19.07.2017 14:39 grayman Note Edited: 0009013 View Revisions
19.07.2017 16:41 stgatilov Relationship added related to 0004521
20.07.2017 19:04 grayman Note Added: 0009016
20.07.2017 19:04 grayman Status assigned => resolved
20.07.2017 19:04 grayman Resolution open => fixed
20.07.2017 19:04 grayman Fixed in Version => TDM 2.06
20.07.2017 19:05 grayman Note Edited: 0009016 View Revisions
21.07.2017 02:09 stgatilov Relationship deleted related to 0004521
21.07.2017 02:09 stgatilov Relationship added related to 0004494
21.07.2017 02:09 stgatilov Relationship added related to 0004150
15.09.2017 04:58 nbohr1more Relationship added related to 0000642