View Issue Details

IDProjectCategoryView StatusLast Update
0004494The Dark ModCodingpublic21.07.2017 02:09
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.05 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004494: 2.05 prevents frobbing of spilled purse in Accountant 2
DescriptionThere's a safe in Accountant 2 that contains a number of loot items. All of the loot can be frobbed when the safe is open, except for a spilled purse.
Additional InformationThe problem is the spilled purse has two clipmodels, one related to its physical size, and one related to its frob box. The second is much larger, and it clips into the setFrobbox target belonging to the safe's lock.

The safe's lock activates first at spawn time, puts the purse on its list of contained items, and turns off the purse's frobability.

The safe itself activates next at spawn time, finds that the purse isn't frobable, and leaves it off its list of contained items.

When the safe door is opened, only the items on the safe's list return to frobability. Since the purse isn't included, it stays unfrobable.
TagsNo tags attached.

Relationships

related to 0004439 resolvedgrayman problem setting up clipmodel for model models/darkmod/mechanical/switches/lever_small1.lwo 
related to 0004573 resolvedgrayman Can't frob purse in The Creeps 

Activities

grayman

grayman

13.03.2017 18:02

administrator   ~0008765

While building a list of items that are within a target_setFrobable brush, only include those whose physical bounds touch the target brush’s bounds.

Ignore any candidates who are being considered solely on the basis of their frobbox size.

Rev 6775:

Target.cpp
grayman

grayman

20.07.2017 18:47

administrator   ~0009015

This subsequently turned out to be the wrong thing to do.

Unbeknownst to me, the frobbox_size on purses had been changed in 2.05 from 0 to 10.

This was the real cause of the problem.

I've reverted the code change made for 4494 in SVN, reverted the purse frobbox_size back to 0, and now the spilled jewel purse in The Accountant can be frobbed.

Issue History

Date Modified Username Field Change
13.03.2017 15:01 grayman New Issue
13.03.2017 15:01 grayman Status new => assigned
13.03.2017 15:01 grayman Assigned To => grayman
13.03.2017 15:02 grayman Relationship added related to 0004439
13.03.2017 18:02 grayman Note Added: 0008765
13.03.2017 18:02 grayman Status assigned => resolved
13.03.2017 18:02 grayman Resolution open => fixed
13.03.2017 18:02 grayman Fixed in Version => TDM 2.06
20.07.2017 18:47 grayman Note Added: 0009015
21.07.2017 02:09 stgatilov Relationship added related to 0004573