View Issue Details

IDProjectCategoryView StatusLast Update
0004594The Dark ModGUIpublic07.09.2017 14:37
ReporterAluminumHaste Assigned Tograyman  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformX64OSWindowsOS Version7
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004594: Use different splash images depending on resolution aspect ratio
DescriptionSpringheel brought up the need for correction of the default splash screen (clock image) on mission loading. Since it's a circle it's really obvious that's it's stretched in anything but 4:3.

I've uploaded the replacement images (SVN rev 14858)

Grayman will need to create code like the spyglass changes to use the new images.(http://bugs.thedarkmod.com/view.php?id=3807

Rev. 6087:

GameLocal.cpp
GameLocal.h
Player.cpp
Player.h

Rev. 13961:

spyglass.gui
tdm_playertools.script
)

TagsNo tags attached.

Activities

AluminumHaste

AluminumHaste

05.08.2017 12:40

developer   ~0009048

splash.dds and splash_4x3.dds are the same image.
Once code is implemented, we can delete splash.dds
grayman

grayman

05.08.2017 18:10

administrator   ~0009049

Generalized the method name (idGameLocal::DetermineOverlayAspectRatio()) for determining aspect ratio (work done in issue 0003807).

Used that with the new launch_* screens to determine which one to display at loading time.

Rev 7057:

Session.cpp
Player.cpp
Game_local.cpp
Game_local.h

Rev 14861:

loading.gui
AluminumHaste

AluminumHaste

06.08.2017 01:05

developer   ~0009050

I uploaded a new image, launch_16x9tv.dds, which is the aspect you're using.

You'll need 1 more entry in the code, no hurry though, whenever you get a chance.
grayman

grayman

06.08.2017 17:21

administrator   ~0009058

Changes made to accommodate launch_16x9tv.
grayman

grayman

06.09.2017 18:09

administrator   ~0009145

Resolved?
AluminumHaste

AluminumHaste

06.09.2017 20:10

developer   ~0009148

Would need other people to test, works fine at 16x9 for me.
Springheel

Springheel

06.09.2017 21:22

administrator   ~0009149

Looks good for me, but I'm 16x9 too.
AluminumHaste

AluminumHaste

07.09.2017 02:33

developer   ~0009153

I just tried latest SVN build, and now none of it works.
The spyglass is stretched again and the loading screen is back to being stretched.
grayman

grayman

07.09.2017 12:40

administrator   ~0009154

A quick peek shows me 5:4 is wonky, but the others are fine.

I'll do a complete detailed pass in a bit.

What are the settings where you say "none of it works"?
AluminumHaste

AluminumHaste

07.09.2017 13:00

developer   ~0009155

I haven't changed anything with my settings. I just updated SVN and ran DarkMod.exe, and dmapped then ran the map. Now spyglass overlay is stretched as well as loading splash.

Running 1920x1080. Also I don't have a mission currently installed.

Maybe try that
grayman

grayman

07.09.2017 13:09

administrator   ~0009156

Tried 1920x1080.

Spyglass looks fine.

Will go through everything (again).
grayman

grayman

07.09.2017 13:37

administrator   ~0009157

Ok, this is a ton of work to redo all the tests.

What, exactly, is failing?
AluminumHaste

AluminumHaste

07.09.2017 13:46

developer   ~0009158

The issue in having is the game is not selecting the correct splash image, and it's back to being stretched. What revision are you using? I checked out SVN last night, but it might be my local repository. I'll try my backup and see if it's doing the same thing
grayman

grayman

07.09.2017 13:54

administrator   ~0009159

14906

Win32 Binary built from 7120
AluminumHaste

AluminumHaste

07.09.2017 14:17

developer   ~0009160

Okay, that's what I'm using also.
This is the issue I'm having:

Spyglass is stretched: https://imgur.com/K3ME778
Loading splash stretched: https://imgur.com/dR5bXGj
grayman

grayman

07.09.2017 14:19

administrator   ~0009161

What is your monitor resolution?

What resolution settings are you using?
AluminumHaste

AluminumHaste

07.09.2017 14:20

developer   ~0009162

Last edited: 07.09.2017 14:25

View 2 revisions

I renamed my Darkmod.cfg so TDM made a new one and after setting graphics settings back to 16:9 and 1920x1080, the overlays and splash guis are working again.

Strange, I have no idea what could be in the cfg file that would have caused that issue.

EDIT: the differences that stand out for me are:

seta r_useIndexBuffers "1" is set to "0" in the default config file.
seta image_roundDown "0" is set to "1"1 in the default config file.
seta r_fovRatio "1.3333" is set to "0" in the default config file.
seta tdm_lg_split "0" is set to "1" in the default config file.

Everything else is commands or stuff that's unrelated like sound settings.

grayman

grayman

07.09.2017 14:23

administrator   ~0009163

Good.

Can I mark this issue as resolved?
AluminumHaste

AluminumHaste

07.09.2017 14:25

developer   ~0009164

Yes for now, it was a modified config that was causing the broken issue.
AluminumHaste

AluminumHaste

07.09.2017 14:29

developer   ~0009165

The issue was caused by r_fovRatio being set 1.3333, which is strange as 16:9 is 1.3333. Changing that back to 0 fixes the splash being stretched.

Issue History

Date Modified Username Field Change
30.07.2017 21:14 AluminumHaste New Issue
04.08.2017 19:38 grayman Assigned To => grayman
04.08.2017 19:38 grayman Status new => assigned
05.08.2017 12:40 AluminumHaste Note Added: 0009048
05.08.2017 18:10 grayman Note Added: 0009049
05.08.2017 18:10 grayman Status assigned => feedback
05.08.2017 18:10 grayman Resolution open => fixed
05.08.2017 18:10 grayman Fixed in Version => TDM 2.06
06.08.2017 01:05 AluminumHaste Note Added: 0009050
06.08.2017 01:05 AluminumHaste Status feedback => assigned
06.08.2017 17:21 grayman Note Added: 0009058
06.08.2017 17:21 grayman Status assigned => feedback
06.09.2017 18:09 grayman Note Added: 0009145
06.09.2017 20:10 AluminumHaste Note Added: 0009148
06.09.2017 20:10 AluminumHaste Status feedback => assigned
06.09.2017 21:22 Springheel Note Added: 0009149
07.09.2017 02:33 AluminumHaste Note Added: 0009153
07.09.2017 12:40 grayman Note Added: 0009154
07.09.2017 13:00 AluminumHaste Note Added: 0009155
07.09.2017 13:09 grayman Note Added: 0009156
07.09.2017 13:37 grayman Note Added: 0009157
07.09.2017 13:46 AluminumHaste Note Added: 0009158
07.09.2017 13:54 grayman Note Added: 0009159
07.09.2017 14:17 AluminumHaste Note Added: 0009160
07.09.2017 14:19 grayman Note Added: 0009161
07.09.2017 14:20 AluminumHaste Note Added: 0009162
07.09.2017 14:23 grayman Note Added: 0009163
07.09.2017 14:25 AluminumHaste Note Edited: 0009162 View Revisions
07.09.2017 14:25 AluminumHaste Note Added: 0009164
07.09.2017 14:29 AluminumHaste Note Added: 0009165
07.09.2017 14:37 grayman Status assigned => resolved